Teredo Tunneling Adapter will not start

#1
I was trying to hook up my camera, Canon SD 1000, To my laptop, but windows would not recognize it.

I then ran the “Hardware and Devices troubleshooter and got the following result:

“Microsoft Teredo Tunneling Adapter has a drive problem Not Fixed”

I then pulled up the properties display got this result:

General Tab: “This device cannot start (Code 10)

Advanced Tab: In the Property Box “:Network Address” and the Value Box “it was blank

I then tried to update the drive and the result was “The driver is up to date”

I tried uninstalling the driver and re-starting my Laptop. The result was that the listing for “Teredo Adapter” was no longer listed. I then did a system restore and got the listing back

I ran the Microsoft “Fix it” routine. It reloaded the driver and did not help

I have two laptops both running “Windows 7 Home Premium” and both have the same problem.


I need help.
 


#2
I got no help from the Microsoft Help Desk. They wanted $99 to fix my problem with a a 30 day warrant

I asked if this was a software problem and quickly said NO
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.