Terratec Aureon 5.1 PCI - Optical In issue Win7 64

#1
Hi all,

I do a lot of recording to hard disc of LPs and radio shows. For years I've used my Minidisc deck in record mode as an A/D convertor which sends the signal to the optical in on my Aureon 5.1 PCI soundcard. It's a great way to record.

I used this method in XP with no issues, and when the Win 7 RC was released I installed the 32 bit version. No issues, the system worked great. As the RC just expired I bought a copy of Home Premium and installed the 64 bit version. Everything appeared to work fine...until I tried to record.

After selecting the right inputs etc I started recording an LP. It recorded okay, and then I went to edit. Upon playing back the .wav I discovered it had a case of the chipmunks. :frown: Everything was sped up.

An educated guess led me to believe it was a sampling rate issue. A quick calculation (thanks google) told me 44.1/48 = 0.91875.

In Audacity I changed the speed of the file by -9.19% and lo and behold that number seemed to fix it, so it clearly is something to do with sampling rate. I could just keep editing the files, but when compared to a file I previously recorded correctly, the speed adjusted files do not sound as good.

I messed about with every sampling rate selector I could find, both in the C-Media control panel thingy and in Windows' sound control panel. I tried 44.1Khz and 48Khz for the input and the output. No change. It's driving me a bit batty. I am using the latest driver from the Terratec website. I tried uninstalling that driver and using the old XP driver, but that didn't seem to want to install.

If anybody has any ideas on how to fix this I'd be very grateful. I do a lot of needledropping and if I can't fix this I'm going to have to uninstall and go back to 32 bit. :(

Thanks,

Geoff

EDIT: I should add I've tried recording using Audiograbber and Audacity, and they both exhibit the same issue, so it appears to be a problem at driver level, not a software setup issue.
 


Last edited:
#2
Well I fixed this... as I was about to pull the pin on it, I found the previous version of the driver on my hard disk. It's labelled as a driver for Vista 32+64 bit rather than the current Win 7 driver, and is missing the bug that was causing me the sampling rate grief. Very happy to say, problem solved. Doing needledrops as we speak. :D
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.