Windows 7 The Witcher (Enhanced Edition)

Just as an FYI, in one of the recent patches for The Witcher, they removed the copy protection from the game.

via Patch 1.5:
"- Removes copy protection (DRM). Game no longer requires game disc inserted in DVD-ROM in order to play."

windows 7 and witcher enhanced

This game worked on vista when I upgraded to w7 it won't work because of the same issue mentioned. Windows strikes again. That is why i spend most of my time on MAC. Atari or microsft needs ot address this bug. BTW the registry booster advertised when you look for an answer did nothing to fix the problem. As they say windows works great unless you use it.

witcher enhaced on windows 7 soln.

at the site there is a link to disable the program which is what is blocking the game on windows 7. I ran it and the game runs now,. y


Essential Member
Microsoft Community Contributor
I am having the "You have to run this game as Administrator" or something like that problem.

It's been a while since I tried it.
I tried both running the game as Administrator and logging in as Administrator and I still got the same message.

I have tried installing the game several times with the same result.
The game ran fine on my old computer in Windows 7 32 bit but I'm now trying to run the game in Windows 7 64 bit with Direct X 10.

It's the only thing I have found that will not run on my new computer.
I'm running Dragon Age, Aion, Tomb Raider Underworld, and they all work fine.

I don't have a clue as to where to go from here.


Official Tages page for driver download:
TAGES, the AAA Copy Protection System

Download and install the new tages drivers from their site, merely running the executable worked and it reported running, then launch the witcher with zero problems on win7. Seems the default tages driver will not work properly in win7.

This came up when I did a fresh install win7 reported a driver disabled after the install, and I let win7 determine the fix and voila witcher works just fine.


Essential Member
Microsoft Community Contributor

I downloaded and installed the drivers.
I finally have the game up and running.

Thanks for the help.


I am also having problems with The Witcher EE. When I go to start the game, it just tells me that I need to put the original disk in the drive, when in fact it is. Does anyone have any ideas on how to fix this problem? Anyone else having the same issues?
hey I had the same issue with the administratior access and the original disk message, 7 has a problem with the targes drive so you need to get patch 1.5 and eliminate the drive from your system. the patch will also make it so you do not have to use the cd to play. Unfortunately, you may have to uninstall and reinstall the game before you do this, because it may randomly crash on you. but if you do this and have the patch on zip to install right away you should be fine. that last part is unconfirmed as my game is currently randomly crashing, and this is what I have just read from other sources. it plays fine otherwise and I hope this message helps.

Can anyone confirm or deny that this game will run on Windows 7 if purchased digitally through Direct2Drive? The site says that it won't, but I'm reading a lot of stuff here that encourages me to believe that things may have changed. Problem is, you guys are all apparently talking about the on-disc version and I don't know if that would apply to a digital purchase. I'd be really grateful if anyone here could advise me before I make a purchase, thanks!

(Please forgive the unintentional necrobump, but I felt this didn't warrant a new thread. I never played the first Witcher and am just now getting around to looking into it, so this is all new to me.)


Essential Member
Microsoft Community Contributor
Sorry wrong post.

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.