USB MICE UNUSABLE / Error CODE 10 Device Manager (PS/2 Bug)

tomboudiboudi

New Member
Hello everyone!

I'm encountering a really annoying and unpredictable problem: for a reason I ignore, my mice (Mad Catz RAT 7) isn't recognized by Windows and has just stop working.

When I plug it in, the mice's leds lights up 10sec then suddently light off, and the cursor/clics don't move/operate at all.
I've tested my RAT 7 on a different computer (Dell XPS 13 L322X, running Windows 10), it works. Then, I plugged a different mice on my computer (Dell XPS 15 9560, running Windows 10), this one didn't work and wasn't recognized too.
Moreover, all my USB ports works correctly (tested with other stuff like USB Drive, External Drive, External SoundCard, Windows Phone...).

So, the problem is on the software side.

There what my device manager shows:
FileDownloadHandler.ashx


We can see that the RAT 7 is still recognized as the driver is still installed on my computer.
Since, I've tried to uninstall/reinstall this driver, but it didn't change anything to my problem.

On the picture, we can see a "PS/2 compatible mice" that can't actually rune (error code 10):
FileDownloadHandler.ashx


I've tried to uninstall this device from device manager, and plugging again my RAT 7, without success.
I've tried to uninstall everything under "USB bus" including the host one and restart, without success too.


I've tried this tricks too:

_built-in Windows problem/issue solver in administrator mode + Microsoft Fix it tools
_attempt to delete registry keys "Upperfilter"/"Lowerfilter" in LOCAL MACHINE, but those keys appeared to basicaly not exist on my system...
_system restore before the bug appeared
_attempt to repair from a Windows 10 live USB boot

...WITHOUT SUCCESS :'(

I'm asking you now becaus I'm kinda running out of options actually, and I strictly don't want to reinstall/format my system as I've been doing it 2 weeks ago and been reinstalling my whole CAD/DAW software suites...

I'll send you every kind of logs files that could be useful! :)


There is my setup:


Windows 10 x64, 1607 (14393.693)

Dell XPS 15 9560:

Intel i7 6700HQ 2,6 / 3,6 GHz
16Gb ram
GeForce GTX 960M 2Gb DDR5 / Intel Iris 530
SSD Samsung 512Gb
 

kemical

Windows Forum Admin
Staff member
Premium Supporter
Hi,
have tried booting into safe mode? If the mouse runs relatively normal then you know for sure it's a software issue.

What about your other drivers such as USB and chipset? I had a quick look at your drivers and you have some chipset drivers which may be later than your versions?
Support for XPS 13 L322X | Dell UK

Sometimes in Device manager you can accrue lot's of old copies of drivers for various devices and it may help in your instance if they were removed?
Uninstall Hidden Devices, Drivers, and Services

Lastly Mad Catz support looks quite helpful at a glance and might be worth a look through?
Mad Catz Tech Support – Get help with Mad Catz and TRITTON Products | MadCatz.com
 

tomboudiboudi

New Member
Hi kemical and thanks for the answer,


I was about to try a safe mode boot, I'll keep you informed about it.

About the drivers, they are all up to date on my XPS 15 9560. The link you send me isn't for my laptop, but for the other one I used to test my RAT.

I'm not sure I understand what I should with your thing of "hidden/old devices/drivers"... should I remove all the old ones (grayed out in the device manager)? Should I do that in safe mode?

I'm not closed about the idea of asking Mad Catz about my problem, but my problem appears even if I plug in a non-Mad Catz mice, so I seriously doubt that they could help me out...
 
Last edited:

BIGBEARJEDI

Fantastic Member
Premium Supporter
Another thing several of us do use here to troubleshoot this kind of problem, is to download a free copy of Ubuntu Linux and burn onto a blank DVD disc or Flash Drive and boot to it. I've had many computers that wouldn't work with ANY mice, wired or wireless in Windows, and when running from Ubuntu in LiveCD mode (in Memory), the mouse suddenly jumps to life!!:fdance: This tells you that it's a Windows issue or a possible hardware failure such as a failing/faulty RAM Stick or failing/faulty Hard Drive. The Ubuntu bypasses both Windows and the Hard Drive, but not the RAM. So, if your mouse device begins working in Ubuntu; it's most likely a software issue as you surmise; unless of course your Hard Drive is being wonky.o_O We usually recommend that you TEST your Hard Drive first, so if you cannot resolve your hardware using traditional methods of uninstalling/reinstalling drivers, and other driver related repairs such as kemical suggest, you may be looking at a complete Windows Reset or Windows Reinstallation from factory Recovery Media. If your RAT 7 mouse works with Ubuntu, and you can't fix it with driver repair methods, you should test your hard drive, and then apply more aggressive Windows repair or reinstallation techniques. The fact that the mouse works on another Dell PC, means the mouse is good;:) so there is something wrong with your XPS 15 PC.

Before you start any of these repairs, I would strongly urge you to FIRST BACKUP ALL OF YOUR PERSONAL DATA TO EXTERNAL MEDIA! THIS WOULD INCLUDE YOUR LIBRARY FOLDERS FOR DOCUMENTS, PHOTOS, MUSIC, VIDEOS, AND ANY SAVED E-MAILS OR ATTACHMENTS IN ORDER TO AVOID IRRETRIEVABLE DATA LOSS!!
Regardless of the repairs you attempt, and your hesitance to have to rebuild your Windows from scratch, this is a MUST-DO-STEP!!

Next, I'll provide you with the links you need for everything I suggested above here:

LINK TO GET FREE UBUNTU LINUX LIVECD: Download Ubuntu Desktop | Download | Ubuntu

LINK TO TEST YOUR HARD DRIVE: Hard Drive Diagnostic Procedure

LINK TO MY TROUBLESHOOTING GUIDE WHICH INCLUDES COMPLETE STEPS TO REINSTALL YOUR W10: https://windowsforum.com/threads/unclickable-task-bar.222292/#post-676594

If you follow the links above in order, I believe you have a very high probability of solving your mouse issue on your XPS 15.
3 other things to consider:
1.) Did you try a wired mouse such as a Dell, Microsoft, or Logitech mouse on all USB ports on your XPS 15 PC? Did any of these mice work on any or all of the USB ports?
2.) If your RAT 7 mouse fails to work on your XPS 15 with Ubuntu LiveCD (running from Memory), chances are very good that you have a hardware incompatibility within the Motherboard of the XPS 15, and that mouse will never work with that PC!:waah: If you reach this point, you should follow kemical's suggestion to contact Mad Catz, the manufacturer of the Mouse device and ask them for help. They may be able to provide you with a special driver that may work your model Dell PC, or at the very least post a "No-No" message on their support forum or knowledgebase that your Dell XPS 15 does NOT work with the RAT 7 mouse you own.:waah: That way, nobody else will have the problem you encountered. Ideally, it should be labeled as INCOMPATIBLE on the product packaging, though in my experience manufacturers only print COMPATIBLE computer models that are known to work with their device, not the other way around.:scratch:
3.) If #2 occurs to you, and the manufacturer can't help you or provide you a special custom driver for your PC, it might be time to change vendors, and buy a gaming/high performance mouse from another manufacturer, such as Razor!;)

Hope this provides you some further direction.
Best of luck,:encouragement:
<<<<BIGBEARJEDI>>>> ...now Extraordinary Member!

 
Last edited:

tomboudiboudi

New Member
Hello BigBearJedi (you definitely should had a "d" betwin "r" & "J" in your pseudo ;)), and thanks for your answer!


So, I've created a live USB of Ubuntu with Rufus, and I've boot on it.
Guess what...MY DAMN RAT WORKS in Ubuntu! :) (I've bet on that)

I've followed your link about Hard Drive Diag, but I didn't find any kind of diag softwares for my drive because I can't fin my SSD model on Samsung website...
It's a Samsung PM951 NVMe SSD (512gb), maybe you could find some soft for it...


So I tried testing my SSD with these tools:

_ Seagate Seatools: after running "long generic" test, the software showed up my SSD as being 100% good/functionnal
_ CrystalDiskInfo 7.0.5 Shizuku Edition: same, my SSD is 100% correct

So I can't really believe the fact that my SSD is wrong...
I need to say that my RAT used to work heavenly on this computer before yesterday crash.


Unfortunately, I've only tested one different mouse on my computer, a random no-name gamer mouse, because I don't have any other mouse at home :/

I've submitted a ticket on Mad Catz support, waiting for them to send me feedback about it!
 

tomboudiboudi

New Member
Hi bochane and thanks for your answer,

but like I said in my first post:

We can see that the RAT 7 is still recognized as the driver is still installed on my computer.
Since, I've tried to uninstall/reinstall this driver, but it didn't change anything to my problem.

I didn't mention that it was with the most up to date driver from Mad Catz, I thought it was obvious :/
 

bochane

Excellent Member
I didn't mention that it was with the most up to date driver from Mad Catz, I thought it was obvious :/
Sorry, I want to be sure that you installed a freshly downloaded version of that driver.

Has there been some update just before your mouse died? Or did you install something?
 

tomboudiboudi

New Member
Hi Bochane, I finally found the ULTIMATE FIX for my problem, thanks to @PatriciaGuenot from french Microsoft Community!

There is it:

  • disconnect every useless USB devices
  • uninstall completly every antivirus on your system
  • full disk cleanup from disk cleanup utilitary
  • delete C:\$WINDOWS.~BT. if existing
  • Download Windows 10 ISO here: https://www.microsoft.com/fr-fr/software-download/windows10
  • Right-Clic on ISO, "Mount"
  • Inside mounted volume, double clic on "setup" and Windows Upgrade/Repair
Now let the magic happen...

Link to original post (in french): https://answers.microsoft.com/fr-fr/windows/forum/windows_10-hardware/souris-usb-inutilisable-erreur-code-10/f8ce3ed9-df33-4e89-a780-b88a1cdc8e84?tm=1485659397763&rtAction=1485689591580&auth=1
 

bochane

Excellent Member
It sounds like some incompatibilities between drivers....

Don't forget to backup all your user files first
Keep us informed, I will keep my fingers crossed.....

Henk
 

tomboudiboudi

New Member
It sounds like some incompatibilities between drivers....

Don't forget to backup all your user files first
Keep us informed, I will keep my fingers crossed.....

Henk

Yes I think so, drivers incompatibilities is the most probable thing.

Like I said in my previous message, the problem is finally solved, but thanks anyway :)
 
Top