USB port issues/Candidate for moron of the year

Discussion in 'Windows Vista Help and Support' started by tinythinker, Jun 5, 2009.

  1. tinythinker

    tinythinker New Member

    Joined:
    Jun 5, 2009
    Messages:
    4
    Likes Received:
    0
    OK, I doubt this will have a solution that isn't really traumatic. But oh well.

    I was having a problem with some devices that were supposed to be 100% fully compatible with Vista Home Premium on My Dell Inspiron Desktop. Namely a SONY Camcorder that was being incorrectly identified and hence not working with my PC. Sooo, I've been in touch with a Microsoft rep via email. One possible problem I was told may be with corrupt USB drivers/adapters, so her suggestion was to go to Device Manager and under the USB heading turn off all these drivers and then restart Windows. They would be reinstalled or reintialized and then we would see if they had been the problem.

    I don't know why, but I did it.

    And you can guess what has happened.

    Basically, the BIOS system knows and recognizes all the devices, but Windows is now blind to them. So the system will start up, load Windows, and then take me to the screen where you select an account to use/enter password if necessary. But the mouse and keyboard don't get any response. It may very well be that Windows might correct this if I could upload the desktop, but I can't. And I've tried looking at all the things I can do with F2 and the Setup screen when the PC is first powering up, but none of that is helpful.

    Then I get an idea! What if I use an old mouse or keyboard of the PS2 variety (what was used before all peripherals went USB) or find a USB/PS2 adapter. Then I could bypass the blind USB ports, get to the Desktop, and presto, fix the problem.

    But if you look closely, the two round plug-ins on the back, which are the right size for your standard now "classic" mouse port, are in fact not that at all. There is no such port!

    So, once I get to the opening Windows screen, the only input I can give is to hit the power button, which immediately causes the whole PC to power down. Then I can wait a moment or two, hit that button again, and sit and watch the opening Windows screen after it loads up until it enters screensaver mode.

    I am really out of ideas. I can't think of any way to trick or bypass the system to get around this. I did find a way to get the computer to offer to start in safe mode somehow, but it just opened a crappier looking version of the opening Windows screen with still no mouse/keyboard functionality. At one point I had to close down the PC by hitting the power strip switch, which caused the PC to offer to either start normally or run a Windows repair program. I tried 'repair' twice and both times I got some weird gray screen with a big white functional mouse pointer and nothing else, even after waiting for some minutes. But if you choose for it to start normally after a power interruption or just turn it off and on properly, you get back to the regular opening Windows screen.

    Someone suggested doing a reinstall of Windows, but it took me forever to get old files from several years of clutter all organized and loaded to my newish PC so losing all of that data would be a nightmare. Someone else said to do a "dirty" install in order to avoid data loss. I have no idea how to do either.

    System Info:

    Dell Inspiron 530 Desktop running 32bit Windows Vista Home Premium Service Pk 1
     
  2. tinythinker

    tinythinker New Member

    Joined:
    Jun 5, 2009
    Messages:
    4
    Likes Received:
    0
    Eureka! It is fixed.

    So, just in case someone else does something like this...

    The first thing I looked for was some alternative way to boot the system. I knew I used the system restore feature and that there must be some way to repair the problem, but as you can read above, it was a lot of frustration trying to get access. Everyone from the guy at Staples to the my knowledgeable online acquaintances kept suggesting I reinstall Vista, which sounded like a potentially large and complicated thing, especially if you are worried about data loss.

    So I kept hearing about doing a "dirty" installation rather than a "clean" one, but I had no idea what the difference was or how to know I am doing one or the other. Furthermore, the only CD that came with the computer is labeled "Operating System/Reinstallation DVD" and it says right on the CD
    "The software is already installed on your computer. Use this DVD only to reinstall the operating system on a Dell PC."

    "This DVD is not for reinstallation of programs or drivers."
    Says nothing at about repairs, etc. I am desperate at this point, so I put in the CD and turn on the PC and hit F12 as soon as it starts booting. I then chose CDROM from a list of possible alternate boot sources. Now I get a Windows screen with a functional mouse! It explains that I can choose to do an upgrade install (no file loss), a clean install (total files loss), or I can go to repair. OK then, so the upgrade option must be the "dirty" install.

    Only now repair actually works, unlike previously, and gives me a menu of options including going back to a restore point. Now that sounds like the best and safest option, so I choose a restore point from two days ago and...

    *tada*

    It's like my stupid, stupid computer ruining behavior never happened.
     
  3. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,803
    Likes Received:
    1,563
    Hi and welcome to the forum.. :)

    Very glad to hear you got things sorted out and much thanks for posting your solution. As you say, it all adds to the data base of solutions!

    :cool:
     

Share This Page

Loading...