USB printer issues

#1
Hey Guys and Gals, I just upgraded to 7 from Vista (best move made in a long time!!) however the only issue I have run into is with my printer. It is a Lexmark X6150 all in one and when I try to connect it via USB Windows does not even see it. The power is on the printer, I have tried rebooting with it plugged in and without it plugged in I have tried different USB ports I have tried scanning for hardware changes I have tried manually installing it (no USB001 port shows up when setting up new ports) nothing seems to work. Any help would be appreciated.
 


#2
I have tried manually installing it (no USB001 port shows up when setting up new ports) nothing seems to work.


Have you tried this way:


Control Panel > Devices and Printers > Add a Printer > Add a Local Printer > Choose a Printer Port > Use an existing port > USB001(Virtual Printer Port for USB) > Next > In the Manufacturers section, select Lexmark > In the Printers section, look for your printer model and select it. If no such model, select another model number near yours.
 


#3
Thanks for the response!, However I have tried this and the port USB001 does not show up as an option, all I see is LTP and COM ports
 


#4
You probably don't have your printer installed, why there is no port USB001.



Lexmark X6150
 


#5
I attempted to install the printer driver from Lexmark but when I get to the stage when the installer asked how the printer is linked and I click USB the installer does not detect the printer and I can not advance in the installer. The weird thing is that this printer never had issues with Vista.
 


#7
I ran the program and it stated that hardware changes were not detected and to try to scan for new hardware. I did that and it failed to find any new hardware and I tried the driver installer again and It could not detect the printer in the USB port. Thanks for your help so far!!!
 


#8
Well, wanted to let everyone know I finally got this problem fixed. Not quite sure what happened but this is what I did. I got tired of it and tried to connect the printer to the router and set it up as a network printer and when I connected the line from the printer to the router the printer beeped. I tried to see if the computer detected it and It did not. So I unhooked the printer from the router and reconnected it via USB and then the computer detected it and allowed me to install the drivers! Go figure....?
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top