User account missing from login screen

kisokos03

New Member
I cant log in to my main user profile.



Previously I had an issue where I was getting notifications saying to set up Windows Hello, although I already had a pin, and when I tried to create a pin, it would ask for my pin to verify identity then the window would just close. This was the same if I tried to make a pin through Windows settings. I tried to find a solution online and most forums and the likes, including on Microsoft Answers said to delete the contents of the Ngc folder in C:\Windows\ServiceProfiles\LocalService\AppData\Local\Microsoft\Ngc, which would rest pin data and allow me to remake it and Windows to realise this.



Initially it seemed to fix the issue as I did this on my user account and I was now able to set up a pin through Windows settings, however I tried to first relog then restart my PC (just to make sure it worked) but when I tried to log in again, my user account was gone from the login screen, and the only account was the default Windows Administrator account which I had enabled anyway.



From the Admin account I can see my user account, and before restarting it even said it was still logged in, but on clicking on it, it still just takes me to the Administrator login screen with no way to change user.



I tried multiple system restores to even a few days before this happened, but that didnt restore Ngc, and even said that documents werent affected by the restore. I also tried to navigate to where it should've been, and used the 'previous versions'
tab from properties. Here theres actually an older version from before it was deleted but I cant restore or view it, because whether I try to open Ngc directly or from the previous version of the parent folder, access is denied. I cant copy the file or change the permissions or its owner, if I try that I get an error message saying 'The media is write protected', and I cant enter or copy the folder from powershell (if I open the 'previous version' folder and shift right click to open powershell'.



The only way I have managed to in any way get inside the previous version of Ngc was through git bash which I already had on my PC. With that I can do right click>open git bash here, and I can navigate the contents of the Ngc folder and verify that this 'previous version' does actually have all the files.



so just to recap: I deleted the contents of Ngc to reset my pin. I cant restore it through system restore which leaves it unaffected. Although I know previous versions of the folder do contain the deleted files, I have no way to restore them, copy them or save them anywhere on my PC.



Is there any way I can still restore these files, or make Windows re-create them from scratch?

All my user specific files are still there, and the user still exists, I just cant log on to it.
 

bochane

Fantastic Member
I think I would try to save all files, remove that account from the PC and than recreate it...
But I admit it does not explain what is going wrong...
 

ussnorway

Windows Forum Team
Staff member
Premium Supporter
The old account will be incompatible for some reason

I would replace/ remove the hard drive and do a fresh install at this point... Old data can be transferred after

Sent from my SP9 using Windows Forums mobile app
 
Top