Windows 7 Win 7 network issue for steam games

#1
This issue started yesterday, I feel that there is a network OS prob reason being when i play steam games or unreal tournament, i get packet loss.


I tried troubleshooting it by bypassing router and contacting the isp, and they said nothing they could see, but I feel there is some kind a packet loss going on in the game, seems like every 30 or 60 secs i get a 1 sec lag spike.


I feel i pinpointed it down to something in the network settings in win 7 just dont know where to start, can anyone offer any advice ?
 


#2
Problems with online games

Hello,

I have the same problem with online games. With Windows XP I dont have problems.
I am searching for an answer, if someone knows something about it, please leave a help message here.

Games with ping problems:
- Guild Wars
- Warcraft 3

Thank you.
 


#3
Try to deactivate your Windows Firewall, had this problem before, the problem was that Windows didn't show me any warning to let my steam's games have access outside my internet, so sometime, I was able to play, other times I wasn't. It seems Windows had fun to cut my connection sometime, then opened it again, then cut it again, etc, etc.
 


#4
I'm also having this problem. just installed windows 7 RC. Steam was working in the previous windows 7 beta (build 7000)
I've tried forwarding ports, adding stem to allowed list in windows firewall settings and also deactivating windows firewall. No joy :frown:

Any help would be appreciated!
Thanks
 


#5
you LAN or Wireless Drivers aren't optimized to work with this version of Windows 7, it happenned mostly with one of my Wireless card, with XP with was perfect, but with Vista, had lag spike very often. If you do use a Wireless, I suggess you to use your Wired connection, and if it still doesn't work, try to find the most recent driver for them. Maybe something has change between Build 7000 and 7100.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.