Win7 Cannot connect to network Printer on XP os.

Discussion in 'Windows 7 Networking' started by Rodrigo, Jan 11, 2010.

  1. Rodrigo

    Rodrigo New Member

    Joined:
    Jan 11, 2010
    Messages:
    6
    Likes Received:
    0
    My computer running Windows 7 (Home premium x64) is trying to connect to a printer (HP PSC 1410) in my local network which uses Win XP 32 bits.

    I go to "add printer" ----> "network" (it finds it with no problem) ---------------> I select the printer and click "next" ----------------> "cannot find driver for the printer in the network, press browse to find it manually".


    That about sums it up. Anyone with the same problem?


    pd: printer is on sharing mode




    Regards and thanks in advance.
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    First go here and download the drivers for the printer HP Deskjet and Officejet Full Feature Software and Drivers HP PSC 1410 All-in-One Printer - HP Customer Care (United States - English)
    These drivers are for host based printers so you may have to temporarily attach it to your Win7 machine if possible, to save yourself some head scratching and then switch it back to the XP machine once the drivers have been installed and you are able to print successfully from the Win7 machine while it's attached. If this is not an option, please let us know and we'll try a couple work arounds.
     
  3. Rodrigo

    Rodrigo New Member

    Joined:
    Jan 11, 2010
    Messages:
    6
    Likes Received:
    0
    Thanks for your quick reply. I fear this is not an option since the printer is used by quite a few people and detaching it will bring some chaos, not to mention all the wires and stuff you have to go through to do it. If there's an alternative solution which doesn't involve temporarily physically removing the printer i would rather start with that one first, leaving the former for last resource.

    Thanks again
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    OK, let's try.
    First I will assume that you have already downloaded that HP Driver executeable that I linked in my previous post to it's own folder, somewhere on the Windows 7 machine. Now, because it's an executeable you'll need a utility to actually extract the files (the program itself contains an auto extractor, but will just extract to a temp folder somewhere and start the setup process, which we probably don't want to do at this point.) so download and install 7zip
    7-Zip make sure you get the version for 64 or 32 bit depending on your install. Once the install is completed go to the folder you downloaded the HP Drivers to. Right click on the file choose 7zip and choose extract here. It's a big file so it may take a minute or two. Now do this
    Open Devices and Printers
    Select add printer near the top menu bar
    Select add local printer
    Choose Create a new port and local port from drop down arrow Click Next
    In the enter a port name do one of the following
    1. \\MachineNameHostingPrinter\Printer'sShareName or
    2. \\ipaddressOfMachineHostingPrinter\Printer'sShareName
    In the install printer driver dialog box do one of the following
    1. In the left panel select you printer manufacturer and in the right panel select your printer model (to use Win7 native drivers) or
    2. Select the have disk button and direct the install process to the folder where you have download and extracted the Win 7 drivers for your printer.
    Let us know how you're doing
     
  5. Rodrigo

    Rodrigo New Member

    Joined:
    Jan 11, 2010
    Messages:
    6
    Likes Received:
    0
    I followed your instructions step by step and used the windows native 7 drivers for the "HP Deskjet 1400 series" instead of the "have disk" button. Worked wonders!!!

    I'm deeply grateful for your time and quickness in solving my problem. Hats off for you.



    Best regards,
     
  6. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Glad to hear you've resolved your issue. Thanks for posting back and letting us know. Thank you, for becomming a member here and please hang around, share your experiences and perhaps help another member with similar problems.
     
  7. benny

    benny New Member

    Joined:
    Jan 18, 2010
    Messages:
    6
    Likes Received:
    0
    Hi

    I am having similar trouble as what was resolved with the OP.

    However my particular problem is that the driver for the printer is actually a Vista64 driver (no win7) and I get a compatability error when I select the INF file upon trying to connect the \\hostpc\sharedprintername.

    Do you have any suggestions?


    Details:
    I'm trying to connect a Epson Stylus RX630 connected via USB to a desktop running XP32 SP3, over a WLAN, to my laptop, a shiny new G51J ;) running Win7HP64.
    There are no Win7 drivers at all for the printer, vista64 is the closest I can get.
    I had this setup up and going in 2 minutes from my old laptop (which ran XP32 as well)
    edit: some more details:
    I directly connected the printer to my laptop via USB, windows update found and automatically installed drivers for it.
     
    #7 benny, Jan 18, 2010
    Last edited: Jan 19, 2010
  8. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Benny:
    Hello and welcome to the forums. Is the issue resolved, have you moved the printer back to the XP machine and is your Asus laptop printing to it across the network now? Very nice laptop by the way. Let us know if you are still having problems.
     
  9. benny

    benny New Member

    Joined:
    Jan 18, 2010
    Messages:
    6
    Likes Received:
    0
    thanks for your reply - sorry I think I wasnt clear, can't install over the network, but when directly connected Windows Update finds and installs automatically a driver so I can use the printer on the laptop.

    I will poke around to see where(if) Windows Update saved the driver on the hard drive. I will also get in touch with Epson - Windows update must be getting its driver from somewhere!

    I will post here again after trying these things
     
  10. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    If you have had it installed and working on the Windows 7 machine with a direct connection, then you should be able to use the process described above in post #4 and select epson in the left panel and scroll up and down in the right panel, your driver should be there. Try it and let us know
     
  11. benny

    benny New Member

    Joined:
    Jan 18, 2010
    Messages:
    6
    Likes Received:
    0
    Thank you for your help, it's working

    It was only when I tried using the option "Use existing port" -> "\\hostWinXP\EpsonRX630" that the box came up allowing me to select Epson on the left and the printer model on the right (all other times it went straight to prompting for the INF file as though I had clicked "have disk"), and I assume it used the driver installed on my laptop which was called "Epson Stylus Photo RX630 (M)" - I have no idea why the (M) is there or what it means. I think the "existing port" was created when I tried last time before cancelling when it rejected the INF from the downloaded vista64 driver.
     
  12. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Glad to hear you got it working. Thanks for posting back and letting us know. The (M) designation often represents (Mobile) and perhaps that's the case in your instance since it is a laptop. Not completely sure. Thanks again.
     

Share This Page

Loading...