Windows 7 compatibility failure

Discussion in 'Windows 7 Help and Support' started by Ortus, Jan 23, 2009.

  1. Ortus

    Ortus New Member

    Joined:
    Jan 23, 2009
    Messages:
    8
    Likes Received:
    0
    Windows 7 compatibility failure SOLVED!!

    Hi There!

    I've been running Windows 7 Beta 1 Build 7000 since the release, without any major issues.
    But now I have a problem that's really annoying, and I just can't seem to fix it.

    I just bought the game Grand Theft Auto IV and I was happy to finally test it out. But the game doesn't work, well okey, I think and I start to do a little research. After five minutes of searching the net I can conclude that I need to run it under the compatibility mode "Windows Vista".

    I go back to the dvd-folder and change this in the GTA IV setup.exe, but in the back of my head I suspect that this is not going to work since I've had alot of problems with W7 not working in compatibility modes. And all my expectations were true, it did not work.
    The message I recieve follows.. "The application failed to initialize properly (0xc0000005). Click OK to terminate the application"
    This is not the first time this message appears when I try to run a program in compatibility mode. I've tested to combine it with "Run as an Administrator" and I've also tried to run it under other compatibility modes, but still, same message.

    Please help me out here, so my money wont be a waste.

    Greetings
    (or the way we say it in Sweden..)
    Med Vänliga Hälsningar
    Mattias


    EDIT: I solved the problem by reinstalling my Windows 7 Beta. Now everything works out.
     
    #1 Ortus, Jan 23, 2009
    Last edited: Jan 24, 2009
  2. bboy500

    bboy500 New Member

    Joined:
    Jan 16, 2009
    Messages:
    204
    Likes Received:
    3
    run autorun DO NOT RUN SETUP!. autorun isntalls more files then setup and without those files it will not work. also i did windows xp sp2 mode and it worked flawlessly after installation on windows 7 32 bit

    rep me if i helped you =D (i want more rep T.T)
     
    #2 bboy500, Jan 23, 2009
    Last edited: Jan 29, 2009
  3. Ortus

    Ortus New Member

    Joined:
    Jan 23, 2009
    Messages:
    8
    Likes Received:
    0
    Yes I am awared of this and the problem still remains. You see.. If I just click the Autorun the setup will tell me that GTA IV is not compatible with GTA IV. This is why I need to run it in Windows Vista compatibility mode. And that's the thing that is not working.

    Thanks Anyways

    EDIT: The Social Club is installed but not the game, when the game is about to install the setup tells me that it's not compatible.
     
  4. bboy500

    bboy500 New Member

    Joined:
    Jan 16, 2009
    Messages:
    204
    Likes Received:
    3
    yes to fix that run it under windows xp sp2 mode! im sure it will work for you.

    and make sure to go where your setup .exe is. right click it and select properties. select compatibilty and make sure windows xp sp2 is checked and run as admin is check then clik apply, ok and open utorun and try again. this should work
     
    #4 bboy500, Jan 23, 2009
    Last edited: Jan 29, 2009
  5. Ortus

    Ortus New Member

    Joined:
    Jan 23, 2009
    Messages:
    8
    Likes Received:
    0
    I still get the error when I try to change compatibility modes.
     
  6. montyuk

    montyuk New Member

    Joined:
    Jan 22, 2009
    Messages:
    166
    Likes Received:
    2
    i dont suppose you've either used a reg hack or another program to remove the watermark from the desktop?
    these are known killers of the backwards compatibility.
     
  7. Ortus

    Ortus New Member

    Joined:
    Jan 23, 2009
    Messages:
    8
    Likes Received:
    0
    Actually I have removed the watermark. I'll try to restore it.
     
  8. blakegriplingph

    blakegriplingph New Member

    Joined:
    Jan 25, 2009
    Messages:
    42
    Likes Received:
    0
    Sorry for the bump, but I found out that you can still apply the patch and keep the compatibility mode at the same time. After a few hours of googling around and stuff, it turns out that in order for user32.dll and/or user32.dll.mui to be modded, you need to change ownership and permissions to the file. By default, system files are owned by NT SERVICE\TrustedInstaller. What the watermark hack does is to change the ownership of the file to the user, but the guy behind it must have forgotten to add some code for the permissions to be back to the default values.

    What I did was to open an untouched DLL file, look at its permission settings, and apply the same values to the affected DLLs. And there you go! No more annoying application failure errors whenever you try to use compatibility mode in a patched W7 install...
     
  9. shabamabam

    shabamabam New Member

    Joined:
    Mar 19, 2009
    Messages:
    2
    Likes Received:
    0
    I am having trouble opening programs setup.exe due to compatibility. HOw do you change the DLL file?
     

Share This Page

Loading...