Windows 7 - Erratic Recognition of External USB Hard Drives

#1
Hi,

My PC (Windows 7) has two internal hard drives (C & D) and "C" is reserved for the operating system;" D" for my Data.

For some time, I have also had two external "USB 2" hard drives (250GB & 500 GB), which recently, I have replaced by two "USB 3" One TB WD My Book 3 Essentials hard drives - this also involved installing a USB 3 PEC card.

These drives (the USB 2 and the USB 3) were/are recognised as drives "E" and "F" in "My Computer" (Computer, with Windows 7).

A problem I have regularly experienced with both the "USB 2" and "USB 3" drives is that frequently, only one of these external drives is recognized in "Computer" and in "Disk Management". Sometimes "E" and sometimes "F".

The missing drive is sometimes restored if I re-boot, or if I un-plug and re-plug in the drive which is not recognised.

Interestingly, if I open the Device Manager, only one of the drives is displayed (Even if both are present in "Computer".

Western Digital have been most helpful, but have not resolved the issue. They believe that Windows 7 is seeing two drives with the same signature (Identity) and hence thinks that there is only one drive.

WD suggested using "Disk Management" to delete both volumes, formatting and giving different names to each drive. I have done this, but the problem still exists .

In a effort to resolve this issue, I have re-installed Windows 7, but the problem still exist, without any other software installed; hence, I don't believe it is an incompatibility issue

I would be interested to know whether anyone else has experienced this problem and found a resolution

Brian
 


nmsuk

Windows Forum Admin
Staff member
Premium Supporter
#2
What motherboard do you have?
 


#3
ASUS® P6T: DDR3, 3-Way SLI & CrossFireX on Demand
 


Joe S

Excellent Member
#4
Do you have the Smartware garbage installed? Between the Smarware and the virtual CD that can't be deleted they have really annoyed a lot of people. Not to mention the firmware updates that corrupt dive, make password unusable and other problems. I also wonder about the micro USB port they use a lot of complaints about that coming loose.
Joe
 


#5
Hi Joe,

Thanks for your reply.

Smartware is no listed in "Programs & Feature (Control Panel) and given that I have deleted/formatted both WD drives, before connecting to my PC, I don't think it would have installed automatically. Not aware of Micro USB port

Brian
 


Joe S

Excellent Member
#6
WD customer service isn't much help for anything with these problems. If you look at their forum it's full of frustrated people, there are no stickies or anything useful like that and I think the main moderator from WD must be from customer relations. Did you try using different ports? I don't know if this will make any difference or not. When you get a drive recognized delete the driver remove the drive properly then reboot. Do the same with second drive. Then plug one in when it is recognized go to disk management and give it a new letter. reboot and do the same with the second drive. Do the virtual CD's show up in device manager? With the crappy firmware WD shoved on and Windows 7 there may be some conflict and confusion confusion with these letters. It looks to me like WD started this mess back in 2008 and had problems and just polluted most of their externals with this Smartware/virtual CD mess. I think when I need another external HD I'll build my own.
Joe
 


#7
Hi Joe,

Thanks again for your response. I have tried virtually everything I can think of:

Deleting the drives, formatting, giving different names and drive letters. Although USB 3 drives, I have tried them in my USB 2 ports, and I still get erratic recognition.

I had the same problem with my previous USB 2 external drives, a Lacie 250 GB and a Seagate 500 GB.

This leaves me to think it is a design fault with Windows 7, but I don't think Microsoft would admit to this.

I have looked in the Device Manager and cannot see any "Virtual CD's" (Not sure what the come under, but have opened most headings)

Interestingly, this time, when I looked under hard drives, both "WD My Book 3's" were listed; previously, only one was listed, despite both being recognised ("Computer" & "Disk Management")

I am convinced that Windows 7 sees two drives with identical signatures and thinks that there is only one!

Think that it is something I will have to live with, but I do get frustrated when I cannot resolve an issue - I only use these drives to backup data/operating systems; hence they are not used for day to day working.

Regards

Brian
 


Joe S

Excellent Member
#8
Since you had trouble with other drives I would suspect Windows too. Are your USB drivers/controlers up to date? You might try deleting them and rebooting. I can't think of much else to try. It's pretty obvious WD does very little real world testing on their externals before releasing to public. Then when troubles appear they mostly thumb their nose at them. Every time they have a firmware update more people show up at the forum either with corrupt data or locked out of their drives. Frequently the update froze or crashed PC.
Joe
 


Joe S

Excellent Member
#9
I just saw this posted just one more thing to try.
Or it appears that the computer is not providing enough power for this device to be recognized , so i will suggest you the following :

1-go to device manager under usb serial bus controller and look for USB root hubs , on each of them do a right click and go to properties > Power management if ''ALLOW THE COMPUTER TO TURN OFF DEVICE'' is checked please uncheck them all, reboot , and retry to connect your device , it might solve your issue .
Joe
 


#10
I shall try deleting USB drive/controllers, but I don't have much hope; given that problem exists with both USB 2 and 3 - the 3 is brand new and I have let Windows install these (as well as trying the ones that came on the CD).

Thanks for your ideas.

Had hoped that someone had experienced the same problem and new od a Windows Fix

Regards

Brian
 


nmsuk

Windows Forum Admin
Staff member
Premium Supporter
#11
You could also goto your power options and disable usb selective suspend to see if that helps.
 


#12
Thanks for this tip; I shall try it out.

I have not come across "usb selective suspend " before. But will do some googling!
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.