Windows 7 Explorer slow when viewing from Libraries or Favorites

Discussion in 'Windows 7 Help and Support' started by msb11, Oct 28, 2009.

  1. msb11

    msb11 New Member

    Joined:
    Oct 28, 2009
    Messages:
    38
    Likes Received:
    0
    As the title states Explorer is bogged down when the folders have a large number of items in them (over 500). I have searched multiple places and this topic is brought up regularly but too few solutions. The only bit of information I have is that when I view the same folder from the Computer link (in the Navigation pane) it does not slow down when I open the folder. It instantly populates the window with the folder contents.

    I think this is because the libraries and Favorites are virtual folders??? I don't know why this would cause Windows Explorer to freeze up for 10 seconds to display the folder contents but it is incredibly frustrating. Moving files between folders can be time consuming and has forced me to completely abandon the Libraries & Favorites.

    So does anyone have any idea if this is something normal for Windows Explorer? Is there some setting I missed that I need to tweak?
     
    #1 msb11, Oct 28, 2009
    Last edited: Oct 28, 2009
  2. msb11

    msb11 New Member

    Joined:
    Oct 28, 2009
    Messages:
    38
    Likes Received:
    0
    ???

    Is this not happening with anyone else:confused:
     
  3. smiller

    smiller New Member

    Joined:
    Nov 2, 2009
    Messages:
    4
    Likes Received:
    2
    Same thing is happening to me on multiple machines (three so far... every Win7 install I've done.) Makes using directories with large numbers of files almost impossible!
     
  4. msb11

    msb11 New Member

    Joined:
    Oct 28, 2009
    Messages:
    38
    Likes Received:
    0
    Well I tried to see if the indexing was some how involved but even when I re-index the locations it still slows down. I could see how this behavior would happen if I was trying to view files on others computers (in my Homegroup) but all these files are on my local machine:confused:

    So I guess this is an issue for some people but I think it will surface more as people start populating the libraries. Surly there are people out there that have more than 500 pictures or videos
     
  5. smiller

    smiller New Member

    Joined:
    Nov 2, 2009
    Messages:
    4
    Likes Received:
    2
    One thing to check... are you running Windows Defender in real-time protection mode? I was, and since disabling real-time protection I haven't experienced the problem once, even in a directory of over 7gb and 3300 files. Give that a try...
     
    msb11 and (deleted member) like this.
  6. msb11

    msb11 New Member

    Joined:
    Oct 28, 2009
    Messages:
    38
    Likes Received:
    0
    Thanks for the input:) I actually have Defender disabled since I am using Microsoft Security Essentials (MSE). Based on what you said I will look into MSE and see if it is interferring some how.
     
  7. drsethl

    drsethl New Member

    Joined:
    Nov 15, 2009
    Messages:
    2
    Likes Received:
    0
    Experiencing same problem--post back if you find a fix!

    Hi,

    I noticed this too today, when I was adding a few more folders to my Documents library. Am using windows 7 x64, my hardware is all lightning fast so didn't expect this sort of thing. Like you say, it's as though you're accessing something on the homegroup rather than on your local computer. My 'solution' is to cut down on the number of locations I include in the library, and ensure that the ones that are included don't have too many subfolders and immediately accessible files. It's a bit annoying though, as I like libraries and would like to make more use of them. If you come up with a solution please post back, likewise I'll keep looking!

    Cheers

    Seth
     
  8. David Le

    David Le New Member

    Joined:
    Apr 2, 2011
    Messages:
    2
    Likes Received:
    0
    Re: Experiencing same problem--post back if you find a fix!

    Yep same thing happening to me.

    FIX:

    Go into MS security essentials

    Click on Settings

    Change "Monitor files and program activity on your computer" to Monitor only incoming files.

    Save and you should be right
     

Share This Page

Loading...