Windows 7 - Home Premium x64 | Startup Repair System Installation

Discussion in 'Windows 7 Help and Support' started by Caspurrr, Jul 28, 2013.

  1. Caspurrr

    Caspurrr New Member

    Joined:
    Jul 28, 2013
    Messages:
    4
    Likes Received:
    0
    Hey All,

    So I am pretty sure that my Windows 7 home premium installation has become corrupted somehow. I've just noticed thins not 'working' well and have been experiencing more and more BSODs over time.

    I have ran many disk / system file checks (sfc /scannow), and it states that there are certain files that are corrupt but cannot be repaired.

    When I try to run a 'Startup Repair' from my Windows 7 DVD it is unable to find ANY Windows Installations, which concerns me.. and therefore leaves me no options to fix.


    Yesterday, I decided to try and do a 'upgrade' repair from the Windows 7 DVD in hopes that it would completely clean/replace all system files.

    It took forever, but finally upgraded. All my files remained (which is what I wanted), however, nothing seems to have changed.

    When I tried to do the startup repair, it still dosen't find any Windows installations on my system.. which makes NO SENSE.

    Obviously I have a working windows installation, since if I take OUT the Windows 7 DVD, it will boot normally, and things seem to be working (other than a few weird glitches/ BSODs everyonce and a while).


    Can you please help me with the following:

    • 1). Is there some 100% method to see if my Windows 7 Installation is corrupted / not working right?
    • 2). If Startup Repair dosen't recognize any Windows installation, does this mean my installation is corrupted?
    • 3). Is there anyway to fix the Startup Repair?
    • 4). I am trying to AVOID having to completely clean-install Windows 7, however, if there's no other way I'll have to.
    • 5). Does the Windows 7 Upgrade replace all system files?
    • 6). Is there any other way to fix system files (3rd party software or whatever)?

    Thanks,

    Caspurrr
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Did you do your repair install using a Windows 7 with SP1 install DVD?

    After you did the repair, does the SFC still show errors?

    Could you type the following command in an Administrative command window and then attach the resulting text file? You can copy and paste the command and the text file will be on your Desktop.

    bcdedit /enum all > %userprofile%\Desktop\bcd.txt
     
  3. Caspurrr

    Caspurrr New Member

    Joined:
    Jul 28, 2013
    Messages:
    4
    Likes Received:
    0
    Thank you for the fast reply Saltgrass.

    Yes I did do the repair from a Windows 7 (Sp1) DVD.

    I am currently doing another scannow, and will let you know the results...

    Here is the BCD boot manager run down you requested at pastebin : http://pastebin.com/pQmrvk1c

    Also -- I read something very similar to the issue I am having, where the Startup Repair dosen't recognize the OS installation, and basically dosen't repair anything..

    It seemed that he was able to fix this by 'repairing' the MBR to the active partition. he said he used a command like "/fixmbr" or something. How exactly do I do this, and do you think it's worth trying?

    UPDATE: I did a sfc /verifyonly and it states that Windows Resource Protection did not find any integrity violations.

    Do I need to do a boot-time sfc /scannow or will this suffice??

    Thanks,

    Caspur
     
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    The BCD store indicates you are booting from the second partition on your hard drive. Windows 7 will, by default, setup a System partition to boot from, unless you force it to do otherwise. Have you done something to change the normal boot scenario? It should work in this current configuration, just wondering how it might have gotten changed, and what might be in the first partition.

    It also appears Bit Defender is involved by having a boot option that can be chosen just as a memory diagnostic might be chosen. But since I have no experience with how that interacts with your system, I cannot determine it if might be causing your current situation.

    Could you take a snipping tool picture of your Disk Management window and attach. You can attach files on this site by using the image option.

    The bootrec.exe commands you mention might help, but your system is booting, just seems to be getting lost on occasion. And again, I am not sure how the Bit Defender recovery option might be involved. The fact the bcdedit command worked, would seem to disagree with the Startup Repair option not being able to find an install.

    If you are getting BSODs, you might look at the BSOD forum and follow their instructions on how to get help with those. A dump file might supply the needed information.
     
  5. Caspurrr

    Caspurrr New Member

    Joined:
    Jul 28, 2013
    Messages:
    4
    Likes Received:
    0
    Hey Saltgrass,

    Thanks again for responding to me and addressing my thread.. it's people like you that make this world awesome!

    Like you said.. my system IS booting, but it concerns me that the Startup Repair can't find my installation. It used to fine, and it would help sort out a lot of issues I have experienced in the past. What exactly does that mean when Startup repair dosen't see my OS installation.. BUT it works fine?

    Regarding your question about the 'second partition' and booting.. I don't 'think' I did anything out of the ordinary.. however, I've had to backup/restore many many times using Acronis True Image Home, and I suppose I may have screwed something up in terms of selecting the wrong partition or something.

    As you can see in my Disk Management screenshot below, I have a System Reserved partition that is marked active (which I believe is correct right?), and my normal C partition. Should my System Reserved be marked as the "boot" partition? Let me know if you see anything out of the ordinary with that.

    [​IMG]

    I literally just installed BitDefender two days ago, and i don't think it has anything to do with this since I've been experiencing this stuff for a month or two.

    I've been getting occasional "IRQL NOT LESS OR EQUAL" and recently a "IRQL GT.." BSODs.. but am more concerned about the health of my installation.

    Thanks again for helping me, and let me know any further actions I can try.
     
  6. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Your install looks fairly normal, but it does appear you have been playing with the partition sizes. Not often you see a system partition only 87 MB.

    Do you know what the E: entry is that is showing as a DVD drive but formatted as RAW? Are you running a Virtual DVD drive? I suppose it might be related to Bit Defender..

    One more thing I might ask, I promise. Open an Administrative command prompt and use the following commands with enter after each. The sel dis 1 line refers to the disk number from the first command. If your primary drive is showing as another disk number, use that.

    Diskpart
    lis dis
    sel dis 1
    lis par

    You can copy and paste the info generated by the list partitions line. I would like to see if there is another partition which is not showing in your Disk Management picture.

    Type exit to leave Diskpart.

    Do you really only have 7% free space on the c: partition?
     
    #6 Saltgrass, Jul 28, 2013
    Last edited: Jul 28, 2013
  7. Caspurrr

    Caspurrr New Member

    Joined:
    Jul 28, 2013
    Messages:
    4
    Likes Received:
    0
    Hey Saltgrass,

    The "E" drive is my DVD drive.. which currently has a blank DVD in it.. so that is what your seeing there.

    Yes my C drive currently only has about 7% left.. but that is because I've yet to clean my old OS installation (from the upgrade) and have a whole BUNCH of games and stuff. Is that bad?

    Here are the results from the diskpart. There is no hidden partition. My computer was setup by the company I ordered it from.. and I am not sure why they would make the system reserved only 87 MB, but that's how it has been from the beginning... is that an issue?

    DISKPART> lis par

    Partition ### Type Size Offset
    ------------- ---------------- ------- -------
    Partition 1 Primary 87 MB 1024 KB
    Partition 2 Primary 698 GB 88 MB
    I hope you have some more helpful tips as I really want this Startup Repair to recognize my OS so I don't feel like something is terribly wrong.

    Thanks,

    Caspur
     
  8. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Well, I realize why the BCD store shows HardDiskVolume2. I forgot to take into account you have your secondary drive as the first drive and the partition on that is Volume 1, so your System Partition would be Volume 2...

    If you are leaving the blank DVD in your drive all the time, I would suggest you take it out.

    How full a hard drive can be I suppose could be discussed. I do not know of a basic free space requirement, but there may be one. I do know the Shadow Copy service is supposed to require 10% of the partition's size to create the Shadow copies. If you have the capability to move some data off the drive for testing, you might try. Or you could make an image of the current install and get a larger drive then use the image to restore your system. I will see if I can find free space requirements..

    The IRQL NOT LESS OR EQUAL is probably referring to some device driver. A dump file might explain further...

    I can't think of anything else to suggest, except perhaps doing a chkdsk to see if any corruption is on the drive. But the SFC being clear is a good sign.
     

Share This Page

Loading...