Windows 7 Pro does not awake from Sleep properly.

Discussion in 'Windows 7 Help and Support' started by stonooka, Jan 7, 2012.

  1. stonooka

    stonooka New Member

    Joined:
    Jan 7, 2012
    Messages:
    20
    Likes Received:
    0
    Desktop does not respond to mouse actions as previously nor the front panel power switch.
    I have to disconnect the power cord, reconnect, and press the front panel power button. Then the unit starts up and returns to window without the login window as if it was sleeping.

    The problem started after my attempts to install a defective external drive enclosure connected with an esata cable. I have since obtained a working external enclosure connected with an esata cable. The present Sleep wakeup malfunction is now present with or without a working external drive.
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Sounds like you may have loaded a driver that is not playing nice.

    Do you have the drivers for the eSATA ports installed, for mine it is the JMicron.

    Have you tried uninstalling the device and starting over? Have you checked the Power Management tab on the properties dialog of the device?

    Any messages in Event Viewer?

    The utility normally used to track down power problems is Powercfg. If you open an Administrative command prompt and type

    Powercfg -energy

    it will scan your system a give a report as to potential problems it finds. Make note of where the report is kept and copy it to the desktop to open. Before running, close down all non-essential programs and let it work for the normal 60 seconds.

    If the report shows USB errors, those are fairly normal, so you would be looking for something else, probably related to a driver or device.
     
  3. stonooka

    stonooka New Member

    Joined:
    Jan 7, 2012
    Messages:
    20
    Likes Received:
    0
    I ran powercfg -energy as recommended by Saltgrass with the external drive not connected and here's what was reported:

    1. "Sleep time out is disabled." Yes I did that manually by using Control Panel.
    2. USB Devices not entering Suspend:
    - Microsoft Wireless Mouse and Keyboard
    - USB Root Hub (Host Controller ID: PCI\VEN_8086&DEV_3B36;Location: PCI bus o,
    device 29, function 3;Device ID: USB\VID_8086&PIDF_3B39.
    I think this is the video display adapter on the PCI bus.
    -repeat of above except function 3 instead of function 0.
    - USB Printing Support
    3. "Power Management Disabled due to known incompatibility with the hardware in this computer."

    4. There was informational stuff on successful operation.

    There was no mention of disk drives or drivers. Should the external drive be "dismounted" before disconnection? How does one dismount it?

    Nevertheless, I updated the "outdated" drivers reported by UniBlue by paying $30.00 for the Uniblue subscription. No affect on the Sleep malfunction.

    Should I re-enable the Sleep timeout and run Powercfg -energy again?

    Still confused.

    stonooka
     
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    This seems interesting.. Maybe if you tell us about your system we will see something. There may be something going on with the
    ACPI. I suppose you have checked the bios settings for that?

    I would probably disconnect the drive and do a cold boot. Then see what it does. But if it gives the message above, I would think it should give you some details. I suppose you have not seen anything mentioned in the action center or the event viewer?
     
  5. stonooka

    stonooka New Member

    Joined:
    Jan 7, 2012
    Messages:
    20
    Likes Received:
    0
    Thanks for responding.
    What is ACPI?
    I do not know how to interpret Event Viewer, so far.

    Action Center told me to update the Sata disk controller. I did that by downloading from the Gigabyte web site. No change in inability to wake after sleep after update.

    Here's the info on the computer:
    1. Desktop
    2. Windows 7 Pro 64 bit
    3. Gigabyte GP-P55A-UD3 mobo (Marvel sata HD Ctler)
    4. i7 860 2.8 Ghz CPU
    5. 8 Gig Ram
    6. 2 internal Sata hds, not striped.
    7. Microsoft wireless mouse and keyboard
    8. Diamond Video Card
    9. LG R/W dvd/cd drive
    10. 3 1/2 inch Floppy Drive (for loading legacy software in XP Virtual)
    11. 1.5 Tbyte external sata hd using esata interface to enclosure.
    This is my 2nd enclosure. The first one had a defective esata interface which I suspect
    may have been the cause of the sleep malfunction. The first enclosure besides not recognizing the hd, would
    cause my 2nd internal hd to disappear.

    I will run powercfg -energy again with the new hd drivers and sleep timeout enabled.

    Will report on results.
     
  6. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I checked your motherboard manual, assuming it was the correct one, and I do not see any eSATA connectors. You say you are using an eSATA external device, what is that device and where do you have it plugged in?

    You have 8 onboard SATA connectors. The first 6 are SATA II(3 GB) and 2 SATA III (6 GB). The first 6 use the chipset drivers for the motherboard and the last 2 use the Marvel controller. You say the 2 internal drives are not setup as a RAID?

    So you have loaded the chipset drivers and now the Marvel driver, but it did not get any better. I don't see any other drivers you could load related to your SATA controllers.

    When you advise where the external drive is plugged in and if you have that set as AHCI, we can discuss that further.

    The floppy drive you have installed seems to have caused problems in other Windows 7 installs. I run an external USB floppy which works fine, but I do not have a floppy enabled in the bios.
     
    #6 Saltgrass, Jan 10, 2012
    Last edited: Jan 10, 2012
  7. stonooka

    stonooka New Member

    Joined:
    Jan 7, 2012
    Messages:
    20
    Likes Received:
    0
    Hi Saltgrass,

    Thanks for rapidly responding.

    I neglected to mention, I am using an Antec Sonata III 500 enclosure. eSata is just a connector and a special shielded cable. The external sata hd enclosure brand is Comkia(an unknown Chinese Co.). The enclosure is made just for sata drives and has an external USB, Firewire, or eSata interface and it works with esata. The eSata cable connects from the ext enclosure to a front panel eSata connector on the Antec Desktop enclosure. The eSata connector on the Antec is connected internally to one of the sata connectors on the mobo. I think to Sata 3 by the data transfer speed I am experiencing. The previous enclosure that failed on esata was a Sabrent enclosure. It had jumper cables internally for IDE and sata drives and external USB and eSata jacks.

    The floppy drive works fine in my system. I have loaded ACAD and the Paradox Data Base programs to the Virtual XP in Windows 7 successfully.

    I ran powercfg -energy again with the sleep timeout enabled. The report confirmed Sleep timeout was enabled but stated Power Management was disabled because of incompatible hardware again. Meanwhile, I'll look up AHCI.
     
  8. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    AHCI is one form of controller for the SATA hard drives. It will support hot plug capabilities if it is set up right. The other options are IDE or RAID or even a mixture of AHCI/RAID.

    I noticed your bios has some Power handling capabilities (ACPI) that are normally part of the Chipset drivers, but if your system worked fine before, it is probably not related.

    All I might suggest is to uninstall the external drive and remove all drivers and start again. I do not know if the other enclosure left anything that might be interferring, but you might check. Now, or after a reinstall you might go to the device in Device Manager and check the Power tab to make sure it supports the power management.

    I will check on the enclosures you mentioned in your post.
     
  9. stonooka

    stonooka New Member

    Joined:
    Jan 7, 2012
    Messages:
    20
    Likes Received:
    0
    I checked my sata control mode in the BIOS. It is set to IDE: the choices are IDE, Raid, or AHCI. I did not change it at this time.

    My sata internal drives are working fine and Power Management worked OK with Sleep until I started using the external drive. I have also read the tutorial in this forum to enable AHCI (with the registry)after OS install by Bare Foot Kid. Meanwhile I have not done anything about turning on AHCI, so far.
     
  10. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I probably would not change the controllers either. Since each controller can be set differently, you might make you system unbootable by changing the wrong one.

    Just be aware, the external drive says it is hot plugable. Not completely sure that is true if the controllers are not set up right, but I have no reason to think they are not. If the drive is hot plugable, it should be recognized when you plug it in...

    But I have nothing else I can suggest to fix your sleep problem. If the external drive is causing the problem, or even the first one, you should be able to clear it out somewhere and the powercfg should mention it. I am still a little confused by the comments about the known incompatibility.

    You might try the external drive with the USB cable to see if it helps for testing.

    Edit:
    Do you remember any steps you took or have a reference for what you tried to get the first external drive to work?
     
    #10 Saltgrass, Jan 10, 2012
    Last edited: Jan 10, 2012
  11. stonooka

    stonooka New Member

    Joined:
    Jan 7, 2012
    Messages:
    20
    Likes Received:
    0
    The external drives are hot-pluggable. 'My Computer" displays a new drive letter for the isata compatible second external drive with the back-up image files that I had created. I get the incompatible hardware diagnostic when I run powercfg -energy even when the external drive is not connected or when I use a USB keyboard and mouse rather than the wireless.

    The first enclosure worked with a USB cable but not with the esata cable. The first enclosure would cause the internal Secondary drive letter to disapear and would not work with the esata cable. So I returned the the first enclosure.

    I have an image backup file of the computer on the internal second drive that I believe was made before the Sleep malfunction. It may be worth restoring with that.



    I have an image file about 10 days old on my internal secondary drive that was made before the Sleep malfunction. Should I restore my computer with that backup?
     
  12. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Restoring an image is completely up to you, I hate to get involved since something can always go wrong. I do reimage my drives quite often without problems, and would not hesitate to do mine. Have you done a reimage before?
     
  13. stonooka

    stonooka New Member

    Joined:
    Jan 7, 2012
    Messages:
    20
    Likes Received:
    0
    Having problems posting...does not seem to happen. I'll try again.

    The 1st external drive that would work with USB cable but not with esata cable was returned. Both drives are hot plugable . On boot up with the external drive turned on and connected, the computer assigns a new drive letter and the drive files are accessible.

    The external drive does not show up in Device Manager, even though it is working. The external drive is not mentioned in the Powercfg report.

    I tried setting IDE enabled (for the keyboard and mouse) via Power Options/change settings for the plan/change advanced power settings/IDE/enabled but did not to work. Save Settings button was grayed out. Someone in another forum did this and was able to correct the Sleep wakeup problem.

    I probably need to perform a clean OS install after I save all my data and program files. Is it worth it? Everything else works except Power Management.
     
  14. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Don't know about the changing settings, but there is a blue text selection on the top of the Advanced settings window you may need to select prior to changing some settings.

    If the drive doesn't show up in Device Manager, does it show up the the Computer dialog window? Make sure you don't have hide empty drives selected in the folder options. If you think the situation with the external drives caused the problem, you are probably right. We just need to figure out how to get around it.

    Maybe plug the drive in and do a safe disconnect, if it shows up.

    Edit: Oh, and if it isn't showing up in Device Manager, you might be able to scan for new devices (computer icon on top) and have it discovered.
     
    #14 Saltgrass, Jan 11, 2012
    Last edited: Jan 11, 2012

Share This Page

Loading...