Windows 8.1 keeps defaulting to allow remote access

Bob07984

Active Member
I have a laptop running Windows 8.1 Pro, and i am experiencing a problem with it Allowing remote connections (RDP).

A while back i noticed that port 3389 (RDP) was open or whatever on this laptop when i scanned my LAN. I know RDP can be a security risk, and i don't need it, so, i opened the appropriate menu (see attachment), and selected "Don't allow remote connections to this computer". Fine. RDP port closed.
However, windows seems to keep defaulting back to "Allow remote connections to this computer" (As seen in attachment)? At first i thought it was when i restarted, but it seems to do it even between restarts.

Does anyone know why this keeps happening, & how i can force it to stay on "Don't allow connections"?
 

Attachments

  • RDP Allowed.JPG
    RDP Allowed.JPG
    48.2 KB · Views: 27

Mike

Windows Forum Admin
Staff member
Premium Supporter
This setting should save. If it is not saving, it is possible that a third party software is opening RDP. You should take an inventory of what is on the system and make sure that whatever is opening RDP or preventing the setting from being changed is disabled.
 

Bob07984

Active Member
Hello, thanks for the reply.
As far as i know, there should not be anything (legitimate) that would be opening RDP, but i will dig through appwiz etc again to see if i spot anything, although i don't know how to specifically identify the software that may be causing it...

as a "precaution" i have created a firewall rule that *should* be blocking the RDP port, whatever that dialog says...

Thanks
 
Top