Windows 8 Won't create a network bridge

#1
I have a slightly annoying problem, as I sometimes need to bridge my WiFi and Ethernet, then I sometimes delete the bridge, re-create it when I need it.. rinse and repeat. But since some time I am unable to create a network bridge anymore. When I try, windows says creating network bridge... my adapters shut down and turn on again - and nothing. no new adapter, just my ethernet and wifi, both working separately.

I cannot use ICS because I need each PC on the main network to have it's own IP, not my PC acting as a NAT router so they have my laptop IP and internally another IP.

When I check the event logs I see the following but don't understand how it can help me fix my issue:

Code:
Information    13-7-2014 17:42:37    Service Control Manager    7040    None
The start type of the Microsoft MAC Bridge service was changed from auto start to demand start.


Information    13-7-2014 17:42:05    Service Control Manager    7040    None
The start type of the Microsoft MAC Bridge service was changed from demand start to auto start.


Information    13-7-2014 17:42:05    UserPnp    20003    (7005)
Driver Management has concluded the process to add Service NdisImPlatformMp for Device Instance ID ROOT\MS_IMPLAT_DEF_MP\0000 with the following status: 0.


Information    13-7-2014 17:42:05    BROWSER    8033    None
The browser has forced an election on network \Device\NetBT_Tcpip_{EA162CCE-91DD-47BA-A876-4F3D7FEFB30C} because a master browser was stopped.
before and after I click "bridge" I always have only 2 adapters - wifi and LAN, not the microsoft virtual multiplexer anymore (so I should have 3).

I tried removing the adapter multiplexer from devices in device manager and restarting the computer many times but that does not help.

Is there a way to fix this without reinstalling windows?

I tried reinstalling the network adapters too and rebridging them - not working.

I tried connecting two wifi dongles and briging them - nothing, I also tried bridging them in any combination with my other adapters - again nothing.
 


ussnorway

Windows Forum Team
Staff member
Premium Supporter
#2
It's hard to imagine why but there are two basic options which will work;
1. Purchase a wifi router and plug that into the main network.
2. Install a network profiling system… vmware workstation (the virtual network editor in particular) is one of the best but is incompatible if you have hyper-v running.

If going physical or software is best for you will depend on other facts which we don't know about yet.

p.s. have you perhaps enabled hyper-v on this laptop… that would explain why the network can't be bridged any more?
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.