Windows Server 2019 Server Manager has bugus 169.254 address

Yanta

New Member
Server manager shows 2 addresses; 192.16.1.x and 169.254.x.x. The first is the valid address, the second I assume is because I always clean install all Windows with the network disconnected. The motherboard, and X299 XPower Gaming AC motherboard has 2 onboard NICS. But I have a 10G PCIe adapter installed (AQN107), which is the one I want to use.

I was about to install some additional roles (IIS, WSUS) and noted the 169.254 address. How can I get rid of it, "unbind" it?

The server will run Macrium, IIS, WSUS, MySQl, Coldfusion,OpenVPN and also be used as a file store. I'm concerned the bogus address will cause issues with at least IIS.

I've tried netsh int ip reset.
I've disabled the onboard NIC and even uninstall the drivers but I can't seem to get rid of it.

Would be grateful for some guidance.

Thanks
 

Neemobeer

Cyber Security Engineer
Staff member
Any IP address that starts with 169.254 is an APIPA address. These get automatically assigned on an interface that is configured for DHCP, but is unable to contact a DHCP server.
 

Yanta

New Member
Thanks for your response. Actually, I was aware of that. The question is how to get rid of it.
When I add roles or features I'm asked to select a server, and I'm presented with two IP addresses. One being this address.
At this point, the server is connected to the network. It gets it's IP Address from the router which uses reserved addresses based on MAC address. So once it's connected shouldn't the 169.254 address be dropped?
 

Neemobeer

Cyber Security Engineer
Staff member
If it's getting both addresses I would assume it has two network interfaces. If it's a VM remove the second NIC, if it's physical you can either physically disable the NIC or go into the interface properties and just uncheck everything should be sufficient.

1623682564067.png
 

Yanta

New Member
I don't use VMs. Too many limitations. Instead I have a dedicated PC for testing.

As I said in the OP, the motherboard has two onboard NICs, and I have a PCIe 10G adapter installed. I use the 10G as the primary adapter. The onboard NICs are disabled. I have not only disabled the NIC, I also uninstalled the drivers for them too. I also tried disabling the NIC in the BIOS. Server manager still shows the bogus 169.254 address.
 

Yanta

New Member
Apologies for my poor English skills.

This address only shows in Server Manager.

IPCONFIG does not list this address.

I'm not near the PC right now, but I'll send through the output soon.
 

Yanta

New Member
Ok, I guess I'm going to have to live with this. This address shows ONLY in Server manager as 169.254.x.x,192.168.1.x.
I'm having a problem with IIS not showing one website, but that might be a configuration error.
And WSUS seems to synchronize fine, but doesn't find any updates for PCs, or even the server itself. It's patched to Oct 2020 so there definitely should be some OS patches as well as .NET patches. Again, not sure if this is caused by the bogus address, or a configuration issue.
 

Neemobeer

Cyber Security Engineer
Staff member
It shouldn't, the 192.x address should have a lower metric and will be favored by all connections.
 

Yanta

New Member
Remove the adapter from the registry.
Now Server manager shows only the real NICs.
thanks for your help.
Problem solved.
 
Top