/windows/system32/winload.exe

Discussion in 'Windows 7 Installation' started by varkeyeldo, Jan 14, 2009.

  1. pcs3657

    pcs3657 New Member

    Joined:
    May 6, 2010
    Messages:
    210
    Likes Received:
    13
    The best solution to this issue is as follows:

    Remove any Graphics cards or other optional devices

    Make a bootable USB device from Windows 7(follow this link on how: How To Boot And Install Windows 7 From USB Flash Drive (Updated) - Make Tech Easier)

    Start the installation after making the boot priority to be the USB first)

    After the installation is complete install the drivers for Your graphics card

    Install the device and restart

    This should do it :)
     
  2. ShadowZero

    ShadowZero New Member

    Joined:
    Oct 28, 2011
    Messages:
    2
    Likes Received:
    0
    Thank Google for this! I had Windows 7 working for quite a while, though often still used Windows XP (dual boot). But suddenly the winload.exe exception occurred. A format and re-install didn't even work!

    But enabling S.M.A.R.T. for the hdd in the BIOS fixed this. Just wondering, what the heck went wrong? And I just noticed that after re-installing I can disable S.M.A.R.T. again and Windows 7 still works :?

    My system:
    - Asrock AliveNF5-eSATA2+ R3,0 , nForce 520 (ATX, PCI-e, Sound,
    LAN, SATA II, RAID)
    - Kingston 2GB DDR2 (2x1GB) PC6400 800Mhz CL5 Dual Channel Kit
    - AMD Athlon 64 X2 5200+ (AM2, 2x2.6GHz, 1MB L2 Cache, 400MHz
    Bus, 65W, Boxed)
    - Sapphire Radeon HD2400 XT 256MB DDR3
    - Seagate 500GB SATA-300, 32MB, Barracuda 7200.11 ST3500320AS
    7200rpm
    - LG 6x Super Multi Blu-Ray Reader
    - CLUB3D Theatron Agrippa 7.1 PCI DTS + DDL + DTS Retail
     
  3. CHDRob

    CHDRob New Member

    Joined:
    Nov 23, 2011
    Messages:
    8
    Likes Received:
    0
    Hello, I myself am getting this error and I am very tech savy. I am a Technical support agent behind a Computer Help Desk supporting MANY service plans and programs and I have tried the above options as well as my own.

    I am recieving:

    Windows has failed to start. A recent software or hardware change might be the cause.
    Try the method below, if this still occurs please contact your system administrator

    1. Choose from one of the F8 safe mode advanced boot options
    2. Select "Repair your Computer" from installation disk
    3. Choose one of the available system recovery options

    Error:

    File: windows/system32/winload.exe


    Status: 0XC0000225

    Info: Windows could not start because the file is either missing or corrupted.




    Given I have a little bit of information to add. I have built my own machine and I've been building them for 10+ years. On this machine I have a 500GB SATA HDD with 2 partitions. One with Windows Vista the other with Windows 7, both HOME edition. Recently I have been wanting to upgrade my Windows 7 partition to Windows 7 Ultimate and EVENTUALLY scrap my windows Vista in replace for the NEW Windows comming 2012. Windows 7 home was fully booting fine, up until I wished to upgrade to Windows 7 Ultimate. I for some reason after backing up my files from partition 2 (W7) and was ready to upgrade, could not, the application had failed to start when I already had the OS running. Understandable, given the fact that Windows 7 Home to Ultimate technically is not an upgrade. What I had done was:


    -Shrink volume from partition 2
    -Re-formated Unallocated data to Partition 3 (25GB)
    -Inserted Install disk
    -Restarted computer and used F12 to select CD/DVD drive
    -Installed OS to Partition 3 (25GB)
    -Configured OS on partition 3

    With doing this, I was unable to Boot Windows 7 Home (Partition2) As I still had the same "Select an OS" screen Windows 7/Windows Vista, my Windows 7 choice goes to partition 3. I atleast can see my system was perfectly capable of booting and running Windows 7 Ultimate and was able to install, my discovery was a success. I then wished to make it my Partition 2. I did the following:

    - Removed added extra data from Partition 1(WV) as I will be eventually "scrapping" this OS so that I had more available space on it
    - Shrink Volume on Partition 1(WV)
    - Deleted Partition 2 and 3 to Unallocated data
    - Formatted Unallocated Data into new Partition 2 (which is now larger than it was as I was planning to only use W7 Ultimate Until new windows is available, in which W7 would be installed on Partition1 and I would extend it back to 50/50 to install new OS on Partition2)
    - Installed Windows 7 Ultimate onto Partition 2
    - Configured OS

    What I found at this point was that upon trying to configure, the OS works perfectly fine first boot from installation process. As soon as I shut my computer down to re-boot windows 7 to save my changes, or just to test if it's "bootable". I got this error message!
    I was very puzzled! Given it had JUST worked on a smaller 3rd partition and I had deleted any existing data that might have been on there already by turning it into Unallocated data and formatting. Using F8 on the Windows 7 option gives same error and so does F8 on Windows Vista, so I have no recovery options and I can not get an option to F8 on Install disk

    I had then tried to boot Windows Vista, works PERFECTLY! Good news!
    I used my OS to then Delete and re-format Partition 2, this time Extended partition1 back to where both partitions are 50/50 equally sized.
    Curious I didn't jump to installing Windows 7, I tested booting HDD without my Choose an OS selection, it told me BOOTMGR is Missing press ctrl+alt+del. Uh-oh I thought, I had screwed up my hard drive from making my partition2 larger than I needed it to be. However! I said I will just try to install Windows 7 Ultimate onto partition2 and see where it goes from there

    After installing Windows 7 Ultimate, I got the same issue as mentioned above, except I can again select Windows Vista and boot perfectly fine. I am now stuck without Windows 7 at all...

    Attempted resolutions from there:

    Enabled S.M.A.R.T. as mentioned in other replies
    Attempted to install without ANY extra devices other than my mouse/keyboard and my on-board video card is a piece of ****, it only agitated me.
    I also looked to see if the winload.exe file is present, it sure is! however taking a look at my Windows Vista winload.exe it's over 1,000KB and my Windows 7 one is only 591KB. Tried to copy my WV one to my W& however it doesn't let me delete the W7 one without "permission"? so I can't do that and try that one
    I have also re-burnt the disc from making a backup image from it to try that I have now actually wasted 3 DVDs doing that as I have attempted different burn speeds

    Anything else I should try? I'm also afraid to scrap the whole Windows Vista off completely and just only have Windows 7 Ultimate now because I may not even have a bootable hard drive at that point because it appears without this non-working installation I don't even have a bootmgr

    I wish I could just get a repair your computer to come up and command prompt a "bootrec /" command or something. ANY repair your computer I get 0XC0000225 error. I have never been so confused in my whole time with my technical background. Why would it work on my 25GB partition 3 and effect NOTHING! but as soon as I switched that partition to the last approx p1:(40%)/p2(60%) it zonked everything? I'm very confident there is some kind of flaw in my HDD with how this turned out, however a scan disk shows no error, no bad sectors nothing unreadable...

    rarely do I need help, but I'm reaching out, someone think of an option?
     
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Well, let me see if I can boil down your problem.

    You have a hard drive with 2 partitions and you want to dual boot Vista and Windows 7....

    Can you boot into Vista and get us a snipping tool picture of the Disk Management window, then attach using the paperclip? If you can't boot to Vista (hard to keep track :confused: ) then you could boot to the install DVD, on the second page after the language selection, there is a Repair my computer option. Do a Startup Repair an perhaps it will restore your boot. It might take up to 3 runs to repair some problems.

    In order to upgrade from Windows 7 to Windows 7 higher, you need to use the Windows Anytime Upgrade, unless you have a separate license key for your new install. Are you entering a key during the install (you don't need to)?

    What are you using to change the partition sizes?
     
  5. CHDRob

    CHDRob New Member

    Joined:
    Nov 23, 2011
    Messages:
    8
    Likes Received:
    0
    diskmangement. Current disk configuration. I have been trying to reduce space from the second partition thinking maybe I damaged something somehow somewhere. I used the disk to create this F:/ Volume it automatically created the D:/ and it shows that its empty but says its not free and only 100 MB in size. My disk does not allow me to use any of the Repair your computer options

    .
    What I'm thinking about doing is maybe installing Vista in both partitions to see if I can get that partition bootable and Just do an Upgrade on Vista partition 2 maybe? It doesn't ask me for my activation key until AFTER installation. This is a different key too. I actually bought a Windows 7 Ultimate disk that's why.
     
  6. CHDRob

    CHDRob New Member

    Joined:
    Nov 23, 2011
    Messages:
    8
    Likes Received:
    0
    Also, I can't use sleep mode anymore either, screen goes off and comes right back on lol
     
  7. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    You configuration looks a little strange. Keeping in mind that the system always boots to an active partition, why is your Vista partition not active? Since it was your first install, it should have been unless you changed it, Windows 7 would have used an active partition already there.

    If your boot files are in the C: (Vista) partition, making it active would probably restore the boot to Vista without a boot menu. You could then reformat the rest of the drive and install Windows 7.

    I don't have my Vista computer here, but you should have a bootmgr file and a boot folder in the Vista partition. They should be hidden and maybe system, so you will have to enable that in folder options to see them. If they are there, then we can go ahead and make the Vista Partition active.

    The 100 mb partition is a System partition Windows 7 (and Vista) will install if the drive is not preformatted. Right now you are probably using the Windows 7 boot files in that partition to boot into Vista.
     
  8. CHDRob

    CHDRob New Member

    Joined:
    Nov 23, 2011
    Messages:
    8
    Likes Received:
    0
    You are absolutely right, I did have the vista one active before, trying my last install that created the 100MB partition must have changed it. I have boot files on my Vista Partition therefore I will try making that active and see what happens and get back to you.


    I have made it active, leaving the others not active. It still asks me to Select an OS and Windows 7 boot still says 0xC0000225. Repair your computer on both partitions still go to that error as well. Start-up repair on both my Vista OS install disk and my 7 OS install disk also go to this error. Only things I can do is re-install Vista, 7, or boot Vista.

    I really wish to use Windows 7 as I bought a disk. My goal here is to basically have a dual-boot vista and 7. I may just need to get a new hard drive and install 7 on that. What are you guyses thoughts?
     
    #28 CHDRob, Nov 28, 2011
    Last edited: Nov 28, 2011
  9. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I really do not know what to suggest to remedy your situation. The error C0000225 seems to suggest:
    I did see one site that offered one of those fix it remedies, but I would not let something run if I did not know what was being done.

    If none of your install DVDs will boot, it is probably not just a hard drive problem. A way to check would be to remove or disconnect the drive for testing.

    Possibly resetting your bios to its defaults would help. You have done a complete shutdown and a cold boot?

    I found this, but you do not appear to be running a UEFI system. Maybe you will see something in the link that looks familiar.

    "c0000225" or "c0000017" error occurs when you try to start a Windows PE RAM disk image on a UEFI-enabled computer that is running Windows 7 or Windows Server 2008 R2

    If none of that helps, if you can get it to boot into Vista, maybe you could do a repair install from within Vista to correct the problem... I just do not know. A new hard drive for testing or running a memory check might be some possible choices.
     

Share This Page

Loading...