wired mouse lag in desktop windows 8.1 pro 64

#1
hi guys ,
i have this wired mouse lag in my desktop and also while browsing internet it is so difficult to move the moues :cry_smile::furious: i installed to the latest update what is wrong here , please help me writing this post is so hard while the mouse is lagging :waah: , hope these screenshots will gave you guys more info about my problem



why am i getting this lag it is so annoying i cant work anymore with this lag this is absolutely a real nightmare for me :mad3::furious: please help me there :waah:
my rig is :
windoes 8.1 pro 64
intel i7 4960x oc to 4.3 ghz
corsair h100
asus rampage iv black edition
g skill trident x 2400 (4x8) 32gb
2 x (evga gtx 780 ti classified ) sli
corsair 1200ax platinum
samsung 28 4k led 28d590d
mouse razer deathadder 2013 and keyboard razer deathstalker keyboard
 


Last edited:

badrobot

Senior Member
#2
1. Do you have any other USB peripherals plugged in? Try unplugging them and check how mouse behaves.

2. Is there any cable criss-crossing with your mouse cable? That can cause an interference, too.

3. If 1 & 2 above didn't help, try using your mouse in another computer to see if it is just really the mouse acting up and not your PC. Might be time to get another one.
 


bassfisher6522

Essential Member
#3
Are you using the synapse 2.0? If so try using the Razer DeathAdder legacy driver pacakge. I found with my Raze DeathAdder 3.5 I have better functionality with the legacy driver (which is what I'm using right now) than I do with the Synapse 2.0 cloud crap.

Razer.PNG
 


#4
i restart my pc after that i move the moues there is no lag but once i start to open any folder or brows the internet the lag appear again also i tested my razer dethadder mouse in another pc with windows 7 with Pentium cpu and 1 gb of ddr2 ram and i can move the mouse and brows the internet without any kind of lag , what is the problem this is nightmare :cry_smile:
 


badrobot

Senior Member
#5
I assume that the other PC is using a generic driver when you tested it? Are you using the Razer driver on your PC? You might wanna uninstall it and see.
 


#6
i used the synapse 2.0 latest update i will uninstall it and try Razer DeathAdder legacy driver package is it compatible with windows 8.1 ?
 


#7
i did everything i uninstall synapse 2.0 and the problem show again why am i having this lag please anyone help .
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#8
Try the 8.1.1 update as thats supposed to sort out certain mouse issues
http://windowsforum.com/threads/windows-8-1-1-update.187030/

If that doesn't help try running the driver in compatibility mode for say windows 7?

Is the mouse firmware the latest version?
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#9
If you don't fancy applying the full 8.1.1 update Microsoft do have a fix for mouse issues here:
http://support.microsoft.com/kb/2908279
 


#10
it appear that my lag is from enabling sli mode i disable sli mode now there is no lag i cant enter nvidia control panel how to fix this proplem how to enable sli mode without the lag ?
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#11
Which driver version are you using?
 


#12
337.50 beta
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#13
Try uninstalling using this app:
http://www.wagnardmobile.com/DDU/

That will remove any old bits of driver lying around and then install the latest WHQL:
http://www.geforce.com/drivers

Entering the Nvidia control panel is, as you know, by right clicking on the desktop or look under Hardware and sound in the control panel.
 


#14
i did clean uninstall after that i tried to install nvidia latest WHQL and suddenly in the meddle of the installation this massage appear now this so weird any idea

 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#15
Hi,
looks like you had a bsod. Please read the thread found here:
http://windowsforum.com/threads/how-to-ask-for-help-with-a-bsod-problem.178480/

I'll move your posts to the correct section so don't worry about having to make a new thread,

Did you try to re-install the driver?
 


#16
Is there a special driver from Nvidia for SLI mode, like OP states he using in post #10?
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#17
Is there a special driver from Nvidia for SLI mode, like OP states he using in post #10?
Nvidia FAQ states:
Which driver should I use?
NVIDIA® ForceWare® Unified Driver Architecture (UDA) supports SLI technology. Simply download the latest GeForce or Quadro graphics driver from the driver download page located here.

NVIDIA continually adds new SLI applications profiles to upcoming drivers. For the most up-to-date SLI application support, always use the latest drivers.
Ref:
http://www.geforce.co.uk/hardware/technology/sli/faq#c10
 


Last edited:
#18
guys i manged to solve the problem i disable some apps in the task manger before installing the nvidia latest WHQL and after that i installed nvidia latest WHQL and run it with admin now i have nvidia latest WHQL and there is no weird lag from my mouse i will never install beta drivers again thank you guys for helping me there hope this post help people with the same problem :peace:
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#19
Hey that's great to hear... Just out of interest was it a security app that you disabled or something else?
 


#20
no it wasn't a a security app i think that i disable all app in the srartup only
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.