Wireless not accepting security key

#1
My setup is Linksys WRT610N router, CNET RAlink CWP-905 wireless card

New clean install of windows 7 will not accept the correct valid security key when entered to connect to the network. It does not even seem to go away and check but immediatley says it is invalid.

I am trying to connect to my network using valid settings, WPA-Personal, AES, ********

I have tried completely resetting the router and all its settings yet windows 7 still no joy, my laptop and my xbox have all reconnected fine.

I see some others have had a similar issue but no real solution. As I want to use Win 7 for my mediaserver it needs to be on my network wirelessly. Any ideas?
 


#2
I would be thinking driver for your CNET RAlink CWP-905 wireless card, have you got the latest one from their site

It is also possible they need to publish a new one for windows 7 and just haven't done it yet :frown:
 


#3
I have similar problem. While installing Windows it asked me to enter password for my wireless but it said that it was incorect. After intstallation completed I could connect, but every time i restart my computer it doesn't remember password. I tried to connect to other wireless network, and then it worked (it remember my password), so I dont think that problem is in my wireless card. How could I solve this, because it becomes pretty annoying?
 


#4
arrggghhh tried to get the latest driver form cnet but zip file is corrupted from their website
 


#5
An update for everyone - An upgrade to the driver was pushed out today. I was able to connect to my wireless no problems once the update was installed. Thanks everyone for help
 


ickymay

New Member
#6
good to hear, I think drivers are going to be a problem for many months to come yet :frown:
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.