AD HOC/ Wireless Connection Sharing

Discussion in 'Windows 7 Networking' started by heau, Aug 31, 2010.

  1. heau

    heau New Member

    Joined:
    Aug 31, 2010
    Messages:
    10
    Likes Received:
    0
    Hello, im new here.
    To start off I am not trying to share internet connection, none of the computers have internet. They are not connected to Modems or Routers. The desktop(Host) has a USB Wireless adapter and is runing XP. The laptop(Client) has built in wireless card and is running Windows 7. I am trying to share files between these two, I tried folloing as How-to on the Microsoft website and still havent been able to Locate or Share any files with the desktop. They connect, I've been able to Play a multiplayer Game(Counter Strike) using this connection, but the Host doesnt appear on the client computer..or vise versa. Do i need internet connection to do this?

    It's ok if you have me start from scratch as in Create the Wireless Network, Im all ears or eyes whatever. lol. Pls help.
     
  2. heau

    heau New Member

    Joined:
    Aug 31, 2010
    Messages:
    10
    Likes Received:
    0
    I've tried alot of tutorials but still have had no luck with this..

    What I am trying to do is share files over a wireless connection.

    The host would be a PC Desktop running WinXP SP2. Using a Wireless USB Adapter, no router, no cables.

    The client is a Laptop running Win7 with a built in Wifi card.

    I created an adhoc network on the Desktop PC (WinXP) (Host) but I cant find the Computer name or the files on the Client Laptop (Win7)

    Anyone know what I could be doing wrong?
     
  3. sogoodtobe

    sogoodtobe New Member

    Joined:
    Mar 11, 2010
    Messages:
    70
    Likes Received:
    2
    Get both sides' IP addresses (DOS -> "ipconfig").
    Try accessing the other computer's files in your explorer by typing its IP address (\\IP_address such as \\192.168.1.2).

    On WinXP make sure file sharing is enabled under the connection's properties:
    - right-click your wifi's icon -> open network connections
    - right-click your wifi connection -> properties
    - make sure file sharing is enabled

    That same approach applies in win7 as well, although the network connections are bit tricky to list (DOS -> "C:\Windows\System32\control.exe netconnections" for direct access).

    If sharing is enabled, you might get a prompt to provide your login/pass (on the remote computer).


    hth.
     
  4. heau

    heau New Member

    Joined:
    Aug 31, 2010
    Messages:
    10
    Likes Received:
    0
    ty for responding to my thread.

    I've been told to do the same thing you suggested but havent tried it since what I am trying to figure out is a way to share files without having to type in any Ip or anything, all that the person trying to access these files would need to do is click the network name in his network connections and click connect and thats it, nothing else, no need for other special settings or anything, just click and connect.

    The computer that will be creating this Network connection would be a Desktop PC running windows XP, with a Wireless USB Adapter, that can be accessed by Win7 or WinXP. An Ad-Hoc network with no encryption and that is open is what ive read that can do this, I've created an Ad-Hoc network but when I try to access the PC Desktop(XP) from a laptop (Win7) neither computer can see eachother. I've found other tutorials that suggest to type the IP but what if somone that I dont know is trying to connect, how will they be able to? This is my goal....for anyone to be able to view the shared files on the PC Desktop(XP) ANYONE AT ALL but only view not to alter them or do any harm to the PC Desktop(XP).

    Thank you for your time.
     
  5. sogoodtobe

    sogoodtobe New Member

    Joined:
    Mar 11, 2010
    Messages:
    70
    Likes Received:
    2
    I get your point, but I'm only telling you how to start troubleshooting, not how to configure anything. As a matter of facts, the first thing is to understand why your computers cannot see each other - to understand that, you will have to use their IP addresses.

    That doesn't mean people will need your IP address all the time, it's only to understand the problem here and now.


    Hth.
     
  6. heau

    heau New Member

    Joined:
    Aug 31, 2010
    Messages:
    10
    Likes Received:
    0
    Oh I see thank you for clearing that up.

    Well I created a connection with the PC Desktop (XP) and I tried to connect to the PC Desktop from the Laptop running Win7. I typed in the IP( I typed in the one that says "IPv4 Address") a Web Browser window popped up saying it could not connect that the page is disabled or something like that. I did the "IPCONFIG" in the cmd.exe on the laptop and tried to connect from the PC Desktop and the same thing happened ..Internet Explorer started up saying it could not connect or could not find the webpage. Why is Internet Explorer popping up? I want nothing to do with the Internet...

    I did an IPCONFIG again on the Laptop and the Default Gateway wasnt blank......But when I was connected to the "Ad-Hoc" and did the IPCONFIG it WAS blank.
    Dont know if that means anything but just wanted to bring it to your attention. Thank you for your time.

    On the laptop I typed in the Pc Desktop's IP adress by click my user name then clicking the bar at the top and proceeded to type in the IP Address of the PC running WinXP

    On the PC I typed in the Laptop's (running Win7) Ip address by clicking "My Documents" and proceeded to type the IP in the Address bar where it sayd C/:Username/My Documents or watever.

    Thanks again for your time.
     
  7. sogoodtobe

    sogoodtobe New Member

    Joined:
    Mar 11, 2010
    Messages:
    70
    Likes Received:
    2
    When you type addresses within Internet Explorer, the software does interpret it in a way that would ease most people's lifes, but not yours here. Concretely, Internet explorer is likely to add "http://" to your entry, hence assuming that you are requesting access to an http service. Obviously, as there is none running on your computers, the browser will simply fail to display any webpage here.

    Back to my post above, I actually meant windows explorer and not Internet explorer - there's a slight difference. Open the explorer by right-clicking the Windows logo. Then type the address using backslashes (\) and not slashes (/):
    \\192.168.1.1
    Replace this with the real IP address

    Concerning the gateway field, I would expect that ad-hoc networks do not require default gateways by nature. This is correct for me.
     
  8. heau

    heau New Member

    Joined:
    Aug 31, 2010
    Messages:
    10
    Likes Received:
    0
    oh, yea i entered it in explorer not IE and the windows popped up, i will try it with the baclslashes, ty.
     

Share This Page

Loading...