Ampersand Not Working

#1
Hey there!

Recently my ampersand key just stopped working. It's only the ampersand, the #7 key underneath it and every other key works just fine, but not the ampersand. Using Windows 7 Ultimate.

Any ideas as to why?

Thanks!

Robbie.
 


#2
I need to bump this as I use ampersands a lot in programming and thus this is quite a major issue for me...
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#3
Can I assume nothing prints with the & key? Can I also assume all the other shift functions work correctly from both shift keys?

Is there any possibility the key combination has been assigned? I will look into this possibility more.

Just for the heck of it, have you turned your keyboard over to shake it?
 


#4
Hey! Yep, you'd be right on both counts. I don't know if it's been assigned but I doubt it since I'm pretty sure I haven't installed anything. Just gave the keyboard a good shake with no luck :p
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#5
Have you tried another keyboard?
 


#6
Hey,

Just tried it with a normal PS2 keyboard (the one that won't show the ampersand is a USB one) and it works fine on the PS2. So I'm guessing it's related to the keyboard drivers or something?
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#7
Only one key not working would seem to be a keyboard problem. You might try another USB keyboard, or at least use a different USB plug.
 


#8
Hmm, tried a different plug, didn't help. Don't really want to buy a new keyboard, can't begin to comprehend why only half of one key isn't working...
 


#9
Hi, I recently encountered the same problem. Ampersand is not working, neither is Shift-9 or Shift-Del. The shift keys are WORKING, the 7, 9 and Del keys as well, just not in their three specific combinations. I have a MS Comfort 2000 keyboard that has functioned without any problems so far, and I have no other software running that might steal keyboard shortcuts.

The only clue that I have found online is that it might have something to do with the multimedia buttons on the keyboard; I rarely use the Play/Pause key but a few days ago I did. Can't seem to undo whatever it is that that button might have done, resetting the keys to their default behavior did not help at least.
 


davehc

Essential Member
Premium Supporter
#10
Have you (or a third party program), possibly switched the keyboard language? Hold the left "Alt" key and press the left "Shift" key, and then release them. This changes between languages. Then try the & again. If this is succesful, you can check your keyboard language settings. Control Panel - Regional and Language options.
 


#11
I had this happen recently and it turned out to be the keyboard. It was a Microsoft Comfort Curve 2000. Plugging in a new keyboard fixed it.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.