Apparently new Com Surrogate stopped problem

#1
Before you jump on me, I searched through the other "COM Surrogate Stopped" threads and searched on the Windows tech support sites. I tried most of the solutions (some didn't seem at all applicable and I generally avoid reg edit) and none worked.

I installed a pristine version of Windows 7 on my wife's computer (Velocity Micro, 32-bit install). To my delight, it found my Lexmark Pro700 printer on my machine (HP, 64-bit Windows 7 factory install) via our home network. One of the things I tested is picture printing because that is important to my wife. I reloaded her picture files, opened a random picture in Windows Photo Viewer and selected print. The print option dialog opens, thinks for a second, then the whole Photo Viewer window fades, I get the dreaded "COM Surrogate Stopped" and, when I click OK, the program closes. This was before loading any programs other than Office.

I've added an exception for dllhost to DEP and ran regsvr32 on dllhost.dll and jscript.dll (jscript did not complete due to an unknown error). Still the same results. Any suggestions?
 


zvit

Honorable Member
#2
Here are some more solutions. (There are many)

1. How to fix “COM Surrogate has stopped working” issue | Web Talk
*(After the dll thing that you did, there are a few more steps. Also, there are other solutions there.

2. Fix for COM Surrogate Has Stopped Working Error in Vista - How-To Geek

You might want to look at many other solutions here:
COM Surrogate Stopped - Google Search
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top