Application Error after Error after Error

Discussion in 'Windows 7 Help and Support' started by pRey, May 5, 2009.

  1. pRey

    pRey New Member

    Joined:
    May 5, 2009
    Messages:
    58
    Likes Received:
    0
    Problems, Problems.

    I am running Windows 7 7100 x64 version.
    Everything is great, except.....

    I use a small program called TWX Proxy (you can search for it on web). It's used as a helper for an online game called Tradewars.

    Basically, I use a telnet program (usually ZOC) to connect to TWX.
    TWX then connects (telnet) to the game server.

    If I leave it at this.. it all works fine.
    But.. the TWX program uses scripts to automate in-game activities.
    Usually simple scripts based on triggers, such as, If I get an in game activity warning the script (stays idle until this message is detected) then sends out an 'enter' or something that will tell the server Im not idle.

    IF I load one of these scripts, within 5-10 mins, the TWX program will crash giving me the following error:

    Exception EAccessViolation in module TWXProxy.exe at 000C3429.
    Access violation at address 00623429 in module 'TWXProxy.exe'. Read of address 0000BABE.

    **This is a small program.
    **These is no installer.. you just unzip to a folder and run the EXE file and the program runs.
    I've been using this program for years. No problem in Win XP (have never used Vista)

    Ive tried all of the compatibility modes.
    I have even tried disabling User Access Control.
    I have tried with and without virus scanners / windows defender / firewalls running.
    I have tried disabling many Services (1x1) to see if the service would affect the program.
    I have tried using the 32 bit version of Win 7 also. Same result.

    No success.. The program will run for days as long as I dont load up a script. If I do... 5-10 mins later... poof.. application error..program shuts down.

    Any help would be appreciated.
     
  2. Radenight

    Radenight New Member

    Joined:
    Nov 16, 2008
    Messages:
    4,525
    Likes Received:
    108
    It's probably a case of just not being supported yet.. ;) There are still a few apps that just don't work right on Windows 7 yet... I suspect those will be fixed by the RTM or definitely by the Retail the way things are going.. ;) The list of apps that don't work has become ALOT smaller since just Build 7000 so I imagine that trend will continue with the RC and RTM.. :)
     
  3. pRey

    pRey New Member

    Joined:
    May 5, 2009
    Messages:
    58
    Likes Received:
    0
    I hope that is the case.
    I would try Virtual PC (or XP?) (XP mode?) for Win 7, but, my processor wont support that.

    Still, this program is used by so few people that I dont know that it would show up on Microsoft radar as being worthy to fix.
     
  4. Radenight

    Radenight New Member

    Joined:
    Nov 16, 2008
    Messages:
    4,525
    Likes Received:
    108
    Yeah that's a good point.. ;) Although, there's already alot of rare apps that are in fact supported by 7 this early in it's life so hopefully that app will also be officially supported sooner than later.. :)
     
  5. pRey

    pRey New Member

    Joined:
    May 5, 2009
    Messages:
    58
    Likes Received:
    0
    I have noticed something about how Win 7 is storing files associated with this program.

    Since this is such a small/simple program (no install etc etc) --- I think it is used to having everything in the same folder.

    What I noticed is.. Win 7 is storing files associated with this program in another location.

    For a simple example.. I have my Twx folder at C:\ProgramFiles (x86)\TwxProxy
    --inside the twx folder are usually (in Win XP) are 3 folders (data, scripts & logs) Which the Twx program randomally access and changes.

    -- With Win 7 -- the 'data & logs' folders are being stored in a totally seperate location
    ---> C:\users\ME\AppData\Local\VirtualSore\Program Files (x86)\Twxproxy

    Maybe the Twx program is looking for those folder & files (data & logs) where it "thinks" they should be (which is inside the origional Twx folder that holds the main .exe file)

    I dont know why Win 7 is automatically storing the data and logs somewhere else...

    Is there a way to change this??
     
  6. kingskin

    kingskin New Member

    Joined:
    Apr 9, 2009
    Messages:
    156
    Likes Received:
    0
    so, you unzipped the zip into the prog 86 folder and it created the three folders there as per XP, or are two of the folders created when you run the exe and they are being created in the wrong place? eitherway it's not good! I would think only a trip to the registry could sort it, or maybe you could open some of the smaller files from the program in notepad and see if they have a config file which references the other two directorys which you could then change?

    I dont think it's going to be an easy one to fix mate given like u say so few people are going to be running that set up

    sorry Ive reread your post and from what it says the files are created by the app. well again I would look through any smal files for a config.ini type file and have a look in there. the only other thought is the TMP file location in advanced system properties. Maybe have a quick search through the registry to see if the directory is listed somewhere..
     
    #6 kingskin, May 6, 2009
    Last edited: May 6, 2009
  7. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Just move or copy the program to the C:\Program Files folder.

    the (x86) folder is useless and can be deleted since you're now using the 64-bit version.

    You probably have a c:\windows.old directory which can also be deleted as long as you have copied your important files before install.

    If you get a access denied, download this free app called Unlocker:
    UNLOCKER 1.8.7 BY CEDRICK 'NITCH' COLLOMB

    There will be no references in the registry because it was replaced when you installed
     
  8. kingskin

    kingskin New Member

    Joined:
    Apr 9, 2009
    Messages:
    156
    Likes Received:
    0
    ^^ program files (x86) is still used for currently installed 32 bit apps mate, only native 64 bit apps get to go in
    the prog files folder. I really wouldnt delete it!

    windows.old can go though ;)
     
  9. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Sorry, but not when you do a "clean" install.

    Again, as I stated, there are no references in the registry pointing to anything in the x86 directory.

    All 3rd party apps need to be re-installed, whwther there in the x86 folder or not.
     
  10. pRey

    pRey New Member

    Joined:
    May 5, 2009
    Messages:
    58
    Likes Received:
    0
    Im not sure how clean my install was.
    Im dual booting with Win XP x64.
    The install was on a newly formated partition. I do have x86 directory though.

    As for the Twx program.. I have tried almost everything I can think of. Ive tried running in from many different folders: program files, program files (x86), from the desktop, in all compatibility modes, as administrator... etc etc.

    When program crashes, it does stay resident in the list of Process running. I have to open task manager and 'End Process' manually.

    I know this is not a widely used program. But its just a simple proxy type helper for a small text based game (Tradewars).

    Describing exactly what I am seeing may not make any sense to those who arnt using it..

    For example..
    -I boot up my telnet program (ZOC) and my proxy (TWX).
    -Zoc connects to TWX. (I just tell Zoc to telnet to 127.0.0.1 (port whatever))
    -I setup Twx with a game sever name to telnet to (ex. ultimatetw.com)
    -I hit Connect on Twx.. and the program connects (telnets) to the game server.
    -I login in.. choose a game.. then play.
    ***So far..So good.***
    Here is the confusing part..
    Twx Proxy was made as a Helper to automate certain tasks. Very simple scripts (mostly trigger based)
    Everything will run for days, IF, I do not load a script. If I do everything manually (eg move around universe, port and trade making $$).
    If I load a script.. the program will crash within 5-10 mins. Even the simplest of scripts.. 2 lines of code.
    (ex. of code)
    ------------------------
    waitfor "INACTIVITY"
    send "*"
    ----------------------
    btw "*" is the key for an Enter/Return

    something that simple cause an Application error.

    Something else I dont understand...
    Twx has the ability to Autoload a script upon statup up Twx.

    IF I load a script this way... It will run. Same exact scripts.. They are just loading 'with' (at the same time) as the Twx.exe program.




    I know it might be hard to understand what Im saying without looking at the program. But Im at a loss.

    For anyone who is bored and wants to take a look...
    download at Search Results for "twproxy.com" OR The Grimy Traders Script Database
    simple...free program.
     

Share This Page

Loading...