Audio and wireless disabled and can't restart after Crash

Discussion in 'Windows 7 Help and Support' started by skirkh, Sep 23, 2011.

  1. skirkh

    skirkh New Member

    Joined:
    Sep 23, 2011
    Messages:
    8
    Likes Received:
    0
    First post here!
    Windows 7 home premium. SP1
    Asus K52JT laptop
    AMD Radeon 6370M with HD audio
    Atheron AR9285 Wirelss adapter

    At my wit's end on this one. After a system crash a couple of days ago I found that my audio and wireless were disabled. Tried to restart the services but got error 1053 with wireless and error 1068 with windows audio.
    Have done the following:
    • Checked for any virus malware: Macafee AV, Malwarebytes, Spysweeper and Sptbot. Nothing found.
    • Tried starting in services on many occasions. Same issue.
    • Installed up to date drivers. Rolled back drivers to original versions. Same problem.
    • Ran troubleshooter in windows 7. Received notices that the services were stopped but could not be fixed.
    • Ran windows fixes from Microsoft site with the same result as W7 troubleshooter.
    • Downloaded copies of dll files and replaced them in win/system 32. Same problem.
    • Ran sfc /scannow found no issues.
    • Spent hours reading many forums and websites without any successful suggestions.
    I have my ASUS backup disk(s) so I can install the OS again but I don't want to lose the software I have already installed. So I am looking for any suggestions before taking that drastic step.
    Can anybody help?
    Steve
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    You seem to feel the two items are related, and they might be if some common component is involved.

    Can you tell us what services are not running?

    If you have changed drivers, you probably did that in the device manager. Are there any symbols or warnings next to those devices? Have you tried uninstall them and all of their drivers and allowing the system to reinstall?

    If you have controll keys, such as switching off the wireless on your keyboard, do those work?

    What did you do to be able to replace .dlls, and which ones did you use. These files are usually protected.
     
  3. skirkh

    skirkh New Member

    Joined:
    Sep 23, 2011
    Messages:
    8
    Likes Received:
    0
    I have tried running all the services without success. All that are involved with wirelss and audio are running.
    Control key for wirelss switches on the wirelss light but still the wirelss service will not start. Audio keys will not work and message saying the "audio device is not present keeps appearing".
    I used copies of the Wlansvc and audiosrv.dll from another computer. No difference so I changed them back.

    Wlan cannot be started in services. error 1053
    Audiosrv cannot be started in services. error 1068

    Got me really confused and I think the only way will be to restore the system.
     
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I am still at a disadvantage since what you are looking at goes beyond the normal fixes for your situation. Not saying you are wrong, just do not know.

    Are you starting (restart) Wlan from the Services.msc panel. Mine WLAN isn't running but starts fine. If you want, you can right click and select properties, then the Dependencies tab, it shows what other system components are needed. Maybe you can find something there. Notice the RPC, which seems to be involved in many processes.

    Since my WLAN is not running, perhaps you should try just stopping it and since it is set to use a Manual start, something else would have to start it. The Windows Audio (audiosrv) you mention is running and starts automatically.
     
  5. skirkh

    skirkh New Member

    Joined:
    Sep 23, 2011
    Messages:
    8
    Likes Received:
    0
    Thansk for the help. Decided to just go ahead and restore the drive image from the recovery disks. Wouldn't you know it but disk 2 of the 6 disk backup set is bad! Waiting to get a response from ASUS now on how to get a replacement disk or copy of the installed OS. Fun times!
     

Share This Page

Loading...