autocorrect or autocomplete

Discussion in 'Windows 7 Software' started by tonyroder, Oct 26, 2010.

  1. tonyroder

    tonyroder New Member

    Joined:
    Jul 23, 2010
    Messages:
    52
    Likes Received:
    0
    In Word 2010 I want to create keyboard shortcuts for frequently used words, such as "awa" for "as well as". I could do that in Word 2003 but I don't how to do it in 2010. would appreciate some handholding.
     
  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,830
    Likes Received:
    1,565
  3. tonyroder

    tonyroder New Member

    Joined:
    Jul 23, 2010
    Messages:
    52
    Likes Received:
    0
    I got as far as the Customize Keyboard dialog box, where the closest entry to autocorrect or autocomplete in Commands is AutoText, which does not let me enter an abbreviation for the word I highlight in the text. What must I do now?

     
  4. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,830
    Likes Received:
    1,565
    If you scroll down the category section you'll see 'All commands'. Have you checked to see if this section contains the command better suited for your needs?
     
  5. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Try this open MS Word 2010
    Type;
    I have been lol lately.
    If you have auto corrected turned on and configured properly you should get a red squiggley line under lol.
    Now right click on lol and choose auto correct and then auto correct options from the fly-out menu.
    In the middle of the resultant dialog box in the column titled Replace: type lol
    and then to the right of that in the column title With: type laughing out loud
    Click the add button and then the ok button
    Now in all future cases when you type lol into a document and hit the space bar it will be replaced by laughing out loud.
    Try it back space the lol out of the current document, type it again and hit the space bar.
    This technique has worked for me in every version of word that I can readily remember.
    Hope it works for you
     
  6. Elmer

    Elmer Extraordinary Member

    Joined:
    Mar 5, 2010
    Messages:
    3,873
    Likes Received:
    284
    Excellent Tip Trouble.
     
  7. tonyroder

    tonyroder New Member

    Joined:
    Jul 23, 2010
    Messages:
    52
    Likes Received:
    0
    Thank you Randy.
     
  8. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    You're quite welcome. I hope it was something you were able to use to address your issue.
     
  9. tonyroder

    tonyroder New Member

    Joined:
    Jul 23, 2010
    Messages:
    52
    Likes Received:
    0
    I'm embarassed to say, Randy, but I can't find a way to change the the shortcut for "AutoCorrect English" because it doesn't show in the Customize dialog box -- where the only choice I see is AutoText.
     
  10. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    And I'm embarrassed to say that I don't understand the question. Is it possible you are having an issue with an installed language pack or proofing pack? I believe that Microsoft Office uses the Windows Operating System default input language for its' default language and I suspect inorder to change this you will need to obtain the language and proofing packs you require. If you select
    "File" from the Ribbon/Menu bar and choose options, then select "Proofing" from the left column, most auto correct adjustments can be made here. The language option from the left column is where you set defaults for your installed editing languages, and or add or remove language / proofing packs.
     
  11. tonyroder

    tonyroder New Member

    Joined:
    Jul 23, 2010
    Messages:
    52
    Likes Received:
    0
    in this case English default enabled installed
     
  12. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Wow, I can't help but think that I'm just not getting it.
    Same place, file, options, customize ribbon. Left column, drop down and choose "Commands Not in the Ribbon", right column drop down and choose "All Tabs". Left column scroll down to AutoCorrect area, and select the command and use the add button, you may very well need to create a custom group in the tab of your choice, but it seems that you have already successfully done this.
    There are two different AutoCorrect Options, command link buttons that you can add, one just includes more tabs to all AutoCorrect options, the other, a more restricted interface. But the options to impact the behavior of the command link buttons from within the GUI is pretty much non-existent, they are what they are and they do what they do.
    You may want to read up on macro recording from within Word 2010 and see if you can find a more robust solution to what you are attempting to accomplish or maybe even VBA (Visual Basic for Applications) for Word. This may help get you started
    Getting Started with VBA in Word 2010
    If you find a more suitable solution to your issue, please consider updating your thread as I would also be interested in whatever you may find.
     
  13. tonyroder

    tonyroder New Member

    Joined:
    Jul 23, 2010
    Messages:
    52
    Likes Received:
    0
    That is the one I found in the "All Commands" column, and added it to a custom ribbon.
    It works like a charm when I click on it
    Now, I want to assign a shortcut to it.

    I click on the customize button for keyboard shortcuts.
    I go to All commands in the left panel.
    I look for but cannot find AutoComplete in the right panel.
    I must be doing something wrong.
    What, where?
     
  14. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    OK, a little slow but I think I'm getting it.
    Keyboard shortcuts are kind of independent of the ribbon so try this.
    Open Word 2010
    Select File from the menu bar and choose options
    Select Customize Ribbon
    Now just click the Customize button next to "Keyboard Shorcuts:" at the bottom of the left colum
    In the left column title "Categories:" choose "Home Tab"
    In the right column titled "Commands:" scroll down and choose either ToolsAutoCorrect or ToolsAutoCorrectReplaceText
    depending on which one you would like, you can do both if you want.
    Then Click into the box that says "Press new shortcut key:" Hold down the Ctrl Key and press the number 9 key on your numeric keypad (make sure numlock is on). That should do it.
    Test it to make sure that it does what you want.
    I hope I'm getting it right this time.
     
  15. tonyroder

    tonyroder New Member

    Joined:
    Jul 23, 2010
    Messages:
    52
    Likes Received:
    0
     
  16. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Glad to hear that you've resolved the issue. Thanks for updating your thread with the follow-up. Hope to continue to see you around the forums.
    Best Wishes
    Randy.
     

Share This Page

Loading...