[BSOD] DRIVER_POWER_STATE_FAILURE kernel debug help please

Discussion in 'Windows 7 Blue Screen of Death (BSOD)' started by kempokempo, Jun 1, 2010.

  1. kempokempo

    kempokempo New Member

    Joined:
    May 31, 2010
    Messages:
    4
    Likes Received:
    0
    hello
    I'm on a HP DV6 laptop runing Windows 7 Home Premium x64 and i'm getting a BSOD on suspend, shutdown and hibernate. System hangs for a while, then crashes.

    Other symptoms - I presume they're related - USB ports not working, and hanging installs and uninstalls of software (most work eventually though - and weirdly no hang on installing windbg).

    I ran a memtest overnight - 3 passes, all fine. Tried to run some more, changing the parameters to probe the memory, but that seemed to hang and not do anything for a few hours.

    Attached are recent crash minidumps - I've tried understanding what's going on myself and identifying the culprits, but I would appreciate some help.

    It's telling me it's umbus.sys or hpdskflt.sys or a combination of the two.... which is distressing. Any thoughts? Any and all help or comments would be appreciated.

    Many thanks in advance and i apologise if i'm committing any sort of faux pas by not including some information I really should have

    K
     

    Attached Files:

  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I haven't looked at the dump files, but do you know what the HP files does you reference?

    Can you keep it from starting using Msconfig.exe or use task manager to shut it down prior to allowing sleep or shutdown?
     
  3. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Hey.

    You're getting a 0x9f stop error with hpdskflt.sys.

    Code:
    Unable to load image \SystemRoot\system32\DRIVERS\hpdskflt.sys, Win32 error 0n2
    *** WARNING: Unable to verify timestamp for hpdskflt.sys
    *** ERROR: Module load completed but symbols could not be loaded for hpdskflt.sys
    Probably caused by : umbus.sys
    Hpdskflt.sys is an onboard mobile data protection sensor driver. Please visit HP.com to download and install the latest one for your particular hardware.

    Please let Intel's website scan for the latest drivers available to update these storage filter drivers and others if available:

    Code:
    iaStorV  iaStorV.sys  Wed Apr 08 12:57:17 2009
    iirsp    iirsp.sys    Tue Dec 13 16:47:54 2005 
    http://downloadcenter.intel.com/default.aspx?iid=gg_support-EN_01+home_downloadctr

    I would definitely try to update these drivers from Adaptec for your Ultra320 SCSI device:

    Code:
    adp94xx  adp94xx.sys  Fri Dec 05 18:54:42 2008
    adpahci  adpahci.sys  Tue May 01 13:30:09 2007
    adpu320  adpu320.sys  Tue Feb 27 19:04:15 2007
    This next driver is for Smart Array SAS/SATA Controller Media Driver. Probably a card reader driver. Please try to have this updated:

    Code:
    HpSAMD   HpSAMD.sys   Mon May 18 19:43:49 2009
    These drivers are for your Adaptec RAID Storport Driver and should be updated:
    Code:
    arc      arc.sys      Thu May 24 17:27:55 2007
    arcsas   arcsas.sys   Wed Jan 14 14:27:37 2009
    This Megasas Raid Controller drivers should be updated:

    Code:
    megasas  megasas.sys  Mon May 18 21:09:46 2009
    MegaSR   MegaSR.sys   Mon May 18 21:25:54 2009
    ql40xx   ql40xx.sys   Mon May 18 21:18:11 2009
    Your Realtek network lan driver can use an update for sure. Find your motherboard model using CPU-Z, Then lookup which kind of Realtek device it uses....or just check the device manager. Then update from the link after. Enter your type into the search. For example 8111c:

    Code:
    Rt64win7 Rt64win7.sys Fri May 22 10:52:30 2009
    Realtek


    There are further recommendations but I think we have enough on the plate to get started. Please post another crash dump after updating the above, if necessary and good luck.
     
  4. kempokempo

    kempokempo New Member

    Joined:
    May 31, 2010
    Messages:
    4
    Likes Received:
    0
    Thanks for the help - I'll work through the list...

    I'm starting to think this may have something to do with the WD MyBook World Edition i recently hooked up to the router - it actually appears in device manager as a disk drive. I'm going to remove that and the drive protection as well as update the drivers listed

    Will get back to you.

    Out of interest, what command did you use in windbg to get that level of information?

    Thanks
     
  5. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Well, this is what caused the actual bsods.

    Code:
    Unable to load image \SystemRoot\system32\DRIVERS\hpdskflt.sys, Win32 error 0n2
    So if that is to the WD MyBook World Edition, then it definitely did.
    The command - lmtn

    Very welcome.
     
    #5 TorrentG, Jun 2, 2010
    Last edited: Jun 2, 2010

Share This Page

Loading...