Cannot access jpgs or movs from 2nd drive encrypted

#1
I am hoping there is some small chance here. In anticipation for installing Windows 7 on my main drive I installed my new 1TB SATA drive as secondary under XP, formatted it and moved files to it. I had no problems accessing anything so I didn't think there would be any problem when I tried the Win7 64 bit RC. I never had any encryption set or anything on those files.

I did a new install to my main 300GB SATA drive where XP was and it installed fine and also created a Windows Old file. However, now when I try to do anything to a .jpg or .mov file on the 2nd drive it tells me I don't have access and I see that the file is encrypted. I have been reading everything on Vista and Windows 7 that might help me and nothing works. I have tried all of the following to no avail:

1) Taken ownership, added any and all permissions with full control, etc
2) Sharing the folders or the drive itself
3) Renaming my Windows 7 PC name and user name to match the old one
4) Adding certifcates for the ability to unencypt files using the local security settings, etc as it says on the web
5) Accessing, moving the files or changing permissions using BART's PE
6) Accessing, moving the files or changing permissions using Virtual XP mode

I am allowed to move the files within the drive itself or delete, but can't move them off, copy them or otherwise open or play them because of "permissions". It should also be noted that these are not all from one camera, the jpgs especially were taken with multiple cameras or even downloaded from the web in the last few years so the fact that they were all mysteriously encypted escapes me. When I look at the details of the encyption of a file, it tells me the old user name and comp name as well as the "certificate thumbprint" which is a string of letters and numbers. I did find a file with the same name in my Windows old folder but it says it is a "system file" and not an actual certificate and won't let me add it as one to use on this computer. I am out of ideas. Help is appreciated. All the programs out there that say they decrypt files have to have the old key and I apparently don't have it. Thanks in advance.
 


#2
I just found someone answering a similar problem with XP/Vista and he says:
"You need to create an account with the same username, password, user
number and machine sid as the original account, copy Crypto, Protect and
SystemCertificates directories from
X:\Docs&Settings\Username\Application Data\Microsoft\ to your machine
and log in as that user."

Any idea how to do that and where to get the original user number and sid?
 


#3
One other thought to piggyback the last one: I still have my full version of XP pro. Can I install XP using the settings in the Windows old file in Virtual box? Is that possible and will it give me the same login and SID as I had before?
 


#4
Anyone? A little help??
 


#5
in win7 go to the folder you want to claim back,
right click go to properties,
then to the "security" tab.

at the bottom is an "advanced" button, click it.
then go to the "owner" tab

at the bottom is an "edit" button, click it.
again, at the bottom is "other users or groups" click that.

you can type your username here if u like, or u can find it by clicking the "advanced" button at the bottom.
the click "find now" on the right hand side,
you will notice a list of names appears, scroll down and find your user profile, select it and click "ok"

in the next/previous window, u will notice your user is entered, click "ok" to continue.

make sure the "replace owner on subcontainers and objects" box is ticked, then click "ok"

____

you may need to add some permissions, do this by going to the "permissions tab"
at the bottom click, "change permissions"
click "add"
then find your user using the method explained above.
tick "replace all child object permissions with inheritable permissions from this object"
then click "ok"

and bob's yer uncle. enjoy hope that helps, worked for me!
 


#6
thanks but...

Thanks for the reply after all this time. That didn't work for me, not sure if you had the exact same problem I did but I tried every permissions step possible and basically, since I don't have a certificate for recovery agent (because I never encrypted anything)....it won't let me access them even if I am the owner, etc now. Crazy.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.