Cannot access XP PC.

Discussion in 'Windows 7 Networking' started by gengiscant, Aug 6, 2010.

  1. gengiscant

    gengiscant Well-Known Member

    Joined:
    Aug 6, 2010
    Messages:
    6
    Likes Received:
    0
    It is my fervent wish that one day that it will be far less trouble getting the basic computing needs to work without having to seek help.
    I cannot access the shared docs on the XP PC.
    I get the error \\*****\shared docs is not accessible etc etc.
    For some reason on the Win 7 PC under network I have 2 PC's with my name and 2 PC's with the XP PC's name, both the XP machines if double clicked show 3 printers,there is only one connected, and a shared doc folder.
    If I double click the shared docs I get the above error.
    I am using windows firewall on both PC'S and both have the same workgroup name.
    This is a fresh install of Windows 7.
    Everything is on in Windows 7 that should be on.
    Windows XP can access the 7 PC.
    I have googled but have yet to find a solution.
     
  2. CommonTater

    CommonTater New Member

    Joined:
    Jul 21, 2010
    Messages:
    868
    Likes Received:
    36
    Look in your Network and Sharing center in Control panel... Does it say "Home Network"?

    XP doesn't know home network, this is a Win7 contraption that 99% of the rest of the world does not understand yet. Any time you have mixed OSs on a network you pretty much have to revert to XP style "Workgroup" sharing... Which win7 calls a "Work Network".

    If it does say "home network", click right on the words and select "Work Network" from the list.
    Now go into your advanced sharing and enable "Username and Password" sharing and "Network Discovery".
     
  3. gengiscant

    gengiscant Well-Known Member

    Joined:
    Aug 6, 2010
    Messages:
    6
    Likes Received:
    0
    Ok have changed the network to work.
    "Network discovery" is on.
    Not sure why I should need "username and password" to be on as there are no passwords set.
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    As CommonTater explained, the Windows 7 Homegroup feature has no value to downlevel clients like Windows XP, so if the Win7 Machine is in a HomeGroup then choose leave HomeGroup from Network and Sharing Center.
    It would seem that the netbios cache table contains some invalid entries.
    Open a command prompt, Start Orb, All Programs, Accessories, Command Prompt right click choose run as administrator.
    type nbtstat -R this should purge existing information in the netbios name cache
    then use the ping utility to ping the XP machine, first by IP Address, and then by Name
    then examine the netbios name cache by typing nbtstat -c you should see the XP machine name associated with the correct IP address. I suppose it's possible that if the XP machine is multi-homed (multiple network interface cards) and both cards have Netbios over TCP/IP enabled on the same subnet, then you may get multiple entries in the netbios name cache table.
    You may want to address this by disabling the one you are not using. Machine names (host names) need to be unique.
    Usually the error you are getting is a product of some type of third party software running on the XP machine that is misinterpreting the attempts by the Windows 7 machine to access shares on the XP machine as a network intrusion. So if you have any additional firewall products or internet security suites running on the XP machine, make sure that you have included the Windows 7 machine as a trusted network node. I would usually recommended uninstalling any such products from the XP machine to make future diagnostic steps less problematic, you can always reinstall the software after the problem is resolved.
     
    CommonTater and (deleted member) like this.
  5. CommonTater

    CommonTater New Member

    Joined:
    Jul 21, 2010
    Messages:
    868
    Likes Received:
    36
    You need username and password sharing for compatibility with XP...
    Under XP every file share reqires a username and password. You will be asked for it the first time you access the share but it is remembered from then on.

    Under the Workgroup system, each folder share is set up individually and given a set of permissions for each user who accesses them. For example: "Everyone" might have read only access (likely what you're getting) but "Fred" might have full control, allowing him to modify, rename, delete and add files on the share. "Fred" needs a user account and password on the XP machine before he can access the share...

    There are two reasons you won't be asked...
    1) The user names and passwords are the same on both machines... this gets you access according to permissions.
    2) The target machine has no password set on the account and this gets you read only access.

    IOW... You may have to do some work on the XP machine as well.
     
    #5 CommonTater, Aug 6, 2010
    Last edited: Aug 6, 2010
  6. gengiscant

    gengiscant Well-Known Member

    Joined:
    Aug 6, 2010
    Messages:
    6
    Likes Received:
    0
    So far, a small progress has been made and also a small step back wards.
    I managed to remove the second XP PC with same name by disabling the 1394 connection. I three un-named printers alongside the shared docs folder I am trying to access.
    Turned on user-name and password on the Win 7 PC and as expected, the XP PC could no longer access the Win 7 PC as I have never set a password and no matter whether I left it blank or whatever, it was the wrong password. So I have switched that back off.
    I am able to ping the XP PC and the only security software I have on the XP PC is AVG and Superantispy and windows firewall.
    So what next folks?
     

Share This Page

Loading...