Cannot delete old user account files

Discussion in 'Windows 7 Help and Support' started by tjazar, Aug 21, 2009.

  1. tjazar

    tjazar New Member

    Joined:
    Apr 19, 2009
    Messages:
    22
    Likes Received:
    2
    To test out another problem I was facing, I created a new user account. Now I have no use for that account, so I deleted it, but just to be on the safe side I chose to keep all files from the account. So, Windows created a folder on my desktop with the old account's name, and in it were the folders one expects to find: Music, Pictures, Videos, etc. Turns out, these folders were empty, so time to go in the trash.

    However, Windows will not let me delete these folders. I am continually met with a UAC prompt telling me, "You'll need to provide administrator privileges to delete this folder." I am the admin for this machine, so I click Continue. I am then informed that I "require permission from [my user name] to make changes to this folder."

    I have tried the TakeOwnership reg edit, no success. I have tried using icacls to give myself delete permission, no luck. I enabled the Administrator account via net user, but even the Admin can't delete these folders! I can't even open them.

    I'm at a total loss here. Any ideas?
     
  2. tjazar

    tjazar New Member

    Joined:
    Apr 19, 2009
    Messages:
    22
    Likes Received:
    2
    Alright, just find a (perhaps roundabout) solution. Using Process Explorer from Sysinternals (wonderful tool!), I searched for the handle "Standard User" (the name of the old user's folder). It turned up a number of hits, most of which were used by wmpnetwk.exe. After I killed that process, I could delete the folder! Hooray!

    However, I'm just not sure why this happened in the first place. I guess I should just be happy that I got that dang folder off my desktop.
     
  3. treefort

    treefort New Member

    Joined:
    Dec 17, 2010
    Messages:
    2
    Likes Received:
    0
    Thanks for the tip! Hope I can find it or remember for next time I need it! :rolleyes:
     

Share This Page

Loading...