Can't connect Remote Desktop Server to License manager for RDP connections. 2022 Server on Vmware


New Member
Hi, I've been struggling with this for days. We set up a 2022 Server as a RDP server for a few users to connect to as virtual desktops. At that time, we did not have CALs yet, so I could not connect it to a license manager. By the time I received the CALs, the grace period had passed and users weren't able to connect anymore on RDP. When the CALs arrived, I set up a license manager on the domain controller, but the RDP server didn't connect to it to get the licenses.

So I installed the license manager on the RDP server itself and migrated the licenses to that. They show up fine in License Manager, but users still can't make RDP connections (not even domain admins). I've tried many things to fix it. One issue the RD Licensing Diagnoser listed was that the Licensing Mode was not set. I couldn't find a way to do it through the GUI, so I went into the registry and changed it from '5' (not set) to '4' (Per User). That issue no longer shows up, but it still shows the other issue: "The Grace period has expired but the RD Session Host has not been configure with any license servers." The license server is active on the RDP server, and in the registry it lists the server name under license servers. Still can't connect.

I tried uninstalling and reinstalling RDP roles. On Server manager, it has a Remote Desktop Services tab. On that section, it shows the server under "Servers", but on Overview, it says "A remote desktop services deployment does not exist in the server pool. To create a deployment, run the add roles and features wizard and select the remote desktop services installation option."
When I re-run that, it finds the server in "RD Connection Broker". I chose "Standard Deployment", then "Virtual Machine-based desktop deployment". I go through the next three steps and make sure the server is chosen in all 3, then click "Deploy". It shows that the "RD Connection Broker role service" and "RD Web access role service" succeed, but fails on "RD Virtualization Host role service". The error shown is:
Unable to install RD Virtualization Host role service on server (name.domain)
Exception of type 'System Exception' was thrown.
I've even uninstalled all the RDP services except the license manager are reinstalled, and still no change.
Any help is greatly appreciated.
Based on your description, it seems like you have tried a number of troubleshooting steps to resolve the issue with connecting your Remote Desktop Server to the license manager for RDP connections. Here are some additional steps that you can try:

1. Double-check that the licensing mode is set to Per User on both the Remote Desktop Session Host server and the license server using the Remote Desktop Licensing Manager.

2. Verify that the Remote Desktop Session Host server can communicate with the license server over the network. You can use the Telnet command to test connectivity to the license server on port 27000. If it fails, you may need to allow communication on that port through any firewalls.

3. Ensure that the Remote Desktop Session Host server has the necessary permissions to access the license server. Make sure the RD Session Host server is added to the Terminal Server Computers group in Active Directory, and that the group has been granted the appropriate permissions on the license server.

4. Restart the Remote Desktop Session Host server to clear any cached licensing information that may be interfering with connectivity to the license server.

5. Check the event logs on both the license server and the Remote Desktop Session Host server. Look for any errors that may be related to licensing or Remote Desktop Services.

6. If all else fails, try completely removing the Remote Desktop Session Host role from the server and then re-installing it. Be sure to back up any necessary data or configurations beforehand.

I hope these steps are helpful in resolving the licensing issue you're experiencing with your Remote Desktop Server. Good luck!
The server remembers the old licence and (more important) the fact that ran out is logged locally... There isn't a work around as the system is designed not to allow bypasses

I'd set it all up again... Quicker in the long run

Sent from my Nokia X20 using Windows Forums mobile app