Card Reader problems

Discussion in 'Windows 7 Hardware' started by jloizou, May 13, 2009.

  1. jloizou

    jloizou New Member

    Joined:
    May 13, 2009
    Messages:
    6
    Likes Received:
    0
    I have a new installation Windows 7 on my Acer 5610.
    I have a 5 in 1 card reader but don't work.
    I have put a lot of card but nothing happen!
    I also tried this: Control Panel>Folder Option>View and uncheck "Hide Empty Drives in Computer folder"
    but nothing. :(

    Somebody help me!!!
     
  2. jloizou

    jloizou New Member

    Joined:
    May 13, 2009
    Messages:
    6
    Likes Received:
    0
    I downloaded the driver for Windows XP from Acer official site and now it's OK!
     
  3. kukujiao

    kukujiao New Member

    Joined:
    May 14, 2009
    Messages:
    14
    Likes Received:
    0
    ur card reader is built in ? i've a problem where i insert my SDHC card, it will prompt me to format the SD card...
    but it just wont allow me to format as it will prompt " ur disc is read/write protected" which is actually not..

    any ideaS?
     
  4. jloizou

    jloizou New Member

    Joined:
    May 13, 2009
    Messages:
    6
    Likes Received:
    0
    Yes...it's built in!
    I don't have any problems...like these!
    Check your card protection!
     
  5. kukujiao

    kukujiao New Member

    Joined:
    May 14, 2009
    Messages:
    14
    Likes Received:
    0
    checked already..actually Vista/ XP manage to read the SDHC card, just W7 cannot...
    and mind to know wad is ur card reader version?

    mine is Ricoh 5-in-one card reader, Version is 3.52.02..
    however microSD M2 can read...so i dunno wad is the problem also :(
     
  6. jimscreechy

    jimscreechy New Member

    Joined:
    Oct 15, 2010
    Messages:
    2
    Likes Received:
    0
    I had this problem and it was a royal pain in the A** for me too. I tried all the fixes which of course didn't work, then some smart Alecky kid comes along with this fix which I tried and it worked. I doubt it will work for everyone, laptop users in paticular, but hey, like I said it worked for me and my desktop. Now it may sound silly but this is what I did. Uninstalled the device in device manager which had an error code 43 next to it. Shut the machine down. disconnected the power cord. Press the on button a couple of times for good measure, (to make sure the capacitors are completely dischared) you may notice a brief LED flash or Fan whirl when you first press the on button, even though the power cord has been removed, this is residiual power left behind being discharged. Leave the machine for a minute or two just to make sure. Boot the machine up, then try the card reader once you have logged in.

    This worked for me. For some unknown reason there was an error of the device during installation, and even though I had removed it from device manager residual power wasn't allowing the process to be completed properly. Removing the device and allowing the power power to drain completely from the system allowed the device to be reomved properly. I expect that there is a way to remove it via the registry, but like I said, if it can be done this way, you may save yourself a headache. Removing the battery if you have a laptop may also do the trick. Just make sure you remove the faulty device from device manager first.

    This happened to both my son's and my windows 7 64bit machines, and this fix did the trick. Hope this helps you guys.
     

Share This Page

Loading...