Devices and printers error from clean install

Discussion in 'Windows Vista Installation' started by a247Slacker, Jan 12, 2009.

  1. a247Slacker

    a247Slacker New Member

    Jan 12, 2009
    Likes Received:
    My devices an printers gives this error each time I launch it

    Faulting application name: DeviceDisplayObjectProvider.exe, version: 6.1.7000.0, time stamp: 0x4943197e
    Faulting module name: DeviceDisplayObjectProvider.exe, version: 6.1.7000.0, time stamp: 0x4943197e
    Exception code: 0xc0000005
    Fault offset: 0x000113ac
    Faulting process id: 0xa94
    Faulting application start time: 0x01c974ed34fc087d
    Faulting application path: C:\Windows\system32\DeviceDisplayObjectProvider.exe
    Faulting module path: C:\Windows\system32\DeviceDisplayObjectProvider.exe
    Report Id: 755bfe4b-e0e0-11dd-91a5-00301bb532c8

    The window comes up but nothing is listed. It did let me install a pinter that does work but the printer does not display, only when you go to print in an application then it shows up. Any help would be great.
  2. BlackWolf

    BlackWolf New Member

    Jan 11, 2009
    Likes Received:
    are you sure you got a valid copy? no torrent and nothing?

    What happens if you uninstall the printer?
  3. a247Slacker

    a247Slacker New Member

    Jan 12, 2009
    Likes Received:
    Nope it is from MSDN! build 7000 All patched up

    I will have to figure out how to uninstall the printer as it does not show up when the Devices and Printers crashes. The crash did occur Before I installed the printer though, the very first time I launched devices and printers right after the clean install.
  4. iroken22

    iroken22 Extraordinary Member
    Premium Supporter

    Nov 10, 2008
    Likes Received:
    indeed you will need to uninstall and reinstall the printer. It sounds like a driver was installed incorrectly and needs to be reinstalled.
  5. a247Slacker

    a247Slacker New Member

    Jan 12, 2009
    Likes Received:

    removed the HP laserjet 4m+ printer but I still can not launch Devices and Printers with out getting the above error every time :( I got the above error before even installing the printer must be somthing else I might just try reinstallling and make sure nothing is plugged into any USB ports during the install and see if that makes a difference.
  6. ynzai

    ynzai New Member

    Mar 24, 2009
    Likes Received:
    I have got the same problem. When I launch the device and printer I get an error Device Display Object Provider Has Stopped Functioning.

    Also I could not safely remove hardware for my USB drive.

    Anyone can help???
  7. fucpl

    fucpl New Member

    Apr 21, 2009
    Likes Received:
    Same here it cant start. Green bar goes for ever and nothing happens. I can only access add device, add printer by clicking on "hardware and sound" in the address bar
  8. whoosh

    whoosh Cooler King
    Staff Member Premium Supporter

    Apr 15, 2009
    Likes Received:
    Even though you got the ISO from MS are you sure the way you burnt the imagefile was ok ?
    You mention even b4 you installed the printer so maybe the problem lies with the img file ?
  9. tiagofortunato

    tiagofortunato New Member

    Dec 4, 2009
    Likes Received:

    I think I found a good solution.
    I've tried everything, from reinstalling drivers to the bluetooth service trick, and nothing seemed to work for me.
    So, after some research, I found a ie8-rereg.cmd that solved the problem. It seems that you need to re-register ole32.dll to solve the "Devices and Printers" and the "explorer double-click/new window" issue.

    This file contains the following lines:

    P.S: Copy the blue content to ie8-rereg.txt, rename to ie8-rereg.cmd, right-click on it and "Run as Administrator" - restart your machine and voilà !!

    @echo off
    echo IEREREG Version 1.07 for IE8 27.03.2009
    echo by Kai Schaetzl Internet Explorer FAQ
    echo installs and registers (if suitable) all DLLs known to be used by IE8.
    echo should only take a few seconds, but please be patient
    REM ******************************
    echo registering IE files
    REM IE files (= part of setup)
    regsvr32 /s /i browseui.dll
    REM regsvr32 /s /i browseui.dll,NI (unnecessary)
    regsvr32 /s corpol.dll
    regsvr32 /s dxtmsft.dll
    regsvr32 /s dxtrans.dll
    REM simple HTML Mail API
    regsvr32 /s "%ProgramFiles%\internet explorer\hmmapi.dll"
    REM group policy snap-in
    regsvr32 /s ieaksie.dll
    REM smart screen
    regsvr32 /s ieapfltr.dll
    REM ieak branding
    regsvr32 /s iedkcs32.dll
    REM dev tools
    regsvr32 /s "%ProgramFiles%\internet explorer\iedvtool.dll"
    regsvr32 /s iepeers.dll
    REM Symptom: IE8 closes immediately on launch, missing from IE7
    regsvr32 /s "%ProgramFiles%\internet explorer\ieproxy.dll"
    REM no install point anymore
    REM regsvr32 /s /i iesetup.dll
    REM no reg point anymore
    REM regsvr32 /s imgutil.dll
    regsvr32 /s /i /n inetcpl.cpl
    REM no install point anymore
    REM regsvr32 /s /i inseng.dll
    regsvr32 /s jscript.dll
    REM license manager
    regsvr32 /s licmgr10.dll
    REM regsvr32 /s msapsspc.dll
    REM regsvr32 /s mshta.exe
    REM VS debugger
    regsvr32 /s msdbg2.dll
    REM no install point anymore
    REM regsvr32 /s /i mshtml.dll
    regsvr32 /s mshtmled.dll
    regsvr32 /s msident.dll
    REM no reg point anymore
    REM regsvr32 /s msrating.dll
    REM multimedia timer
    regsvr32 /s mstime.dll
    REM no install point anymore
    REM regsvr32 /s /i occache.dll
    REM process debug manager
    regsvr32 /s "%ProgramFiles%\internet explorer\pdm.dll"
    REM no reg point anymore
    REM regsvr32 /s pngfilt.dll
    REM regsvr32 /s /i setupwbv.dll (not there anymore!)
    regsvr32 /s tdc.ocx
    regsvr32 /s /i urlmon.dll
    REM regsvr32 /s /i urlmon.dll,NI,HKLM
    regsvr32 /s vbscript.dll
    REM VML renderer
    regsvr32 /s "%CommonProgramFiles%\microsoft shared\vgx\vgx.dll"
    REM no install point anymore
    REM regsvr32 /s /i webcheck.dll
    regsvr32 /s /i /n wininet.dll
    REM ******************************
    echo registering system files
    REM additional system dlls known to be used by IE
    REM added 11.05.2006 Symptom: Add-Ons-Manager menu entry is present but nothing happens
    regsvr32 /s extmgr.dll
    REM added 12.05.2006 Symptom: Javascript links don't work (Robin Walker) .NET hub file
    regsvr32 /s mscoree.dll
    REM added 23.03.2009 Symptom: Find on this page is blank
    regsvr32 /s oleacc.dll
    REM added 24.03.2009 Symptom: Printing problems, open in new window
    regsvr32 /s ole32.dll
    REM mscorier.dll
    REM mscories.dll
    REM Symptom: open in new tab/window not working
    regsvr32 /s actxprxy.dll
    regsvr32 /s asctrls.ocx
    regsvr32 /s cdfview.dll
    regsvr32 /s comcat.dll
    regsvr32 /s /i /n comctl32.dll
    regsvr32 /s cryptdlg.dll
    regsvr32 /s /i /n digest.dll
    regsvr32 /s dispex.dll
    regsvr32 /s hlink.dll
    regsvr32 /s mlang.dll
    regsvr32 /s mobsync.dll
    regsvr32 /s /i msieftp.dll
    REM regsvr32 /s msnsspc.dll #no entry point
    regsvr32 /s msr2c.dll
    regsvr32 /s msxml.dll
    regsvr32 /s oleaut32.dll
    REM regsvr32 /s plugin.ocx #no entry point
    regsvr32 /s proctexe.ocx
    REM plus DllRegisterServerEx ExA ExW ... ?
    regsvr32 /s /i scrobj.dll
    REM shdocvw.dll hasn't been updated for IE7 and IE8, it still registers itself for the Windows Internet Controls
    regsvr32 /s /i shdocvw.dll
    regsvr32 /s sendmail.dll
    REM ******************************
    REM PKI/crypto functionality
    REM initpki can take very long to run and is rarely a problem
    REM if there are problems with crypto, SSL, certificates
    REM remove the three following REMs from the lines
    REM echo We are almost done except one crypto file
    REM echo but this will take very long, be patient!
    REM regsvr32 /s /i:A initpki.dll
    REM ******************************
    REM tabbed browser, do at the end, why originally with /n ?
    regsvr32 /s /i ieframe.dll
    REM ******************************
    echo correcting bugs in the registry
    REM do some corrective work
    REM Symptom: new tabs page cannot display content because it cannot access the controls (added 27. 3.2009)
    REM This is a result of a bug in shdocvw.dll (see above), probably only on Windows XP
    reg add "HKCR\TypeLib\{EAB22AC0-30C1-11CF-A7EB-0000C05BAE0B}\1.1\0\win32" /ve /t REG_SZ /d %systemroot%\system32\ieframe.dll /f
    REM ******************************
    echo all tasks have been finished


Share This Page