Disappearing New Partition Part 2

Discussion in 'Windows 7 Help and Support' started by ravna, Dec 24, 2011.

  1. ravna

    ravna Senior Member

    Joined:
    Jun 19, 2009
    Messages:
    58
    Likes Received:
    3
    Hi Guys...asked a similar question back here with no outcome.

    1 This time another brand new computer, Win7 Professional, 64Bit with SP 1, 1TB HDD with 2 partitions...one system and an OEM recovery partition.

    2 Decide to shrink main system partition to create two equal sized partitions using Win7 Disk Management Tools.

    3 Do so...format the new partition and new 'Drive' letter automatically allocated.

    4 Place data in new partition, manipulate, create new folders etc....great no problems.

    5 Shut computer down...restart next day....partition including drive letter not visible in Explorer...go to disk manager...partition visible but no drive letter and when 'Right Clicked' only option is 'Delete'

    6 Delete partition and extend volume back to original....search the Forum and see mention of "great tool"...'MiniTool Partition Wizard...download..try...exactly the same results, just uses a more graphical interface.

    The big question is Why is this thus?.... am running out of hair. [​IMG]
     
  2. whs

    whs Extraordinary Member

    Joined:
    Sep 17, 2009
    Messages:
    1,541
    Likes Received:
    106
    Partitions do not disappear into thin air. There is some process that manipulated it and deleted the volume. I would inspect my startup programs and search for culprits. Agreed, it is a bit unusual. But there must be a logical explanation.
     
  3. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    How about taking a picture of the Disk Management window, maybe we will notice something.

    The only other thing that might be involved is the system recovery process is protecting the drive to keep it where it is. I have never seen this happen, but could be a possibility.
     
  4. Medico

    Medico Senior Member

    Joined:
    Sep 20, 2011
    Messages:
    1,158
    Likes Received:
    65
    I have used mini partition tool (Partition Wizard) with great success for doing just these things. I have deleted partitions, expanded partitions to unallocated space both behind and in front of the active partition with no hiccups at all. I have shrunk partitions to leave unallocated space then formated this newly created unallocated space to allow installation of a second dual boot OS, the whole gambit of operations. Something else is happening on your system.

    Posting a screen shot might help us to understand your setup.
     
  5. ravna

    ravna Senior Member

    Joined:
    Jun 19, 2009
    Messages:
    58
    Likes Received:
    3
    I hope there is whs....but disappear they do, as in if you can't access them they are gone, and I very much doubt there is any program in the start menu with the permissions to delete a partition...if there were it would be chaos across the board in computer land.

    Saltgrass...unfortunately I was so p*&##d off I forgot to take any snips but everything looked normal as I tried three times and paid particular attention to drive letter allocation and volume state and name as in 'Primary', size etc.

    It is interesting that I am not the only one to suffer this. During a search of other forums I came across this question to Microsoft answers...at first I thought it was my post as it is nearly identical to what I wrote, see here.

    The only thing this guy ended up doing different was to reinstall Windows but he did not say if it was from the 'Recovery' partition or a clean instal with other media.

    I have a suspicion the recovery partition may be responsible as it is at the end of the disk...but still to play around with that thought and do some further research..may just clone the recovery partition and delete the original and try again...am determined to get to the bottom of this.
     
  6. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I can't rememeber, did you supply a snipping tool picture of Disk Management in another thread? It doesn't have to be a previous version, but whatever you are showing now.
     
  7. ravna

    ravna Senior Member

    Joined:
    Jun 19, 2009
    Messages:
    58
    Likes Received:
    3
    Hi SG...here are some snips to show what happens...results still same after reboot.... Capture 1.PNG Capture2.PNG Capture3.PNG Capture4.PNG

    I think they are pretty self explanatory...and as you can see in 3...right click gives only the 'delete' option
     
  8. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Well, several questions seem needing an answer.

    Why do you have so many active partitions. You only need one.

    Why does it say it wasn't made by Windows?

    Have you tried making a smaller partition to see if it would stick?

    My best guess is going to be the Recovery partition is some how trying to keep the drive in its original configuration. Maybe disconnecting the other drives would help see what is happening.

    If the 9.77 G partition is the OEM partition, what is the Recovery partition on the second drive?
     
  9. ravna

    ravna Senior Member

    Joined:
    Jun 19, 2009
    Messages:
    58
    Likes Received:
    3
    Not sure how 'Disk 2' was marked 'Active' but have since marked as 'Inactive'....don't think this will/would affect the creation of a new Partition though.

    As to 'Not made by Windows' assume it is like the 'Defrag' program used by Win7...its a third party Partitioning software program. The same message appears if you use MiniTool to do the same job.

    The drive you see as 'F' is a system drive from the guys old computer...trying to recover all his data after a major system crash and is now gone.

    Actually used MiniTool to move the Recovery Partition to just after the OS partition...but because MiniTool stacks all commands for a 'One Off' action there was a mistake in the command Que and the move failed...will try again later.
     
    #9 ravna, Dec 28, 2011
    Last edited: Dec 29, 2011

Share This Page

Loading...