Disk Defragmenter Detects Hard drives as solid state instead of regular

Discussion in 'Windows 10 Help and Support' started by Doug Bordell, Mar 27, 2016.

  1. Doug Bordell

    Doug Bordell New Member

    Joined:
    Mar 27, 2016
    Messages:
    1
    Likes Received:
    0
    I converted from Windows 7 Home to windows10. When I go to Disk Defragmenter it tells me I can't optimize because my drives are solid state. My Drives are Hitachi SATA. How can I make Windows 10
    redetect my Hard Drives?
     
  2. Neemobeer

    Neemobeer Windows Forum Team
    Staff Member

    Joined:
    Jul 4, 2015
    Messages:
    2,412
    Likes Received:
    366
    Can you list the make/model of your computer.
     
  3. ussnorway

    ussnorway Windows Forum Team
    Staff Member Premium Supporter

    Joined:
    May 22, 2012
    Messages:
    2,540
    Likes Received:
    318
    many moden hard drives are hybrids... what is the hdd model as well please?
     
  4. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,052
    Likes Received:
    303
    Hi

    You can check out Defraggler and see if it works better.
    I've used it for years to defragment my computers.

    One of the best things about it is that once it has been defragmented it has a file defrag mode.
    You can chose to just defragment, fragmented files without doing the entire drive, which it can do in only a few minutes.

    I do it several times a week, and it keeps my computer all clean and speedy.

    Defraggler 2.21.993

    It's made by the same people who make CCleaner.

    Mike
     
  5. Neemobeer

    Neemobeer Windows Forum Team
    Staff Member

    Joined:
    Jul 4, 2015
    Messages:
    2,412
    Likes Received:
    366
    Just remember if it really is an SSD or is a hybrid with an SSD cache, do not defragment it you will severely reduce the drives life.
     
  6. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    The Windows 10 defragger is designed to recognise SDDs. It will automatically only trim/optimise, an SSD
     
    kemical likes this.
  7. bochane

    bochane Honorable Member

    Joined:
    Oct 18, 2012
    Messages:
    643
    Likes Received:
    47
    With some older MoBo's Windows can't detect SSD's; you will see a SCSI disk instead.

    To avoid that the weekly Auto Defragmentation reduces the life of your SSD, you can tick it off at the properties section of the disk.

    If WIndows did detect an SSD, you better leave it that way.
     
  8. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    That is interesting, Henk
    I know that earlier releases of Windows 10 were having problems with SSDs on a Raid assembly, which was sorted on later editions, but have not heard of anything as specific as your post.
    I think this is serious enough to discuss in the Microsoft forums, and, for all, to provide feedback. The Defrag is on by default. For the unwary, this could potentially lower the life of the SSD.
    Could you give me any links or info on the subject of ols SSDs, as I would like to take it further.
     
  9. bochane

    bochane Honorable Member

    Joined:
    Oct 18, 2012
    Messages:
    643
    Likes Received:
    47
    It are old MoBo's causing that Windows is unable to detect the SSD. It is a common problem. Those old versions of BIOS don't support IDE and AHCI modes. Just recently I did an upgrade where I saw it. I solved it by removing the auto defrag mark somewhere in the properties settings of the disk.

    I found the following information on internet:

    This only happens, if you change the BIOS settings of the SATA ports from "IDE" to "AHCI" after the Win7 installation.If you do it before starting the OS installation, the in-box MS AHCI driver will automaticly be used by Windows 7 (no risk of any boot problems and no manual registry manipulation required).

    And this
    For instance, the PC in my profile specs has an 2007 Phoenix-Award BIOS, and it offers what interface/mode you would like to apply to the drive. One option is to run the SATA drive in EIDE mode, or SATA mode. It also offers the option to run RAID, or not. When I apply the EIDE mode to a SATA drive, the drive does not show as an SCSI drive in Disk Management, but when I disable that option it does show up as an SCSI
     
  10. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    Thanks for the input. Not enough there, I'm afraid. The quote refers to Windows 7, and the second para to the bios (SATA), which, as I said, has been , hopefully, corrected in the latest Windows 10.

    info. Your :"I solved it by removing the auto defrag mark somewhere in the properties settings of the disk."

    Start - All Apps - Windows Administrative Tools - Defragment and optimise Drives
     
  11. bochane

    bochane Honorable Member

    Joined:
    Oct 18, 2012
    Messages:
    643
    Likes Received:
    47
    Removing Auto Defrag Mark:
    Right Click on C: > Properties > Extra > Optimize > Change Settings

    BIOS
    That old BIOS of that MoBo did not offer a choice between AHCI and EDI and I think that that makes the difference.

    Two remarks - and sorry for that!!
    - I am on a non English version of Windows, you will probably see slightly different names for options
    - I returned that old PC, so I don't have the type number of that MoBo. But it is a common problem; I found many hits in Google.

    Hope this helps,
    Henk
     
    #11 bochane, Mar 29, 2016
    Last edited: Mar 29, 2016
    holdum333 likes this.
  12. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    Trivial observation, Maybe language differences. On my computers, the path you mention is Right Click - Properties - Tools - Optimise. --- No "extra" offered.

    Again, your response is appreciated. I am already in a dialogue (usually hopeless!) with MS on the subject.
     
  13. holdum333

    holdum333 Banned

    Joined:
    Mar 27, 2016
    Messages:
    1,244
    Likes Received:
    147
    Capture48.JPG Hi Henk! Your suggestion worked for me. I now have only the C drive selected to optimize weekly!
    Thanks!
     

Share This Page

Loading...