Explorer.exe taking up 15-30% CPU usage when moving mouse on desktop

I don't have any programs opened just the task manager. When I'm not moving the mouse my CPU usage stay from 0-2% but as soon as I move the mouse pointer, even though just a bit, it shoots up to 30%!!!!

Why is that happening? I'm really frustrated about it.



Extraordinary Member
That is extraordinary. Could you give some brief details of you computer memory size and the type of mouse you are using. Fwiw. Moving my mouse does not affect my CPu by more than about 1% - sometimes not at all.

I have 4GB of memory in my laptop and I'm using a logitech v450 nano mouse. I never installed the software of that logitech.

What program can I use (and how do I use it) to monitor the thread activities of the explorer.exe process?

Is this the only way to determine which thread is causing explorer.exe to be using high cpu usage?

I just noticed that even though I totally don't move the mouse pointer, after 30 seconds or so, the CPU usage just boosts up high and after 1 second it drops to 0-1% again.

BUT, continually moving the mouse pointer will maintain the high CPU usage 20-30%.

I had this problem with my Razor copperhead gaming mouse But, this was because of the polling rate on a very weak processor, when I swapped my mouse to a different pc with a better processor, the cpu usage did not jump like how it did on the weak processor.

What processor is in the laptop and how old is that laptop?

Try doing the same with a different mouse & try that mouse on another pc if you have a second pc.

Last edited:
I think this is not a problem with the mouse, since I already tried another mouse.

I have a P9500 (2.53GHz C2D) processor and a Sager NP8660 Laptop with 9800M GTS vidcard. My laptop is less than a year old.

Also, as I've said in my above post, even though I don't really move the mouse pointer the CPU usage of the explorer.exe hovers up and down. Very weird.

Open control panel and click on 'Device Manager'. Expand 'Mice and other pointing devices' and see how many device drivers you have active. If there is more than one, try diabling them one at a time to see if this corrects the problem. Pleas note that you take a risk when you disable a driver that your mouse will not work at all, so be sure you know how to navigate with the keyboard prior to making any changes.

Tried that already. I even tried just using the Touchpad of the laptop, same problem.

I highly think that this is not a problem with the mouse since it happens even though you don't move the mouse pointer. Moving the mouse pointer will just maintain it at 20-30% explorer.exe cpu usage and NOT MOVING the mouse pointer would make it go up and down.


Extraordinary Member
prehaps its something to do with power settings...maybe the cpu throttles up and down due to other background activity....such as windows defrag (which is enabled to defrag in spare cpu cycles), windows defender (again hidden task that auto scans etc), plus whatever anti-virus etc, as my pc never budges off 1% when idle or simply wandering about the desktop.

Last edited:


Extraordinary Member
Try this. Make a note of your alterations so that you may return to the defaults if needed.
Type Services.msc in the Start, or RUN box.

Scroll down and disable the following. You can do this all at once, orby elimination, one at a time.
Security Centre
Windows Defender

The problem is unlikely to have anything to do with the Defrag program, as at worst, it is only scheduled to operate once a day, not continually.


Extraordinary Member
The problem is unlikely to have anything to do with the Defrag program, as at worst, it is only scheduled to operate once a day, not continually.
ya sure cos mine was set to defrag on idle 24/7 till i disabled it off sheduling


Extraordinary Member
These extracts from MSDN pages.
"Defragmentation is scheduled to automatically run periodically and in the background with minimal impact to foreground activity. "

"The Disk Defragmenter process starts according to a schedule that you can adjust. During this period it operstaes at low priority and only when the computer is idle."

But, as a matter of inetest, how did you set it to run 24/7?


Extraordinary Member
no idea to be honest, i merely noticed it was always running...until i completely took it out the equation and deleted it and disabled its shedules, replaced with the nicer auslogic defragger a day or so after installed the OS


Extraordinary Member
Interesting. Well, anything on a schedule is forever periodically scanning, I guess. Maybe in the case of the defragger, the monitoring was enough to give you a problem.

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.