explorer folders slow, green bar

I have a few folders with video's, and some of them are really slow to display the contents of the folder.
This is a new setup of vista business 64 with SP1, I had a similar setup of vista 64 before (on the same computer) and never had this problem.
I switched drives for another brand (samsungs to seagates), but according to performance tests they should be just as fast or even faster.
I already tried options->use icons, never thumbnails but that made no difference.
Also tried other options on/off, but no difference.
I have readyboost and windows search turned off, turned off mcafee, tried other view settings, it all makes no difference.

Has anyone have any more ideas ?


Windows Forum Admin
Staff member
Premium Supporter
specs please

intel q6600 3,3Ghz
4 Gb mem
2,5 TB raid 5

Not that it should matter, a previous setup on this pc didn't have this problem.
Also some folders with the same amount of video's also show instant.


Windows Forum Admin
Staff member
Premium Supporter
The reason why it takes a long time is because vista is loading it into the RAM, perhaps turning off 'superfetch ' may help but I doubt it. I use large DVD's to store files and at times it can be frustratingly slow at opening the disk as once again all the files are being loaded into the RAM... You could also try opening device manager, look under disk drives and right click the set up found there. Choose properties and then policies. Near the bottom of the revealed box is another way to increase disk performance so try ticking that.

You could try more RAM....lol

That wouldn't explain why some folders with the same amount of files load instant and others are slow, and why in a previous setup it was always fast.
Besides, disabling superfetch didn't help either.
I would understand if files would be slow on DVD's because that also depends on the speed of the dvd drive.
But my harddisks perform very well, but even if it was the harddisks, then why would some folders be fast ?
And the performance properties of harddisks are not used when you have a raid setup.
And lets be honoust, more ram wouldn't help either, it only uses up to 25% at this point.


Windows Forum Admin
Staff member
Premium Supporter
Yup your right of course I forgot it worked in an earlier set-up... oh and I was only joking about the RAM.. Have you tried googling the problem??

yep, but I can only find the basic solutions like the explorer options and turning of services (and more ram :)). And they don't help.


New Member
Has anyone been successful in discovering a remedy for this issue. I have the very same problem with Win vista Home Premium SP1.The folder in question contains a lot of .avi file(121GB's). What is odd is I have a dual boot system with Win XP Home also and if I open the same folder under XP it displays the files immediately. Vista behaves like this no matter what way I display the files, tiles, list ect. Anyone know why this is. Oh and I am also sure this did not always occur like this, I have just noticed it recently.

Coolermaster Wavemaster Case, Syncmaster 215TW Monitor, Dual Boot Win XP HE/Vista HP SP1, Evga 780i SLI, Core 2 Quad Q9450 + Zalman CNPS 9700 NT Cooler, Evga 8800GTS KO AC3S 640MB, 6GB Crucial BallistiX PC6400 SLI, 2 x WD Raptor 74GB, Hitachi Deskstar 250GB, Seagate Cuda 250GB, Plextor 708A + BenQ LS DW1655 DVD Writers, Creative X-Fi Extreme Music, Logitech Z-2300 2.1 THX, MS Intellimouse Explorer Bluetooth, PCP+C 750W Quad SLI PSU.


Essential Member
Premium Supporter
Are you up to date with your graphics drivers?
Nvidia, for example, has some betas out at the moment, and I believe ATI/amd are throwing around a "7" beta.
Kemical keeps everyone up to date with the drivers. Have a look here:

I have the same issue, started to happen 3 to 4 days ago. Large folders with avi take up to 1 minute to show up with files, last week it was instantaneous. I have checked for viruses, super-fetch, my x box reads the files quicker then vista explorer. Once the files come up and I click another folder and back it takes another minute for anything to show up. All I remember that there was a update the system did last week on start up, as I walked into the room I saw the end of a black screen with regetit on it before it changed to the blue update screen as window starts up (2 of 3…).:mad:

Just found the solution, go into the folder that takes a long time to show up.

Wait till all files are visible.

Click on name column 2 times (to sort the files by name).

Click to another folder and back.

Done!… all it needed is to be sorted!!! And people were reinstalling their OS… I will be having a ritual burning of my Vista license certificate when windows 7 is out!

That did not work for me but I have a folder with 147 .avi files of approx 700mb per file. However what did work was this. When I right clicked on the folder and selected "Customize", "Pictures and Videos" was selected in the "Use this folder type as a template". When i changed this to "All Items" all was well and now the folder loads very fast irrespective of what view method is chosen.

Just wanted to sign in here and thank Gerry for finally finding the answer to this one.
I knew what was happening because there were different columns being displayed in the detailed view for
video and image folders, and knew it would have to scan all the files to read that additional info (thus why you
see the slow loading green progress bar) but didn't know there was an option to change the folder behavior
back to normal until now. Thanks. Now they load *instantly*.
I've seen many people complain about this problem for Vista and Windows 7 in other forums
but this is the only place I've seen the answer.

[langtitle=es]Re: explorer folders slow, green bar[/langtitle]

[lang=es]También para mí la solución fue difícil de encontrar, pero es más sencilla de lo que parece.
El detalle es que los discos duros adicionales o las particiones adicionales no están agregadas por defecto al índice de búsqueda. Por lo tanto, windows tarda demasiado en identificar los archivos contenidos en cada carpeta.

Simplemente habrá que posicionarse en cualquier carpeta, o más aconsejablemente en la raíz de toda la partición o disco duro, y realizar una búsqueda desde la barra de búsqueda en la parte superior derecha (no importa qué tipo de búsqueda)
Casi inmediatamente aparecerá una banda amarilla con la advertencia de que las búsquedas serán muy lentas en esta carpeta hasta que se agregue al índice. Es necesario aceptar que la carpeta se agregue a dicho índice, y eso es todo. Desde ese punto, la barra verde de búsqueda de contenidos no deberá aparecer otra vez.

Espero les sirva esta solución. Saludos![/lang]

(espero que con estas pesimas traducciones automaticas del sistema puedan enterder lo que en realidad quise decir)

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.