External HDD locked access!

#1
Hi all, i am new to this forum and am in great need of knowelabdel assistance .
Basically i tried to secure several files in my Western Digital HDD by right clicking and selecting the option "share with ....nobody". this allowed me to still enter the file afterwards.
Next time i log on my drive shows no details and when i click on it says access denied and i cannot enter the drive at all.
i have tried many times to unlock to no avail.

When i plug my HDD into my older windows xp pc it shows the correct details of the drive and i can access it though not the 3 files i locked but still this does not help.

Can anyone shed any light on this problem as the locked files i cannot bear to lose (old baby pictures etc)
many thanks in advance
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#2
To understand you situation, a couple of questions:

Did you share specific file in a Folder, or an entire Folder with those files in it?

Did you select to not share the entire drive with no one?

I tried you situtation on an internal drive so the folder showed the lock, but was still able to access it after a reboot. Depending on your answers, I will try my external drive next.

You can start explorer in Admin mode by right clicking the taskbar icon, then right clicking Windows Explorer and selecting "Run as Admin", maybe that would help.
 


#3
thanks for your reply, in response - i locked 3 folders within the external hdd but not the whole drive iirc. i have tried to run as admin but still shows access denied to my external hdd.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#4
I just tried mine and selected Sharing from the context menu and Nobody for a folder on the external drive. Rebooted and was still able to access it.

Next, I suppose we need to look at the properties of the folder/s to see if a sharing change, or maybe even some type of security change might need to be made. If you can get the properties and the security tab, maybe check who is owner or what permissions the different users have...
 


#5
i have done the above and 2 groups/usernames exist namely SYSTEM and administrators(laptop/administrators)
both have all permissions ticked except special permission.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top