Extremely hidden folder

Mitchell_A

Essential Member
#21
This is just so strange.
There's no reason for those files to be invisible anymore, there really wasn't in the first place.
If you copy a file to the folder, is it visible? If so then looks like a browser problem.
 


#22
I agree, it's incredibly strange. Just copied a file to the folder. It warns me that I have to be Admin to do so, but when I click OK it goes fine and is perfectly visible.

I can't call this a "browser problem" because: 1st any 32bit program can see it (unless run as Admin or without UAC, wtf?) and 2nd if the browser saves files with some strange permissions that makes it nearly invisible to everything else, I still consider that to be a fault of the OS or filesystem

Just saved your sigpic to the folder and it also defaulted to locked, invisible. So it does seem to be something about how the browser saves files (and perhaps all 32bit programs, only tried reading the files with others). But let's recap some of the craziest points:

* It shows me as the owner in the owner tab, but not in the Edit Permissions tab. In the Edit Permissions tab, I cannot even see who the owner is or take ownership!
* Even though myself and the Administrators group have full permissions, any program run as Administrator cannot view them under any circumstances!
* When UAC is disabled, the files are invisible under any circumstances!
* 64bit programs appear unable to view the files under any circumstances!
 


Mitchell_A

Essential Member
#23
So only browsers (and other apps?) make the files invisible?
Try executing the browser as an admin (not sure if you already tried, sorry if you have).
 


Mitchell_A

Essential Member
#24
and don't go spreading my sigpic around ;)
 


#25
Well, saving the file in the 32bit browser makes it invisible. Then the file can be read in any other 32bit program.
Running the same exact browser as admin makes the files invisible.
Running the same exact browser regularly but with UAC disabled makes the files invisible.
 


Mitchell_A

Essential Member
#26
Try running Internet Explorer 64 bit.
I actually just discovered it today.
 


#27
It acts like any other 64bit program and cannot see the files. 32bit IE works like any other 32bit program and can see them. This is so strange, I'm honestly leaning towards thinking this is a real bug in the OS. By the way, thanks Mitchell and Trouble for looking at all this with me. I'm new to this site, let me know if I can send you some Reps.
 


Mitchell_A

Essential Member
#28
Reps are always welcome, I;ll continue to search around for some solutions and test things out.
Cheers,
 


#30
I don't think this sounds exactly like my problem. I've never gotten the error message mentioned and this is about Offline Files, which I don't even run as a service.
 


Mitchell_A

Essential Member
#31
OK.
So let's just make sure we're still on the same page..
You can't copy files to %windir%/backgrounds and keep them visible, regardless of whether you run programs as admin compatiblity mode etc. But the files are visible when you copy them to the folder using explorer?
 


#32
Pretty much. I can't save files to %windir%/backgrounds from within a 32bit program and keep them visible. If I copy files to that folder from a 64bit program (like explorer) they are visible.
 


#33
Ashley, I am having EXACTLY the same problem and this was the only post I could find that was addressing the issue. I was using a firefox plugin (downThemAll) to download a list of links to a directory. Upon browsing to the directory in windows explorer the files were gone. I went back to firefox, clicked the "show in directory" option and it popped up (with the little lock icon). I've done all sorts of permissions changes, sharing changes, registry "cleans" and nothing seems to help.

Please post if you find a solution and Ill do the same.

btw, I have not been able to see them with any 32bit apps.... Not sure why.
 


#34
Have you tried disabling UAC or running firefox as administrator? In my case, the files were invisible even to the browser when I did that.. I still haven't figured out exactly what's happening.
 


reghakr

Essential Member
#35
I know you don't want to her this, but there are no super hidden files in Windows 7 if you use a special set of tools.
 


#36
.... what?
 


#37
I know this was on the first page,,, but anyone reading this thread let it be known that the following is Very BAD Advice.

Use this registry script to enable the right click option then open your root drive, right click on "windows" and select take ownership.
It doesn't matter if anyone has done this a 1000 times over,, at some point it is going to cause a problem.
.......

And yes, follow Drew's Instructions.

*******
After having read the thread, I am not convinced this is a windows specific issue.
This sounds like a Firefox issue with setting proper permissions on files in certain locations (ie. Windows Folder or C: drive or other Special Permissions folder). IE8 will not open a folder location, it will launch Explorer with that location.

There are other tests I would need to run if I get time, but for now, I am calling this an FF issue.

What version of FF are you using?
 


Last edited:
This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.