F8 DOES NOT OPEN SAFE MODE OPTIONS

#1
​Installed Win 7 Ultimate on a HP Pavilion g7 that was running Win 7 Pro. Everything runs fine, but for the f8 key. Regardless of when I depress the key during initial start-up, all I get is 9-10 loud beeps and normal start-up. I realize that, if all I were looking to do is use safe mode, I could access the function via command prompt. I want the button to do what it is supposed to do ... allow me to access the whole variety of start-up avenues.

Yeah, I know, a little ocd on my part ... I just like things to perform as required.

Hoping someone may have run into a similar situation and may know of a fix?

Any and all input would be greatly appreciated.

Thanks,
RDR66
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
#2
Sometimes on lappies you have what's called a 'F' lock on the keyboard or try pressing F5 instead.
 


#3
Sometimes on lappies you have what's called a 'F' lock on the keyboard or try pressing F5 instead.

Tried the f5, but same result. No f lock that I can find on the computer either. SHould I even be concerned about this or can I simply let it go? lol
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#4
Sometimes the bios seems to be involved in how the F keys work during boot. If there is a bios update, you might try that, but considering it is an OEM system the keys might be set up a little differently. I assume you did not use an anytime upgrade, but just loaded Windows 7 yourself?

One thing you might try is to open an administrative command prompt and use the followings commands. Report back what the results are.

reagentc /info

reagentc /disable

reagentc /enable


The result of the /info switch should look something like the following:

C:\Windows\system32>reagentc /info
Extended configuration for the Recovery Environment

Windows RE enabled: 1
Windows RE staged: 0
Setup enabled: 0
Custom Recovery Tool: 0
WinRE.WIM directory:
Recovery Environment: \\?\GLOBALROOT\device\harddisk0\partition2\Recovery\0e3be3ba-4362-11df-a0b5-d4924bc3
b0e2
BCD Id: 0e3be3ba-4362-11df-a0b5-d4924bc3b0e2
Setup Files:
Recovery Operation: 4
Operation Parameter:
Boot Key Scan Code 0x0
REAGENTC.EXE: Operation successful
 


#5
Thanks for the input! I'll check what you've suggested a little later today and I will let you know how I make out.
 


#6
Tried all that you suggested, including the bios update. No chage. I'm giving it a break as it does not seems to be disrupting anything. Thanks!
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top