For Anyone Using A Keyspan USA-19HS USB To Serial Adapter, Please

Robert11

Extraordinary Member
#1
Hello all,

I am running an HP Desktop Pavillion, about 3-4 yrs old, and Windows 7, the 64 bit version.

My problem relates to trying to get my Keyspan/Triplite USA-19HS USB To Serial Adapter working again.

I haven't used it for about a year, and am now trying to get it going again.

Have Downloaded what I am pretty sure is the correct Driver/installation package from their site.
Seems to install just fine, and the Keyspan Folder is under Programs (x86) where I imagine it should be.

Also, two of the actual Drivers, and two of the .dll also ended up in the System32 Folder.
Don't understand this, but I imagine it is correct.

Have Downloaded and re-installed, now, several times, both with and without the actual unit on the end of the cable.

No matter what I do, in Device Manager the Keyspan icon does show, but has the yellow "not-good"
mark also. Error msg when I click on it is that it cannot find, or open, the unit.

Also, essentially the same message appears in their "Serial Assistant" program to the effect that it cannot locate the unit (even if it is plugged into the cable).

Have spoken to two of the Keyspan technical support guys. Really nice, helpful, and apparently really
know the product, but haven't been able to offer anything much more than the re-tries.
The green LED on the unit never goes on.

So,

Since it seems like it is probably something I am doing wrong, as usual, (will blame it on old age), I am wondering if you folks might have anything specific to suggest that I can try ?
Or, thoughts on what I may be doing wrong ?
Or, ...?

BTW: I can't find the installation CD that came with the unit, so I downloaded the Driver/Installation download from their site. Do you think that perhaps the CD had something "more" on it that is essential ?

I'm totally out of ideas.

Much thanks,
Bob
 


#2
Have you tried using a different USB port with the cable? Preferably, a USB port directly attached to the mobo.
 


Robert11

Extraordinary Member
#3
Hi,
Thanks for help; much appreciated.

Yes, I tried several of the PC USB Ports.

Bob
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.