How do I stop Windows automatically installing drivers for new devices?

Discussion in 'Windows 7 Help and Support' started by Beagle, Mar 3, 2010.

  1. Beagle

    Beagle New Member

    Joined:
    Mar 3, 2010
    Messages:
    6
    Likes Received:
    0
    Hi all, this is my first post - hope someone can help!

    Since upgrading from XP I've been unable to get my wireless internet connection working. I've tried everything except try different drivers for my NIC.

    And this is my problem:

    Windows automatically downloaded and installed the latest driver for my Realtek 8185 card. I suspect this may be the cause of my problems so I want to try different drivers that I've downloaded from the Realtek website (there are several). But when I uninstall the device in 'device manager', and restart, Windows sees the new device and automatically installs this latest driver - it gives me no option to install a different driver.
    And if I try to install a new driver it just says that 'the driver is up to date'.

    How can stop this happening? Surely there must be a way to install your own drivers for hardware.

    Cheers!
     
  2. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321
    Hi and welcome onboard. :)

    When it says a new device has been found, can you close the new device wizard and then install the driver manually ?
     
  3. Beagle

    Beagle New Member

    Joined:
    Mar 3, 2010
    Messages:
    6
    Likes Received:
    0
    Thanks for your reply.

    I don't see a 'new device wizard'. It just finds the new hardware, which appears in the device manager list with a yellow triangle over it, then, a second later the triangle disappears as it installs the driver. I get no option to install a driver manually.
     
  4. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321
    Does the Realtek's driver has an installer, or is it a zipped folder? Can you extract the driver (with 7-zip) ?

    In the device manager, click on your Realtek card > Update driver > From this computer > Browse to the folder with the Realtek driver EXTRACTED,

    have you tried so, does this not work ?
     
  5. Beagle

    Beagle New Member

    Joined:
    Mar 3, 2010
    Messages:
    6
    Likes Received:
    0
    Success! :p

    I had to right-click on device and 'update driver' -> browse computer -> let me pick from a list -> select an different name for the device (this is what it was called under XP - Windows 7 insisted on loading it as something else which was causing the problem) -> have disk -> locate driver on desktop.

    The second driver I chose - which is not the newest one - works and I now (after 2 weeks of pulling my hair out) have a working wireless connection!

    Thanks for your help. :p
     
  6. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    If it should impose itself on you again, do this.
    Device manager.
    Right click you network adapter and and uninstall it.
    Right click again and select properties
    Open the "driver" tab and select "driver details."
    This will tell you which driver is causing the problem.
    It will probably be in System32. Go there and locate the file and rename it(JUst add a 1 to the end, you mat need it back!

    Now. To prevent it happening to any other device, and if you are satisfied everything is working correctly:
    In the Control Panel (icon view) select "System" and, over on the left "Advanced settings"
    Select the hardware tab.
    There you will find an option to automatically update drivers - or not Select "Let me choose."
     
  7. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321
    You are welcome and thanks for your feedback. :)
     
  8. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,852
    Likes Received:
    1,569
    Change the settings found in 'Windows update' to 'find updates but let me choose whether to download and install them'. This should stop the auto process..
     

Share This Page

Loading...