Windows 10 How does everyone like windows 10 so far?

Discussion in 'Windows 10 Help and Support' started by SimplyOreo, Jul 30, 2015.

  1. SimplyOreo

    SimplyOreo Member

    Joined:
    Jul 1, 2015
    Messages:
    49
    Likes Received:
    2
    I know that windows 10 just came out, but how is it going for everyone? Did you have trouble installing anything? I personally like it although I need to adjust to it as it is different from windows 8.1 which I upgraded from. If anyone is having trouble installing or getting windows 10, just ask me I know a few fixes for them. The graphics are awesome and the speed on it is insane and it is just so smooth. All I have to say is that microsoft did a good job on windows 10. Feel free to put your opinions in the comments about windows 10 so far.
     
  2. ussnorway

    ussnorway Windows Forum Team
    Staff Member Premium Supporter

    Joined:
    May 22, 2012
    Messages:
    2,530
    Likes Received:
    314
    I will have to un-install it from my laptop because I need hyper-v remote access for work but I'll keep it on my home sever (replaced w7) dispite the fact it crashed last night... tryed to grab updates while I was playing on SWkor.

    imo the iso install works well (i have 6 systems running X) with nothing too upsetting... very un-Microsoft like.
     
  3. TuoKenny

    TuoKenny Well-Known Member

    Joined:
    Nov 10, 2012
    Messages:
    5
    Likes Received:
    0
    I'm very disappointed! I downloaded 10 and installed it on my laptop as I'm about to take a trip on the Queen Mary II and didn't want to use up the very expensive, very slow internet by having the laptop try to d/l it enroute. Installation was quite easy, though it took a long time. Now, though, I have issues with the OS.

    First - WAY slow! Boot time under 8.1 was 2 minute 38 seconds. Under 10 - 7 minutes 18 seconds! Woah! And what is with the flashing icons on the desktop? Very weird. Very slow response opening programs, too. I mean VERY slow!

    Then there was the notification that the Avast firewall was turned off, and finding that I couldn't turn it on. I had to update Avast, then use uninstall to "repair" Avast, and boot twice to get it work properly.

    And what about Mail? I have it set to my Gmail account, but for two hours it just sat there saying "Working on it..." or some such. Useless, at least so far.

    This feels like a beta rather than an actual RTM version! I'll keep working with it, though, hoping things improve.
     
  4. TuoKenny

    TuoKenny Well-Known Member

    Joined:
    Nov 10, 2012
    Messages:
    5
    Likes Received:
    0
    Oh, one more thing. It was a bit tricky trying to set Google Chrome as my default browser. In the past all I had to do was click on the box that appeared when Chrome warned it wasn't the default. Now a separate window opens where you have to set the default.
    And just to make things interesting, Google Chrome kept displaying in Japanese, even though I made no changes to it. I guess MS really wants us to use "Edge."
     
  5. djpattyd14

    djpattyd14 Member

    Joined:
    Aug 6, 2015
    Messages:
    1
    Likes Received:
    0
    I installed w10 and had problems from the get go. I have a new HP pavilion laptop cost $700 so it's pretty fast. First, startup was really slow. Then I couldn't wake my HP from sleep had to force a shut down . My Auslogics boost speed took forever to load. Couldn't figure out how to set Bing as my home page in Edge. Didn't care for the interface in the taskbar with the tiny icons lacking color and distinction. Let me say I love w 8.1, the startup screen that everybody seems to hate I came to embrace. I'll cling to the past thank you.
     
  6. jason591

    jason591 Well-Known Member

    Joined:
    Jul 20, 2013
    Messages:
    5
    Likes Received:
    0
    Mines crashing all the time,,,nuff said :(
     
  7. Lan3wn3w

    Lan3wn3w New Member

    Joined:
    Aug 6, 2015
    Messages:
    1
    Likes Received:
    0
    Encountered an error after restarting from updating to windows 10 and then installing my hp printer. Wth?
     
  8. Sonny

    Sonny Fantastic Member

    Joined:
    Nov 17, 2009
    Messages:
    1,258
    Likes Received:
    93
    I did a clean install after upgrading and have not had any problems to speak of since. With the upgrade all my browsers were slow in loading after clean install all work good. I have four browsers. edge, google chrome, ie and waterfox. My boot time has went from 12 seconds in 8.1 to 7 seconds in win 10. I am not a game player so I cannot say anything about that. Liking Win 10 so far.
     
  9. alextop30

    alextop30 Honorable Member

    Joined:
    Apr 12, 2009
    Messages:
    16
    Likes Received:
    0
    I have two computers of mine updated! 1st one is my baby - my desktop and Windows is working just fine. It starts fast (ssd drive) also nice and pretty and all. I do not like that my start menu is kinna crap. I cannot pin or unpin different stuff it just does not do it. After restart it is either gone or something new showed up -- I just cannot win with the start menu. In any case cortana/desktop search is really useful I like to search for stuff instead of digging for them.

    Laptop -- Yoga 2 Pro --- update was a disaster. Lets just say nothing worked right. First after the install my keyboard was not working. Then it was the touchpad next was the screen, next was the backlight, after that was the software was freezing and malfunctioning, bluetooth and the accelerometer were not working. Finally I gave in and did a new install. The software stopped freezing, next I updated video, keyboard and mouse drivers manually from Lenovo's website and also turned off those devices going to sleep while in hibernation because they would not come back from sleep, turned off the option for windows controlling the backlight of the monitor and reinstalled my stuff. Now everything is working, fast boot, I do not know if it is because I have ssd in my computer but it is faster than Win8. I have gone 3 days without a single restart sooo so far so good knocking on wood.

    Also I had to go though the privacy settings and whip Windows into shape with what it is giving Microsoft. In any case I kept cortana and edge -- it is actually quite fast - have not tried it on adult content yet to be able to report on viruses :)

    Hope this helps the cats that have laptops!
     
  10. Macker

    Macker New Member

    Joined:
    Aug 5, 2015
    Messages:
    4
    Likes Received:
    0
    Love it - install wasn't without its issues with drivers, etc but that's kind of to be expected... Best OS to date.
     
  11. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,790
    Likes Received:
    1,563
    I did a clean install and apart from the odd occurrence all has been fine.
     
  12. 99taws6

    99taws6 New Member

    Joined:
    Aug 5, 2015
    Messages:
    4
    Likes Received:
    0
    If your boot time under 8.1 was over 2 mins and with 10 it's over 7 mins you might want to seriously do a backup of your data a do clean install of whatever OS you decide to keep. Neither of those times are anything I would be happy with unless I was sitting down watching my P4 boot 95 SR1 or something


    Sent from my iPhone using Tapatalk
     
  13. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    TuoKenny.
    Before this thread drifts from the title, I would suggest you post a new thread in the appropriate section, regarding your boot times. You have a unique problem there which the guys on this forum will sort for you - hopefully before your trip (I'm envious!)
     
    kemical likes this.
  14. strollin

    strollin Senior Member

    Joined:
    Jul 21, 2013
    Messages:
    286
    Likes Received:
    36
    I did the upgrade from Win 7 Pro to Win 10 Pro on an 8 year old netbook (1.6Ghz N270 Atom cpu with 1.5GB ram). I used the MediaCreationTool to create a thumb drive for the installer then did the upgrade with that as I never got the GWX app on the machine. The upgrade was without issue even though it took 2.5 hours.

    I haven't found any issues to date, seems to be running fine. I won't upgrade any of my other machines though because Win 10 just doesn't impress me enough for me to upgrade machines that are running fine with their current OS.
     

Share This Page

Loading...