How to share custom library with Homegroup?

Discussion in 'Windows 7 Help and Support' started by kd06, Sep 16, 2009.

  1. kd06

    kd06 New Member

    Joined:
    Sep 16, 2009
    Messages:
    4
    Likes Received:
    0
    Ok, all I want to do is share some files. I can access my documents, pictures, music, and videos just fine using my homegroup. But how do I share other folders? According to the help file:

    To share other libraries that you've created, follow these steps:
    1. Click the Start button [​IMG], and then click your user name.
      Select the library you want to share, and then, in the toolbar, click Share with.
      [​IMG]The Share with menu
    2. Select the people you want to share with.
    For information about keeping specific files and folders private, see Keep specific files and folders from being shared with a homegroup.


    I tried this. The Share menu only contains one option, Advanced Sharing... No where in there allows me to share with my homegroup. Where is the Share With Homegroup option?
     
    #1 kd06, Sep 16, 2009
    Last edited: Sep 16, 2009
  2. gavin19

    gavin19 New Member

    Joined:
    Aug 8, 2009
    Messages:
    442
    Likes Received:
    11
    I don't have another PC with W7 to compare but I created a Homegroup and then I could right-click on any folder and share it as if I was sharing the folder with another Windows box. Is that what you meant?
     
  3. kd06

    kd06 New Member

    Joined:
    Sep 16, 2009
    Messages:
    4
    Likes Received:
    0
    Not exactly

    Ok, have some new details:
    I have Windows 7 on my laptop and my desktop PC.
    On my laptop, if I right click on a folder in Explorer, and click Share With..., I get 4 choices: Nobody, Homegroup (read), Homegroup (read/write), and Specific People...

    On my desktop, if I right click on a folder, I get only one option: Advanced Sharing...

    There must be some setting that's different on the desktop PC, but I haven't been able to find it.
    I made sure the homegroup settings were the same. I tried leaving and re-joining the homegroup. Any ideas?
     
  4. Bruc3

    Bruc3 New Member

    Joined:
    Sep 30, 2009
    Messages:
    2
    Likes Received:
    0
    part of the answer

    I've been searching around for the same thing and i just found out what i was doing to create the issue. I normally go control panel > folder options > view tab and then uncheck "Use Sharing Wizard (Recommended)". If you turn that option back on, you are given the option that everyone is talking about. (the "share with" and then the 4 options of nobody, homegroup(read), homegroup(read/write), and specific people)

    It seems that you can only share out the library on homegroup if you have "Use Sharing Wizard (Recommended)" checked.


    If you right click on the library and you select properties you will see an "Attributes" section. The "Shared" option is grayed out no matter if you have "Use Sharing Wizard (Recommended)" enabled or not. But this Shared option is the only thing that changes when enabling or disabling the sharing on home group.

    You would think that Microsoft would allow this to be modified even if "Use Sharing Wizard (Recommended)" is disabled.
     
    #4 Bruc3, Sep 30, 2009
    Last edited: Sep 30, 2009

Share This Page

Loading...