HP PhotoSmart C5280 wont install Win 7 64 bit - USB

Discussion in 'Windows 7 Hardware' started by Nasho23, Feb 27, 2016.

  1. Nasho23

    Nasho23 Member

    Joined:
    Feb 27, 2016
    Messages:
    7
    Likes Received:
    3
    I am running Win 7 64bit Pro on GA-H170-HD3 Rev 1 MB (not DDR3) and i5-6600 Skylake CPU and 16 GB Ram, installed Feb 2 2016. This replaced GA-P45 MB and Quad 4 Intel CPU. The Win 7 64bit Pro OS was Cloned onto my SSD. System has been performing fine.
    I have a PhotoSmart C5280 All in One Printer, which was installed after that Hardware Upgrade and has worked OK until 24 Feb, when it started to do some strange things, which I was not able to correct, by changes to settings. In the end I decided to Uninstall the C5280 and perform a Reinstal, which I had done on a number of occasions previously, when it played up.
    Using the Latest HP Software and Driver from HP, the installation failed, with an Error that related to USB Drivers (This Computer does not have the necessary USB Software support to allow completion of USB Installation). I then opened Device Manager and the USB Element (HP PhotoSmart C5200 Series) shows in Device Manager, when the USB Cable is connected to the Printer, with a Coloured Warning. I checked Properties and selected Update Driver. Update Driver found the required Driver (HP PhotoSmart C5200 Series (DOT4USB) but encountered an Error and failed the Installation (The Extended Attributes are Inconsistent)
    I have had a Remote Session with HP; After doing all the things I had already done; They stated the problem has nothing to do with the Printer and it is related to my Computer Hardware.
    This supported by the fact that; The same Software and Driver successfully installed on our HP 650 Laptop running Win 10 64bit. Clean Install, No Issues.
    I have updated the BIOS, with latest from Gigabyte, with no improvement.
    I believe I have BIOS Settings set correctly; Legacy USB is Enabled. Cannot think of anything else.
    In the meantime I have a good Printer that is useless to me and not getting any real work done. Not game to buy another printer, being as it is a USB problem.
    I must mention, all other USB Devices that I use in the Rear USB Ports, do not have problems, Drivers Install and away we go.
    The only other issue I have is with the Front USB Ports, which I have not investigated as yet, but I do not that is connected to the Printer Problem; Its cable is in a Rear Port.

    Any Help would be most appreciated.

    Owen Carlton
     
  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,852
    Likes Received:
    1,569
    Hi,
    have you tried using a different USB port? What about the actual cable connecting the printer, do you have a replacement you could try with?
     
  3. Nasho23

    Nasho23 Member

    Joined:
    Feb 27, 2016
    Messages:
    7
    Likes Received:
    3
    Sorry, kemical, failed to include the fact that I had tried a brand New Cable, out of the Box, and it made no change; No further advanced.
    When the Cable is plugged in, I can hear its acceptance by the PC.
     
  4. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,852
    Likes Received:
    1,569
  5. BIGBEARJEDI

    BIGBEARJEDI Honorable Member
    Premium Supporter

    Joined:
    Jan 28, 2013
    Messages:
    1,805
    Likes Received:
    219
    Hi Nasho,
    Just so you know, that's a really old printer you have there (I sold hundreds of those), so it's not surprising it has problems with Win7 or newer Windows versions. Sometimes, it's just time to throw out the old stuff and get something new. That printer is maybe worth $5 or so, and you can buy a brand new one for about $20-$50. Your printer was an XP-era printer and was designed to run with obsolete XP software that is 15 years old. Computers don't even last that long, and you already upgraded the Mobo and guts. Why not trash that printer, and get something more modern that's more likely to work with modern version of Windows?

    <<<BIGBEARJEDI>>>
     
  6. holdum333

    holdum333 Banned

    Joined:
    Mar 27, 2016
    Messages:
    1,244
    Likes Received:
    147

Share This Page

Loading...