I messed up in regedit (posted this in software too)

soulmaster01

New Member
My exe file wasn't loading (WarFace launcher) , so I searched in online and found video , I went to regedit , then don't remember where , but I changed .exe ones default "value" to "%1"%* , but then this guy changed "exefile" s 1 file "open"'s default value to "%1"* , there were 2 files in it , he didn't change both of them , mine had "%1" %* in it , which is different (it has space in it) so I changed both of them to the one the video showed , but I changed second one too , so now I cant open exe file , intead I get "open with..." window. Someone please help me , it's my first time posting on forum too.
 
Last edited by a moderator:

Neemobeer

Windows Forum Team
Staff member
Editing the registry when you don't know what you're doing can have major consequences as you found out. The exe and exefile registry values control how every executable launches and would not impact only a single exe. For your initial issue I'd say it's a problem with the launcher. You wont be able to fix this issue while booted into Windows.

What you can do is boot to the recovery environment and then manually load the CLASSES registry hive and change the values back.

HKEY_ROOT_CLASSES is actually a mapping in to HKLM\Software\Classes, so you need to load C:\Windows\System32\config\SYSTEM
 

soulmaster01

New Member
Editing the registry when you don't know what you're doing can have major consequences as you found out. The exe and exefile registry values control how every executable launches and would not impact only a single exe. For your initial issue I'd say it's a problem with the launcher. You wont be able to fix this issue while booted into Windows.

What you can do is boot to the recovery environment and then manually load the CLASSES registry hive and change the values back.

HKEY_ROOT_CLASSES is actually a mapping in to HKLM\Software\Classes, so you need to load C:\Windows\System32\config\SYSTEM
How do I boot in recovery environment
 

soulmaster01

New Member
im doing that but it asks me to sign in my account. i changed oassword for it but it says its incorrect , guess it needs time
 
Top