I promise you cannot solve my wireless problem!

U

Unregistered

Guest
#21
You won't believe but I have the same freaking problem. Also with my other laptop but it fixed itself?!?
I'm sorry for the long post, but as the title promises, I'm betting no one out there can solve my problem (and re-installing vista is not a "solution" by my definition). I wanted to give you every little detail so you can understand and appreciate the extent of my situation.



I purchased a Latitude D620 with the Dell WLAN 1390 mini-card. It shipped about a year ago with XP Pro (and has the "Windows Vista Capable" sticker).

I then upgraded to Vista Business. This was a clean install - from the disc with a complete repartitioning of the hard drive. All my drivers are 100% up to date.


The Problem

I started losing my wireless randomly, getting the red X over the wireless icon in the system tray. This happens at different wifi locations - it is not unique to one location. I'll just be surfing the net and suddenly things cannot load, and I see the wireless has a red X in the system tray. I may also leave my computer (with working wireless) just sitting there for 5-10 minutes doing nothing, then come back to find the wireless gone and the red X in the system tray. What is interesting is that when this happens, i can single-left-click and choose the "connect to a network" option. It pulls up the window and says "Windows cannot find any networks." This is strange because in many of the places this happens (like at home), there are easily 10+ different networks available. So it's not dropping just my one connection, it is saying it cannot find ANY network. This also happens at school where there are access points galore and the ten people next to me on their laptop's wifi have no problem. If I leave the Red X and try to run diagnostics or check the driver in the device manager - everything always comes back that it is working properly even though it cannot find any of the 10+networks in range.

My unacceptable workaround:


There is the hard switch on the left of the D620 to kill power to the wifi card. Turning this off then on does nothing. It turns off the Wifi LED on the D620 above the keyboard, and then turns it back on. The system tray red X does not change. Only three things resolve this problem: a restart, going into standby and coming back out, or disabling then enabling the network card via the device manager.

I then upgraded to Vista Ultimate. This was just an upgrade, no re-install or re-partitioning. Exact same problem. Sometimes I go two or three days without the problem, sometimes I have it happen 3 times in 5 minutes. it is VERY annoying. I'll just be surfing the web and click a link and get "page cannot be displayed." I look down at the system tray and suddenly notice the red X popped up.

Failed Fix #1

On the first three calls to Dell they have connected to my computer and tweaked various wireless settings. They always make sure drivers are up to date (and they are). I have tried using my laptop with Dell Quickset installed, and with Dell Quickset UNinstalled - doesn't change a thing. Have even tried uninstalling the "correct" dell driver and letting Vista handle the wireless card by itself - doesn't change a thing. I have tweaked my power settings to about every possible combination (and this happens both on battery and when plugged in). Nothing worked.

Failed Fix #2

After a third service call I was sent a NEW 1390 WLAN mini-card. Even that did not change a thing.


Failed Fix #3

After the fourth call my laptop was sent in to have both the wireless card replaced as well as the antenna. Again, this did not solve the problem.

Failed Fix #4

After calling Dell again to say the antenna fix didn't change a thing, I was given some vague comment about maybe having problems with WLAN 1390 and vista (which I think is not true). So... they 'upgrade' me for free and send a Dell WLAN 1490 card in the mail. I pop that guy in... problem still persists.

Blame Vista:

So, of course, Dell now says that it must be a Vista problem, as they have replaced all the hardware related to the wireless card. Their solution: do a clean re-installation of vista. I could do this, but it is a total pain to have to back everything up and then re-tweak all the various windows and program settings all over again. I'm in school, finals are coming up, then I have some trips (where I need my laptop working). I don't have a full day to spend backing everything up and then re-installing vista and then re-personalizing everything... not to mention downloading every program I use like Firefox and re-installing every program I use like Microsoft Office.

Some Final Thoughts:

So this problem is across Vista Business, and Vista Ultimate. The card has been replaced and upgraded. The antenna has been replaced. The software/driver/power combinations have been changed around to every possible combination. Absolutely nothing has resolved this. As such, I have been unable to isolate the problem.

The other problem is that I have not found a way to automatically replicate the problem. I have been dealing with this at an annoying rate for months because i'll try something (like changing some software or a driver or the card) and I have to wait to see if the problem will reappear. I can't just change something and then immediately check to see if it solved the problem. the problem may show itself later that day, or maybe not for 2 or 3 days... only at that point can I determine that the fix didn't work.

I am more knowledgeable about computers than your average joe and can assure you that I have made sure there are no viruses, etc. causing this problem. I might also add that this happens on both secure and unsecured networks.

I am at a total loss at this point and have no idea what to do. Anyone have ideas? Anyone think this is or is not Vista?
 


R

raffygo

Guest
#22
I ran in to this problem as well when I was beta testing Vista and then when it was officially release. I called Microsoft and after 4hrs on the phone we came up with a fix. You have to edit the registry, so go to regedit.

HKey_Local_MachineSystemCurrentControlSetServicesTcpip

Highlight the Parameters folder and add a new Key.
The key has to be DWORD, name the Key ARPRetryCount, and set the value to 0.

That should get the machine connected to the domain and allow you to add all domain assets to your local security listings.

Greg

Hi Greg.

I'm trying to do what you are instructing to do. So my problem now is, after adding the key DWORD to the Parameters folder, what do you mean by "name the Key ARPRetryCount, and set the value to 0."?? Does this mean that I should create another key inside the DWORD key?

Thanks!
Raffy
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#23
Hi Raffy,
I took a screenshot to show you..
Basically right-click in the area where you see the dialogue boxes and choose new key followed by DWord. Now fill it out as suggested...
 


R

Raffy

Guest
#24
Hi Raffy,
I took a screenshot to show you..
Basically right-click in the area where you see the dialogue boxes and choose new key followed by DWord. Now fill it out as suggested...
hey kemical.

Thanks a lot for helping me with this.
 


#25
this is for all the vista home users
run this next line in a cmd prompt window (looks like a dos window) this has worked for me on numerous machines
net localgroup "Administrators" "NT Authority\Local Service" /add
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top