Icon stuck in the taskbar

#1
I have an icon (of an app i updated) in my taskbar that is stuck there and i can't remove it. If i rightclick it nothing happens, if i click it it says "This action is only valid for products that are currently installed". Does anyone have an idea about how i can get rid of it?
 


reghakr

Essential Member
#2
If you are familiar with the registry, go to Start > Run, and type Regedit.

Expand the HKEY_CURRENT_USER key and drill down to Microsoft > Windows > CurrentVersion > Explorer > Streams and delete the Settings entry

Now choose the StuckRects2 key and delete the Settings entry here as well.

You'll need to restart your computer.
 


#3
Problem is the Streams folder's empty, or rather there's only the (Default) key. I tried getting rid of the Settings key in the StuckRects2 folder but it didn't help. :confused:
 


reghakr

Essential Member
#4
In your first post you mentioned you "updated" the program.

So, is the program still installed but the icon doesn't work?

Could you take a screenshot and post it back here?
 


#5
Yes, that's what i've done. The program is Techsmith Jing, it was docked in the taskbar and when i loaded it it told me there was a new version available and asked me if i wanted to upgrade it. I did that and now i have two icons, one with the updated app and the old one with a generic windows file symbol (you know, the generic white page with some stuff in it that is there since what? Win 3.1?). Probably it installed the new one in another folder and got rid of the old one instead of updating it, but this left the old icon stuck there and does nothing, obviously, since the program ain't there anymore. I could post a screenshot, sure, do you mean a screenshot of the taskbar or of the registry?
 


reghakr

Essential Member
#6
Is this icon on the taskbar itself or the "notification" area, where your anti-virus, network, and volume icons are located?
 


#7
It's on the bar itself not in the tray, i added that icon manually when i installed the app.
 


reghakr

Essential Member
#8
I happened to run across this program while performing a 'Search'.

It's called "Problem Steps Recorder"

I tried it out and it captures every single mouse click and change that you make, it actually highlights certain areas of text as well. You can e-mail, annotate, etc. Clicking on help brought up a detailed help file on the program.

You can automatically capture the steps you take on a computer, including a text description of where you clicked and a picture of the screen during each click.

It outputs a .zip file on the desktop which extracts a .mht file which opens in your browser. This contains all the captured images a poster may take to provide a 'recording' of the exact steps the poster took to reproduce an error. These files can than be reviewed by the regular members of the forum.

You can access it by going to Start > Run, and type 'psr'

Please upload the .zip file by adding it as an attachment.
 


#9
Any update on this? I have an icon for smartftp that I cannot get rid of with the exact same error message if you try to click it. Happened after I did an upgrade. Just as the original poster nothing in the referenced place in the registry.
 


#10
I, too, am having this problem and would like to know how to fix it. The above mentioned fix did nothing for me as well.
Mine happened upon right-clicking the iTunes icon to pin it to the taskbar. Another icon appeared and whenever I click on it I get the same message. I now, unfortunately, have 3 dormant iTunes icons on my taskbar. Very annoying. x_x
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top