[Install] Windows 7 - No Device Drivers Found

Discussion in 'Windows 7 Installation' started by msam, Feb 3, 2011.

  1. msam

    msam New Member

    Feb 3, 2011
    Likes Received:
    First post :p

    I have read many posts on this issues, in this forum and others, and no solution worked. So I'm giving it a shot at explaining my situation.

    I'm trying to create a dua boot with win7 and ubuntu. I want to install win7 first and then the other os.

    So, using Gparted, if I create a partition, formatted or not, win7 setup will not recognize my hdd and i get the above error message. "No device drivers found".

    If I set my hdd space as unallocated, it gets recognized, but setup tells me it's unable to install windows into any of the drives. No further information is delivered.

    The thing is I can easily install ubuntu and set it up. So there's nothing wrong with my hdd. Why would windows not recognize it and request for the drivers? I went to the Hitachi website, but they tell me there are no drivers available, since all OSs already have that information.

    I wonder why I'm having such a hard time installing win7. Ubuntu clearly works and installs smoothly and no errors occur.

    More info:

    - Installing Windows 7 Ultimate 64bit
    - hdd (500gb) is empty, expect for one OEM recovery partition (12gb)
    - i'm a newbie at this, hence all these issues

    Thank you so much! :D
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Oct 16, 2009
    Likes Received:
    If you have G-Parted, can you attach a picture of the drive and its partitions? How many total drives do you have?

    Perhaps Win 7 is trying to install on the smaller partition. Have you used Win 7 to partition the drive for just its install?

Share This Page