KTPWare touchpad and windows7

Hello, I have a laptop with Elantech touchpad (not synaptics!) and windows7.
I tryed installing some version of KTPWare driver in order to get my tap to click disabled, and now windows doesn't recognise that I even have a touchpad. I don't see it in the device menager and I don't see it in mouse control panel.

Any ideas how to get back my touchpad?

Or probably any link for elantech touchpad drivers for windows7?


Excellent Member
Microsoft Community Contributor
In device manager, see if it was moved to another section, or shows any unknown devices. Click and allow Device Manager to show hidden devices, maybe it would be there. Try scanning for new hardware in Device Manager.

Otherwise, I think I would get rid of the software that seems to have caused the problem, reboot and rescan if necessary.

Ok, I did what you suggested, the device came up when I selected show hidden devices.
I tryed uninstalling and reinstalling and uninstalling everything connected to it but the result was still the same:

This device is not present, is not working properly, or does not have all its drivers installed. (Code 24)
When I click on update drivers it says that windows has decided that I already have the best drivers available and discovers it as Microsoft PS/2 Mouse.

And now that I think of it, I always had a normal mouse connected so actually I can not be sure whether installing a program caused the problem, or if it had never worked at all, since I installed the OS about a week ago.

The model of the laptop is MSI M655X-EU632 if someone needs this information.
Also I am using Windows 7 Ultimate Edition 32bit.

Last edited:
Anyone else has any ideas on how to solve this?


Excellent Member
Microsoft Community Contributor
If you see the device, uninstall it and let Windows find it again.

I installed a clean windows XP installation and the problem was still there.
I removed the USB mouse, and the battery and the charger. And reinserted them. After that the mouse pad seemed to work. I guess there was some technical malfunction in the mouse pad itself that needed a power reset. Unfortunately I no longer have windows 7 installed to test if the drivers I had found worked properly for the touchpad :(

The other problem I had was with games making my network connection lag as hell, and since I prefer playing games I removed the win7. I guess I will try it again when I get a better pc.

Thank you for the help and have a good day to everyone.

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.